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บทที่ 1 
แนะนําโปรแกรม Blender 

 
สําหรับบทนี้เราจะไดรูจักกับโปรแกรม Blender ซึ่งเปนโปรแกรมสําหรับสรางงาน 3 มิติที่เปดใหผูใชสามารถ

ดาวนโหลดมาใชงานไดฟรี โดยที่ความสามารถของโปรแกรมนั้น ถือวาเทียบเทากับโปรแกรมสรางงาน 3D ทั่วไป โปรแกรม 

Blender ยังมีการทํางานที่ไมซับซอนและมีเครื่องมือที่ใชงานงาย ที่สําคัญเราไมตองเสียคาใชจายราคาแพงสําหรับการซื้อ

โปรแกรม จึงเหมาะกับผูเริ่มตนที่สนใจและตองการฝกฝนทักษะดานนี้มากทีเดียว 
 

รูจักกับโปรแกรม Blender 

 
 
    หนาตางทํางานของโปรแกรม Blender 
 
  โปรแกรม Blender เปนโปรแกรมสรางงาน 3 มิติที่มีความสามารถในการสรางโมเดลรูปทรงตางๆ ทั้งยังกําหนด

พื้นผิวหรือลวดลายใหกับวัตถุได สามารถจัดแสง กําหนดมุมมอง สรางชิ้นงานใหเปนแอนิเมชั่น พรอมทั้งใสเอ็ฟเฟกตสราง

ความเหมือนจริงและชวนติดตาม จนกระทั่งประมวลผลงานทั้งหมดออกมาเปนงาน 3 มิติที่สมบูรณแบบ นอกจากนั้น ยัง

เปนโปรแกรมที่รองรับการสรางเกม เนื่องจากมีเครื่องมือที่ชวยในการทําโมเดลสําหรับเกมและการทํางานอื่นๆ ที่เกี่ยวกับ

เกม 
 

จุดเดนของโปรแกรม Blender 
  โปรแกรม Blender เปนโปรแกรม Open Source ที่สามารถดาวนโหลดมาใชงานไดฟร ีและยังมีความสามารถ

ทัดเทียมกับโปรแกรมสรางงาน 3 มิติโปรแกรมอื่นๆ โดยจุดเดนที่นาสนใจของโปรแกรม Blender มีดังนี้ 
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 เปนโปรแกรมที่ใชทรัพยากรระบบและพื้นที่ในการติดตั้งโปรแกรมนอย 

 มีความสามารถในการสรางงานไดหลายรูปแบบ เชน การสรางการตูนแอนิเมชั่น งานดีไซน งาน

สถาปตยกรรมและตกแตงภายใน การสรางสเปเชียลเอ็ฟเฟกต และการสรางเกม เปนตน  

 ทํางานไดหลายแพลตฟอรม เชน Windows, Mac, Linux และอื่นๆ 

 เปนโปรแกรมที่มีกลุมผูใชงานมากกวา 250,000 คนทั่วโลก รวมทั้งมีกลุมศิลปนที่นิยมใช Blender และ

เปดเว็บไซตใหความรูพรอมเว็บบอรดใหสอบถามปญหาเกี่ยวกับการใชงานไดตลอดเวลา เชน 
www.blender.org, www.blendernation.com, http://blenderartists.org, http://3d‐
synthesis.com เปนตน 

  โปรแกรม Blender สามารถใชเปนโปรแกรมพื้นฐานสําหรับผูที่ตองการศึกษาการสรางงาน 3 มิต ิรวมทั้งบริษัท

ขนาดเล็กและขนาดกลาง ก็สามารถนําโปรแกรมไปใชสรางชิ้นงานตามวัตถุประสงคของบริษัทไดเชนกัน เนื่องจากไมตอง

จายงบประมาณในการซื้อโปรแกรมมาใชนั่นเอง  
 

ผลงานจากโปรแกรม Blender  
  ดังที่กลาวไปแลววาโปรแกรม Blender มีความสามารถสรางงาน 3D ไดอยางครบถวน ดังนั้นชิ้นงานที่ออกมา

จึงมีความสวยงามและสรางสรรคไดไมแพโปรแกรมสรางงาน 3D อื่นๆ ดังผลงานตัวอยางเหลานี้  

 การสรางเกมสของ Gingerbloke 

 การสรางสเปเชียลเอ็ฟเฟกตของ DarkWolf 

  ผลงานดานโปรดักสดีไซนของ Sacred 
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ความตองการระบบคอมพิวเตอรโปรแกรม  
  โปรแกรม Blender ถูกพัฒนาใหทํางานไดดีมากขึ้น มีความยืดหยุนของหนาตางการทํางาน (GUI หรือ 

Graphic User Interface) สูง และมีขนาดเบา ดังนั้นความตองการระบบสําหรับคอมพิวเตอรจึงไมสูงมากนัก ซึ่งนี้เปน

ขอดีของ Blender 
 

ระบบคอมพิวเตอร รายละเอียด 
ระบบปฏิบตัิการ 
 
ความเร็วซีพีย ู
แรม 
พ้ืนที่สาํหรับลงโปรแกรม 
การดแสดงผล 
ระบบและอุปกรณอ่ืนๆ 

Windows 2000, XP, Vista / Mac OS X 10.3+, Python 2.3 Suits PowerMac 
G5, Powerbook G4, iMac G5 / Linux glibc 2.3.6, includes FFMPG Suits 
700 MHz หรือสูงกวา 
512 MB  
27 MB 
1024x768 16-bit color แรม 8 MB (แนะนําใหรองรับมาตรฐาน OpenGL) 
เมาสแบบ 3 ปุม 
 

 
 

วิธีการนาํโปรแกรม Blender มาใชงาน 
  สําหรับการนําโปรแกรม Blender มาใชงานนั้น เราสามารถเขาไปดาวนโหลดไดฟรีที่เว็บไซต 
www.blender.org 
 

 
 

ดาวนโหลดโปรแกรม Blender มาใชฟรไีดที่เว็บไซต www.blender.org 
 

Page 5



  เมื่อเขาไปที่หนาแรกของเว็บไซตแลว ใหดาวนโหลดโปรแกรมดังขั้นตอนตอไปนี้ 

  1. คลิกที่หัวขอ Download ดานบน 

  2. เลือกดาวนโหลดโปรแกรมตามระบบที่เราใช ในตัวอยางเลือก Windows 32 bits โดยคลิกที่ไอคอน 

Installer ของโปรแกรม  

  3. เว็บไซตจะแสดงหนาตาง File Download ขึน้มา ใหเราคลิกปุม Save เพื่อจัดเก็บโปรแกรมมาไวที่เครื่อง

คอมพิวเตอรของเรา  

  4. จากนั้นจะแสดงหนาตาง Save As ใหเราระบุโฟลเดอรที่ตองการเก็บไฟลสําหรับติดตั้งโปรแกรมไว แลวคลิก

ปุม  Save 

  5. รอสักครู โปรแกรมจะถูกดาวนโหลดเขามาเก็บไวในเครื่องคอมพิวเตอรของเรา  

  และเมื่อเสร็จแลวเราจะไดโปรแกรม Blender สําหรับใชงานฟรีที่เหมาะกับระบบปฏิบัติการของเรา 
 
 1. คลิกหัวขอ Download 

 
 
2. คลิกที่ไอคอน Installer ของโปรแกรม               3. คลิกปุม Save 
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4. ระบุโฟลเดอรสาํหรับเก็บไฟลสําหรับติดตั้งโปรแกรม แลวคลกิปุม Save              5. โปรแกรมจะถกูดาวนโหลดมาไวในเครื่องของเรา 
 

  เมื่อดาวนโหลดจนเสร็จ

ครบ 100% แลว ตัวติดตั้ง

โปรแกรมจะแสดงอยูในโฟลเดอร

ที่เรากําหนดไว 

 
 

 
 
 
 
 
 
 

วิธีการติดต้ังโปรแกรม Blender 
  เมื่อเราไดดาวนโหลดโปรแกรม Blender เขามาในเครื่องคอมพิวเตอรของเราแลว ใหเริ่มตนการติดตั้งโปรแกรม

โดยดับเบิ้ลคลิกที่ไอคอน      

  1. ดับเบ้ิลคลิกที่ไฟลสําหรับติดตั้งโปรแกรม (ไฟล blender-2.48a-windows.exe) 
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5. โปรแกรมจะแสดงเสนทางโฟลเดอรหรือ Path 
สําหรับติดตั้งโปรแกรม ใหเราเลือก Path เดิม แลวคลิก
ปุม Next เพื่อเขาสูขั้นตอนถัดไป 

2. คลิกปุม Next เพื่อเขาสูการติดตั้งโปรแกรม 3. คลิกปุม I Accept เพื่อตอบรับเงื่อนไขของ โปรแกรม

4. สามารถเลือกใหโปรแกรมสรางไอคอน                     
สําหรับเขาสูโปรแกรมอยางรวดเรว็ที่เดสกท็อป 
และทาสกบารก็ได แลวคลิกปุม Next 

6. คลิกปุม Next เพื่อติดตั้งโปรแกรม 7. รอสักครูเพื่อใหโปรแกรมทําการติดตั้ง 
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  เมื่อโปรแกรม Blender ถูกเรียกใหเปดขึ้นมา จะมีลักษณะหนาตาโปรแกรมดังภาพ และจะมีหนาตางยอยสีดํา

เปดคูกับหนาตางการทํางานขึ้นมาดวยเสมอ ซึ่งถาเราปดหนาตางใดหนาตางหนึ่ง ก็จะเปนการสั่งใหออกจากโปรแกรม 

Blender ทันที 

 

 

8. เม่ือลงโปรแกรมเสร็จแลวใหคลิกปุม Finish และ
ถาเราคลิกเลือกในชอง Run Blender 2.48a (ตัวเลข
แสดงเวอรชั่นของโปรแกรม) จะเปนการสั่งให Run 
หรือเปดโปรแกรม Blender ขึ้นมาทันท ี

เม่ือเปดโปรแกรม Blender จะแสดง 2 หนาตางคูกนั 
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บทที่ 2 
ทํางานบนโปรแกรม Blender 

สําหรับบทนี้เราจะไดรูจักกับหนาตาของโปรแกรม Blender รวมทั้งหนาที่การทํางานของเครื่องมือแตละสวน 

พรอมทั้งเรียนรูเกี่ยวกับการทํางานกับระบบไฟล เชน เปดไฟล บันทึกไฟล ฯลฯ เพื่อเปนพื้นฐานในการทํางานกับโปรแกรม 

Blender ในบทตอๆ ไป  
 

รูจักหนาตางการทาํงานของโปรแกรม Blender 
สําหรับหนาตางการทํางานของโปรแกรม Blender นั้น จะมีสวนประกอบหลักที่สําคัญ 3 สวนดวยกัน คือ 

  สวนที่ 1: Information Window หรือ Main Window จะประกอบดวยเมนูหลักที่เก็บคําส่ังตางๆ 

สําหรับใชในการทํางานในโปรแกรม Blender 

  สวนที่ 2: 3D Window หรือ Viewport เปนสวนที่แสดงผลวัตถุที่เราทํางานอยู โดยอางอิงตามแกน 

X Y และ Z ผูใชสามารถจัดการกับมุมมองตางๆ ได เชน เล่ือนมุมมอง ขยายมุมมองเขาออก เพื่อชวยปรับแตงมุมมองให

ทํางานไดงายขึ้น 

  สวนที่ 3: Buttons Window เปนสวนที่เก็บรวบรวมเครื่องมือในการสรางงานไว เชน การปรับแตง

แกไขรูปทรงวัตถุ การใสลวดลายใหกับวัตถุ การกําหนดแสงไฟ เปนตน  

  โดยทั้ง 3 สวนดังกลาว ยังมีสวนประกอบยอยๆ สําหรับทํางานในรายละเอียดทั้งหมด ดังนี้ 
 
 
 
 

 

สวนที ่1: Information Window หรือ Main Window สวนที ่2: 3D Window หรือ Viewport 

สวนที ่3: Buttons Window 
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สวนที ่1: Information Window หรือ Main Window 
 

 
เปนสวนของเมนูหลักที่ประกอบดวยคําส่ังตางๆ สําหรับใชในการทํางานในโปรแกรม Blender ไดแก  

File    สําหรับทํางานกับไฟลงานในรูปแบบตางๆ 

  Add    สําหรับเพิ่มหรือสรางวัตถุในงาน 3 มิต ิ

  Timeline   สําหรับใชสรางการเคลื่อนไหว 

  Game    สําหรับใชสรางเกมและการทํางานของเกม 

  Render   สําหรับควบคุมการประมวลผลชิ้นงานหรือที่เรียกวา “เรนเดอร” 

  Help    รวบรวมวิธีการใชงานโปรแกรม การใชงานคียลัดตางๆ เปนตน  

โดยนอกเหนือจากคําส่ังเหลานี้ Information Window ยังมีสวนประกอบอื่นๆ อีก ดังนี้ 
 

Screen Selector    
สวนของ Screen Selector จะเปนโหมดที่แสดงรูปแบบของหนาตางในการทํางาน ซึ่งเปนรูปแบบสําเร็จรูปที่

โปรแกรมจัดเตรียมไวใหเลือกใช โดยเราจะใชเลือกใหเหมาะสมกับการทํางานเพื่ออํานวยความสะดวกเทานั้น นอกจากนั้น

ยังสามารถปรับแตง เพิ่มเติม แกไขหรือสรางรูปแบบใหมเองก็ได 

ดังตัวอยาง เมื่อเราคลิกปุม  ที่ Screen Selector โปรแกรมจะแสดงปอบอัพใหเราเลือกรูปแบบของหนาตางการ

ทํางาน เชน ถาเราคลิกเลือก 1‐Animation โปรแกรมก็จะจัดหนาจอใหเหมาะกับสรางการเคลื่อนไหว และถาเราคลิก

เลือก 2‐Model โปรแกรมจะจัดหนาจอใหเหมาะกับการสรางโมเดลนั่นเอง  
 
 

 

 
 

 หนาจอสรางการเคลื่อนไหว 

1.คลิกปุม  2. คลิกเลือก 1-Animation เพื่อเรียกรูปแบบ

Page 11



Scene Selector    
สวนของ Scene Selector ใชสําหรับเลือกซีน (Scene) หรือฉากที่เราตองการทํางาน เนื่องจากในไฟลชิ้นงาน

หนึ่งๆ อาจมีไดหลายซีนเพื่อความสะดวกในการนําชิ้นงานมาทํางานรวมกัน  

โดยเราสามารถที่จะเพิ่มซีนไดโดยการคลิกปุม  ที่ Scene Selector แลวเลือก Add new จากปอบอัพ จากนั้น

เลือกชนิดของซีนที่ตองการสรางใหม เชน ถาเราเลือก Empty ก็จะปรากฏซีนใหมที่วางเปลาขึ้นมา เปนตน 
 
 
 

 
 

 หลังจากเลือก Empty จะปรากฏซีนใหมที่วางเปลา 
 

สวนตัวเลือกที่เหลือในปอบอัพนั้น ใชสําหรับเพิ่มซีนในรูปแบบที่ตางกัน ดังนี้ 

Link Objects   สรางซีนใหมที่ใหวัตถุเหมือนกับซีนที่กําลังทํางาน 

  Link ObData   สรางซีนใหมที่พื้นผิววัตถุเหมือนกับซีนที่กําลังทํางาน 

  Full Copy   สรางซีนใหมที่เหมือนกับซีนที่กําลังทํางานทุกประการ 

การสลับหนาจอทํางานของแตละซีนนั้น สามารถคลิกเลือกซีนไดที่ปุม  ที่ชอง Scene Selector แลวเลือกชื่อซีน

ที่ตองการทํางาน โดยซีนทั้งหมดนี้จะถูกเก็บอยูในไฟลเดียวกันทั้งหมด 
 
 
 

 
 

คลิกปุม  > Scene Selector > Add new > เลือกรูปแบบซีนท่ีตองการสรางหนาตางสําหรับสรางแอนิเมชัน่ 

คลิกเมาสซายที่ชอง SCE เพื่อเลือกซีนสําหรับทํางาน 
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Information   
สวนของ Information เปนสวนที่แสดงรายละเอียดการทํางานในซีน ซึ่งคาตางๆ ที่เราเห็นอยูนั้นจะแสดงตาม

การทํางานของเราขณะนั้น ดังนี้ 

Ve: จํานวนจุด (Vertex) ที่มีในวิวพอรต ดังตัวอยางมีคา Ve:8 หมายความวามีจุด Vertex ที่เปนสวนประกอบ

ของวัตถุในวิวพอรตอยู 8 จุด และถามีการเขียนคาเปน Ve:4‐8 จะหมายความวาในวิวพอรตนั้นมีวัตถุที่มีจุดเปน

สวนประกอบทั้งหมด 8 จุด และกําลังถูกเลือกอยู 4 จุด 

Fa: จํานวนพื้นผิว (Face) ที่มีในวิวพอรต ดังตัวอยางมีคา Fa:6 หมายความวามีพื้นผิวที่เปนสวนประกอบของ

วัตถุในวิวพอรตอยู 6 พื้นผิว และถามีการเขียนคาเปน Fa:4‐8 จะหมายความวาในวิวพอรตนั้นมีวัตถุที่มีพื้นผิวเปน

สวนประกอบทั้งหมด 8 พื้นผิวและกําลังถูกเลือกอยู 4 พื้นผิว 

Ob: จํานวนวัตถุที่มีในวิวพอรต ดังตัวอยางมีคา Ob:3‐1 หมายความวาในวิวพอรต นั้นมีวัตถุทั้งหมด 3 ชิ้นและ

กําลังถูกเลือกอยู 1 ชิ้น 

La: จํานวนของแสงที่มีในวิวพอรต ดังตัวอยางมีคา La:1 หมายความวาในวิวพอรต นั้นมีแสงอยู 1 ดวง 
 

  
  สําหรับสวน User Preference จะเปนสวนที่ถูกซอนอยู โดยการเปดใชงานนั้น เราจะตองคลิกเมาส

ซายคางไวที่บริเวณขอบใต Information Window และลากเมาสลงมาเพื่อให User Preference ปรากฏ 
 
 
 

 
 
 

คลิกเมาสซายคางไว แลวลากเมาสเพื่อเรียก User Preference ใหแสดงออกมา 
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โดยสวน User Preference นี้ใชกําหนดคุณสมบัติการใชงานของผูใช หรือเปนการตั้งคาใหกับโปรแกรมเพื่อให

เหมาะกับความถนัดของแตละคน ประกอบดวยการตั้งคาทั้งหมด 7 หมวดไดแก 
 

1. View & Controls จะเปนสวนของการกําหนดคาใหกับการใชเมาส รวมทั้งวิวพอรตหรือพื้นที่การ

ทํางานและการแสดงขอมูลตางๆ  

 
   
เมื่อเราเล่ือนเมาสไปช้ียังปุมใดๆ ก็จะขึ้นขอความ Tool Tips ขึ้นมาอธิบายความหมายของปุมนั้นๆ ซึง่ 

Tool Tips นี้จะปรากฏเมื่อเราคลิกเลือกปุม  ที่สวนของ Display กอน 
 
 
 
 
 
 
 
 

 
 

สวนของ User Preference จะแสดงออกมา 
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2. Edit Methods เปนสวนที่ผูใชสามารถกําหนดคาเกี่ยวกับการสรางชิ้นงาน เชนการกําหนดพื้นผิววัตถุ การ

ยอนกลับคําส่ัง การกําหนดการบันทึกการเคลื่อนไหวอัตโนมัติ หรือการสําเนาวัตถุ 

 
 

3. Language & Font จะเปนสวนที่ใหผูใชเลือกรูปแบบตัวอักษร ขนาด และภาษาที่ใชแสดงในการใชงาน

โปรแกรมได  

 
 

4. Themes เปนสวนที่ผูใชสามารถกําหนดลักษณะของหนาตางในโปรแกรม Blender เชน ถาเลือกแบบ 

Rounded ปุมตางๆ จะมีลักษณะโคงที่มุมและสีก็เปล่ียนไปดวย ซึ่งหากตองการกลับไปใชคาตั้งตนใหเลือกที่ Default  
 
 
 

 
 
 
 
 
 
 
 
 
 

คลิกเพื่อเลือก Themes ที่ตองการ 
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5. Auto Save การเลือก Auto Save โปรแกรมจะบันทึกไฟลที่เราทํางานอยูเปนระยะใหอัตโนมัติ ซึ่งจะปองกัน

การสูญเสียของไฟลจากอุบัติเหต ุเชน ไฟดับได 

 
 
 
 
 
 
 
 
 
 
 

เม่ือทดลองคลิกเลือกแบบ Rounded หนาตางภายในโปรแกรมจะเปลี่ยนไป 
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6. System & OpenGL เปนการกําหนดการแสดงผลภาพและเสียงใหเหมาะสมกับอุปกรณของคอมพิวเตอร

ของเรา เชน การดแสดงภาพและเสียง สวน OpenGL เปนการแสดงผล 3 มิติที่มีประสิทธิภาพมากขึ้น แตการดแสดงภาพ

ของเราตองรองรับคุณสมบัตินี้ดวย 

 
 

7. File Paths เปนการกําหนดตําแหนงของโฟลเดอรที่จะใหโปรแกรมเก็บไฟลประเภทตางๆ เชน ลวดลายวัตถุ 

ปล๊ักอิน ซึ่งควรใชคาตั้งตนที่โปรแกรมใหมาเพื่อการจดจําที่งาย 

 
 

หลังจากตั้งคาตางๆ แลว และเมื่อตองการเก็บ User Preference ใหเราคลิกที่บริเวณขอบแลวลากขึ้นไปจนสุด

แลวปลอย User Preference ก็จะถูกซอนดังเดิม 
 
 
 

 
 
 

คลิกเมาสซายลากหนาตาง User Preference ขึ้นไป 
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สวนที่ 2: 3D Window หรือวิวพอรต 
ในสวนนี้เปนสวนสําคัญที่เราใชสรางชิ้นงาน ทั้งการสรางโมเดล การทําแอนิเมชั่น การใสพื้นผิว และการทํางาน

ทุกๆ อยาง โดยมากเราจะเรียกพื้นที่การทํางานนี้อีกอยางวา “วิวพอรต” โดยในวิวพอรตนี้สามารถควบคุมการแสดง

ชิ้นงานไดหลายรูปแบบ และยังสามารถใชปุมคําส่ังในดานลางสําหรับชวยในการปรับมุมมองและสรางชิ้นงานได ซึ่งเราจะ

กลาวถึงรายละเอียดในหัวขอตอไป 

 
 
 
 

สวนท่ี 3: Buttons Window 
สวน Buttons Window จะรวบรวมเครื่องมือสําหรับการทํางานไว โดยอางอิงกับวัตถุที่เราเลือกขณะนั้น เชน 

ถาเราเลือกทํางานกับพื้นผิว กลุมเครื่องมือสําหรับสรางพื้นผิวก็จะปรากฏ แตถาเราเลือกทํางานกับการกําหนดแสง กลุม

เครื่องมือสําหรับการจัดแสดงก็จะปรากฏขึ้นมา เปนตน 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

สวน 3D Window หรือวิวพอรตสาํหรับสรางชิน้งาน 

สวน Buttons Window ที่รวบรวมเครื่องมือสําหรับการทํางาน 
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หนาตางแตละสวนนั้นจะมีสวนรวบรวมคําส่ัง เรียกสวนนี้วา “Header” ซึ่งเราสามารถกําหนดไดวาจะให 

Header อยูที่ตําแหนงบน ลาง หรือไมแสดง Header ดวยการคลิกเมาสขวาที่ Header และเลือกตัวเลือกที่ตองการ 

หากเราเลือก NoHeader ก็จะเปนการกําหนดให Header นั้นหายไป และเราสามารถเรียกคืนไดดวยการคลิกเมาส

ขวาที่ขอบและเลือก Add Header เพื่อนํา Header กลับมาแสดงอีกครั้ง 
 

 
 
 
 

นอกจากนั้น เรายังสามารถเปลี่ยนหนาตางสําหรับทํางานไดอยางรวดเร็ว โดยเลือกจาก Windows Type 

ที่บริเวณปุมดานซายของแตละ Header แลวคลิกเลือกหนาตางที่ตองการแสดง เชน หนาตาง Timeline ก็จะแสดง

หนาตางสําหรับควบคุมการเคลื่อนไหวหรือสรางงานแอนิเมชั่นขึ้นมา เปนตน 

 
 
 
 

หนาตางสําหรับการสรางความเคลื่อนไหว (Timeline) 
จะแสดงออกมา 

Header                                                                    คลิกเมาสขวาเพื่อทําการเปลี่ยนตําแหนง Header 

เลือกเปดหนาตางใดๆ ตามตองการ (ในตัวอยางเลอืก Timeline) 

Page 19



ทํางานกับ 3D Window หรือววิพอรต 
เราสามารถปรับแตงวิวพอรตไดหลายรูปแบบ เพื่อรองรับการทํางานไดดีขึ้น เชน ปรับให 1 จอภาพใหญนั้นมี

หลายหนาจอยอยได เปล่ียนมุมมองใหกับแตละจอภาพยอ โดยวิธีการปรับแตงวิวพอรตที่นาสนใจและใชบอยมีดังนี้  
 

แยกวิวพอรตเปนหลายจอภาพ 
การทํางานในวิวพอรตนี้ เราสามารถแยกหนาตางออกจากกันไดอยางอิสระ ซึ่งสามารถทําแบงออกเปนหลาย

จอภาพยอยและสามารถแบงไดทั้งแนวนอนและแนวตั้ง โดยในตัวอยางนี้เราจะแนะนําวิธีการแบงหนาจอแนวตั้งกอน แลว

จึงแบงหนาจอแนวนอนภายหลัง ดังนี้ 

 
 
  1. เล่ือนเมาสมาวางที่ขอบหนาตางดานบน ใหเห็นเปนสัญลักษณหัวลูกศร 2 หัว  

  2. คลิกเมาสขวาแลวเลือกที่ Split Area จะเห็นเสนแบงหนาจอปรากฏขึ้นมาเพื่อใหเราเลือกตําแหนงการแบง

หนาจอไดในแนวตั้ง  

  3. เล่ือนเสนแนวตั้งที่ปรากฏ แลววางเสนแบงตรงจุดที่ตองการดวยการคลิกเมาสซาย จากนั้นหนาตางจะแยก

จากกันในแนวตั้งออกเปน 2 จอภาพ  

  4. เราจะทดลองแบงหนาจอในแนวนอนบาง โดยเลื่อนเมาสมาวางที่ขอบหนาตางดานซาย ใหเห็นเปน

สัญลักษณหัวลูกศร 2 หัว แลวคลิกเมาสขวา เลือกที่ Split Area 

  5. เล่ือนเสนแนวนอนที่ปรากฏ แลววางเสนแบงตรงจุดที่ตองการดวยการคลิกเมาสซาย จากนั้นหนาตางจะแยก

จากกันในแนวนอนออกเปน 2 จอภาพ  
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1. เลื่อนเมาสมาวางที่ขอบหนาตางดานบน 

2. คลิกเมาสขวาแลวเลือกที ่Split Area 
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3. คลิกเมาสซายวางเสนแบง จะได 2 จอภาพ 

4. คลิกเมาสขวาแลวเลือก Split Area เพื่อแบงหนาตางในแนวนอน 
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ถาเราตองการแบงจอภาพยอยมากขึ้นอีก ก็ใหใชวิธีเดิมโดยสามารถคลิกเมาสเพื่อแบงจอภาพจากเสนแบง

จอภาพเดิมไดทั้งแนวตั้งและแนวนอน 

 
 
 
 
 
 
 
 
 

5. คลิกเมาสซายเพื่อวางเสนแนวนอนเราจะไดหนาตางเพิ่มตามแนวนอน 

เราสามารถแบงจอภาพเพิ่มไดทั้งแนวตัง้และแนวนอน 
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ปรับขนาดจอภาพยอย 
เราสามารถปรับแตงขนาดของจอภาพยอยไดอีก เนื่องจากในการทํางานบางครั้งเราอาจตองการเห็นมุมมองใด

มุมมองหนึ่งอยางชัดเจน และมีมุมมองอื่นเปนจอภาพเล็กๆ เพื่อชวยแสดงสวน หรือชวยใหเห็นภาพรวมไดดีขึ้น  

ดังนั้นเราจึงจําเปนตองปรับหนาจอใหเหมาะกับการทํางานขณะนั้น โดยคลิกเมาสซายคางไวที่บริเวณเสนแบง 

และลากไปยังตําแหนงใหมที่ตองการแลวปลอยเมาส ดังภาพ 

 
 
 
 
 

 
 
 
 

คลิกเมาสซายที่เสนแบงคางไวแลวลาก 

เม่ือปลอยเมาส เราจะไดขนาดของจอภาพ ขนาดใหม 
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รวมจอภาพยอยใหกลายเปนจอภาพใหญ 
  ในการรวมจอภาพนั้น สามารถทําไดครั้งละ 2 จอ โดยทั้งสองจอภาพจําเปนตองเปนหนาตางที่ติดกันและมีดาน

ใดๆ เปนดานรวมที่มีขนาดเทากัน โดยสามารถทําไดดังนี้ 

  1. เล่ือนเมาสไปที่รอยตอระหวาง 2 จอภาพนั้นแลวคลิกเมาสขวาเลือก Join Areas  

  2. จากนั้นจะมีลูกศรใหญใหเราเลือกวาจะรวมกับจอภาพใด หนาตางที่ลูกศรชี้ไปคือจอภาพที่จะถูกอีกจอภาพ

ซอนทับไป ดังตัวอยางเราคลิกเลือกจอภาพยอยดานบนซายใหรวมกับจอภาพยอยดานบนขวา ดังนั้นเราจะใหลูกศรชี้ไป

ทางซาย 

 
 
 
 

 
 
 
 

1. คลิกเมาสขวาที่รอยตอระหวางหนาตาง เลือก Join Areas 

2. รวมหนาตางบนซายลากเมาสใหลูกศรชีไ้ปทางซาย 
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ในทางกลับกลับ ถาตองการรวมหนาตางทางขวา ก็ใหชี้ลูกศรไปทางหนาจอดานขวา หรือถาตองการรวม

ดานลาง/บน ก็ใหชี้ลูกศรไปทางดานลาง/บนตามลําดับ 

 
 
 
กําหนดมุมมองใหจอภาพยอย 

เราสามารถกําหนดมุมมองในแตละจอภาพยอยในวิวพอรตได เชน กําหนดใหเปนมุมมองจากดานบน (Top 

View), มุมมองจากดานขาง (Side View), มุมมอง 3 มิติ (Perspctive View) เปนตน โดยใหเราคลิกเมาสซายที่เมนู 

View ใน Header ของวิวพอรต จากนั้นจะปรากฏเมนูขึ้นมาใหเราเลือกมุมมองที่ตองการ  

ผลลัพธคือหนาตางดานซายจะมารวมกับหนาตางดานขวา 
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ในตัวอยางนี้ เราจะเลือกแสดงมุมมองดานขาง ใหเราเลือกคําส่ัง View>Side   หรือกดคียเลข <3> ที่ Num 

Pad ในคียบอรดก็ได จากนั้นจอภาพก็จะแสดงมุมมองวัตถุดานขาง สังเกตไดจากแนวแกนที่แสดงจะมีแค X และ Y 

เทานั้น 

 
 
 
 
 

 
 
 
 

 
 
 
 

เดิมหนาตางทีท่ํางานอยูในมุมมอง Perspective ใหเราคลิกเมาสซายที่ View>Side 

หลังจากเลือก Side แลวมุมมองจะเปลี่ยนไปเปนดานขาง 
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นอกจากนั้น เรายังสามารถกําหนดมุมมองแตละวิวพอรตไดตามตองการ เชน กดคีย <5> เพื่อเลือกแสดง

ระหวาง Orthographic และ Perspective สลับกันไป ดังภาพ 

          
Orthographic View         Perspective View  
 

Orthographic View  คือการแสดงผลมุมมองตามขนาดจริงของวัตถุ โดยไมยึดกับการมองเห็นแบบ

สายตามนุษย ในมุมมองนี้ ไมวาจะหมุนมุมมองไปดานใด วัตถุจะมีขนาดคงที่เสมอ ไมขึ้นอยูกับระยะไกลหรือใกล ซึ่งมี

ประโยชนในการเปรียบเทียบขนาดจริงในการสรางงาน 3 มิติ 

Perspective View   คือการแสดงผลมุมมองตามที่สายตามนุษยมองเห็นจริง ซึ่งในมุมมองนี้วัตถุที่อยู

ใกลก็จะมีขนาดใหญ และวัตถุที่อยูไกลก็จะมีขนาดเล็กลงไปตามระยะหางจากสายตา มุมมองนี้มีประโยชนในการมอง

ผลลัพธจริงเมื่อเราสรางงาน 3 มิติ 

ในเมนู View จะประกอบดวยมุมมองที่สําคัญอีก ไดแก  

    Global View    มองเห็นวัตถุทั้งหมด 

    Local View     มองเห็นเฉพาะวัตถุที่เลือก 

(เราสามารถกดคีย </> ที่ Num Pad เพื่อเลือกแสดงระหวาง Global View และ Local View Perspective 

สลับกันไป) 

  Side    มุมมองจากดานขาง (หรือกดคีย <3>) 

  Front       มุมมองจากดานหนา (หรือกดคีย <1>) 

  Top     มุมมองจากดานบน (หรือกดคีย <7>) 

  Camera     มุมมองจากกลอง (หรือกดคีย <0>) 

  User       มุมมองของผูใช  

  Background Image   มองเห็นภาพพื้นหลังในมุมมองจากกลอง 
 
 

ขยายจอภาพยอยใหเต็มพ้ืนที่วิวพอรต 
เราสามารถกําหนดใชจอภาพใดๆ ใหใหญเต็มพื้นที่ของวิวพอรตไดดวยการกดคีย <Ctrl+  > เพื่อขยายจอภาพ 

และกดคียลูกศร <  > เพื่อยอจอภาพ จะไดผลลัพธเชนเดียวกันกับวิธีแรก นอกจากนั้นเรายังใชขยายหรือยอไดกับ

หนาตางอื่นๆ ดวย เชน Buttons Window   
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วิวพอรตที่เลือกจะขยายเต็มจอภาพ 
 
 
 

เลื่อนเมาสมาที่หนาตาง แลวกดคยี <Shift+Spacebar> 
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ใชเมาสและคียบอรตควบคุมวิวพอรต 
เราสามารถควบคุมมุมมองในวิวพอรตไดดวยการใชเมาส ซึ่งแนะนําวาควรใชเมาสชนิด 3 ปุม คือมีปุมซาย ปุม

กลาง (ปุม Wheel ที่มีลอ) และปุมขวา เนื่องจากโปรแกรม Blender จะใชงานเมาสทุกปุมในการทํางานเสมอ โดยใน

ตัวอยางเราจะทํางานกับมุมมอง Perspective ซึ่งเปนมุมมองที่เราสามารถมองวัตถุไดทุกมุม ดังนี้ 
 

การหมุนมุมมอง 
การหมุนมุมมองทําไดโดยการคลิกเมาสกลางคางไว แลวหมุนไปมาเพื่อดูผลลัพธ จากนั้นปลอยเมาสเมื่อไดมุมที่

ตองการ 

 
คลิกเมาสกลางคางไวแลวหมุนมุมมอง 

 

การเลื่อนมุมมอง 
การเลื่อนมุมมองหรือการเลื่อนกลองไปมาเรียกวา “การแพน” ทําไดโดยการกดคีย <Shift> คางไว แลวคลิก

เมาสกลางคางไว จากนั้นเลื่อนเมาสไปมาเพื่อดูผลลัพธ และปลอยเมาสเมื่อไดมุมมองที่ตองการ 

 
คลิกเมาสกลางคางไวพรอมกดคีย <Shift> แลวเลือ่นมุมมอง 
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การยอขยายมุมมอง 
การยอ/ขยายมุมมองออกเรียกวา “การซูมเขาออก” นั่นเอง ทําไดโดยการกดคีย <Ctrl> คางไว แลวคลิกเมาส

กลาง จากนั้นเลื่อนขึ้นดานบนเพื่อซูมออก และเลื่อนลงลางเพื่อซูมเขา ปลอยเมาสเมื่อไดมุมที่ตองการ 

 
กดคีย <Ctrl> แลวคลิกเมาสกลาง เลื่อนเมาสขึ้นเปนการขยายมุมมอง 

 

 
กดคีย <Ctrl> แลวคลิกเมาสกลาง เลื่อนเมาสลงเปนการยอมุมมอง 

 

หรือเราอาจใชเมาสปุมกลางที่เปนลูกกลิ้ง (Wheel) หมุนขึ้นลงเพื่อทําการซูมก็ไดเชนเดียวกัน  

จากวิธีในการใชเมาสและคียบอรดควบคุมวิวพอรตนี้ เราสามารถใชทํางานกับหนาตาง Buttons Window ได

เชนกัน ยกเวนการหมุนมุมมองเทานั้นที่ไมสามารถใหไดกับหนาตาง Buttons Window  
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รูจักกับ Cross Hair Cursor   
หลังจากที่เราเปดโปรแกรม Blender ขึ้นมาทุกครั้ง ในวิวพอรตเราจะสังเกตเห็นที่จุดศูนยกลางวัตถุวาจะมี

เคอรเซอรที่มีลักษณะเปนเสนบางๆ คลายเครื่องหมายบวกและมีวงกลมสีขาวสลับแดงอยูดวย เสนนี้เรียกวา “Cross Hair 

Cursor” ซึ่งมีหนาที่กําหนดตําแหนงในการสรางวัตถุบนพื้นที่วิวพอรต 

 
 

ภาพ Cross Hair Cursor 
 

ยายตําแหนง Cross Hair Cursor สรางวัตถุในตําแหนงใหม 
เราสามารถยายตําแหนง Cross Hair Cursor ไดดวยการคลิกเมาสซาย ณ ตําแหนงใดๆบนวิวพอรต จากนั้น 

Cross Hair Cursor ก็จะไปปรากฏที่นั่น 

ทดลองลองใชงาน Cross Hair Cursor โดยสรางวัตถุดวยการเลือกในเมนู Add และเลือกวัตถุใดๆ มา 1 ชิ้น ใน

ตัวอยาง เลือกสรางสี่เหลี่ยมทรงลูกบาศกโดยใหคลิก เลือก Add>Mesh>Cube ก็จะพบวาวัตถุถูกสรางที่ตําแหนง Cross 

Hair Cursor พอด ี

 
 

1. คลิกเมาสซายวาง Cross Hair Cursor ในตําแหนงทีต่องการ 
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วัตถุจะถูกสรางอยูที่ตําแหนง Cross Hair Cursor พอดี 
 

ตั้งคาศูนยกลางจอภาพดวย Cross Hair Cursor 
หนาที่อีกอยางหนึ่งของ Cross Hair Cursor คือการทําหนาที่เปนจุดศูนยกลางของการแสดงผลในวิวพอรต โดย

ถาเรากดคีย <C> จะพบวาหนาตางจะเลื่อนมายังตําแหนงที่ Cross Hair Cursor เปนจุดศูนยกลางเสมอ ซึ่งจะเปน

ประโยชนเมื่อเราสรางงานหลายชิ้นในหนาจอและตองการดูวัตถุทีละชิ้น โดยวาง Cross Hair Cursor ที่วัตถุนั้นแลวกดคีย 

<C> เพื่อดึงวัตถุใหมาแสดงที่กลางวิวพอรตก็จะทําไดงายขึ้น 
 

2. คลิกเมาสซายเลือก Add>Mesh>Cube หรือวางเมาสที่วิวพอรตแลวกดคีย <Spacebar> จากนั้นเลอืก 
Add>Mesh>Cube ไดเชนกนั 
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คลิกเมาสซายเพื่อวาง Cross Hair Cursor บนวัตถ ุที่ตองการเลื่อนมากลางวิวพอรต 
 

 
 
                                         เม่ือกดคีย <C> วัตถุจะยายมากลางวิวพอรต 
 

เมื่อตองการให Cross Hair Cursor กลับมาอยูที่จุดเริ่มตน (จุด Origin) ซึ่งเปนจุดที่เสนแกนทั้งสามตัดกันหรือ

เปนพิกัด (0,0,0) จากนั้น Cross Hair Cursor จะกลับมาอยูที่จุดเริ่มตนดังเดิม 
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Cross Hair Cursor อยูจุดอื่น 
 

 
 
เม่ือกดคีย <Shift+C> Cross Hair Cursor จะกลับมาอยูที่จุดเริ่มตน 

 

ทํางานกับระบบไฟลในโปรแกรม Blender 
ส่ิงตอมาที่เราควรเรียนรูจัก ก็คือ การทํางานในระบบไฟล จุดประสงคของหัวขอนี้ เพื่อจะใหเราเขาใจการสราง

งาน การเก็บงาน และการเรียกใชงานไดอยางถูกวิธี 
 

การสรางไฟลใหม 
เราสามารถเริ่มตนการทํางานในโปรแกรม Blender กับไฟลใหมไดทันที เนื่องจากเมื่อเราเปดโปรแกรมใหม 

หนาจอการทํางานก็จะเปนไฟลใหมใหเราทุกครั้ง ดังนี้ 
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ทุกครั้งที่เปดโปรแกรมจะเปนการเริ่มงานในไฟลใหม 
 

สังเกตวาเมื่อเราเปดโปรแกรม Blender ขึ้นมา เราจะพบวัตถุรูปทรงสี่เหลี่ยมลูกบาศก 1 ชิ้น โดยเราอาจใชงาน

จากวัตถุที่โปรแกรมกําหนดใหหรือลบทิ้งไปได (ซึ่งเราจะกลาวถึงรายละเอียดในบทที่ 4 การทํางานกับวัตถุ)  

แตถาเราตองการจะสรางไฟลใหมอีกครั้ง โดยละทิ้งงานทุกอยางที่กําลังทําอยู ใหเลือกใชคําส่ัง File>New... 

หรือกดคีย <Ctrl+X> หลังจากนั้นจะมีปอบอัพปรากฏขึ้นมา ใหเรายืนการสรางไฟลใหมดวยการเคลียรหนาจอทั้งหมด ให

คลิกเมาสซายเลือกที่ Erase All เพื่อสรางไฟลใหมโดยละทิ้งทุกการทํางานบนหนาจอ 

 
 

ปอบอัพใหเรายืนยันการสรางไฟลใหมดวยการเคลยีรหนาจอทัง้หมด 
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การบันทึกไฟล 
หลังจากที่เริ่มทํางานบนวิวพอรตไปบางแลว และตองการจะเก็บบันทึกไฟลงานนั้นไว ซึ่งเรายังไมเคยบันทึกไฟลนี้

มากอน ก็ใหเลือกคําส่ัง File>Save หรือกดคีย <Ctrl+W> จากนั้นโปรแกรมจะใหเราตั้งชื่อและระบุโฟลเดอรที่ตองการ

เก็บไฟล เมื่อใสขอมูลครบแลวใหเราคลิกเมาสที่ปุม   

 
 
เลือกคําสั่ง File>Save เพื่อบันทึกไฟล 
 

 
สําหรับการระบุโฟลเดอรที่ตองการเก็บไฟลนั้น ทําไดโดยการคลิกที่จุดสองจุด เพื่อถอยหลังไปยังโฟลเดอรอื่นๆ 

หรือคลิกเมาสซายที่ปุม    ดานบนสําหรับเลือกไดรวที่ตองการเก็บไฟล 
 
 

คลิกเมาสเพื่อเลือกไดรวสําหรับเก็บไฟล 
คลิกเมาสเลือก .. เพื่อถอยกลับไปยังโฟลเดอรที่ตองการ 
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เมื่อเราเลือกโฟลเดอรไดแลว ก็ใหตั้งชื่อไฟล แลวคลิกเมาสซายที่ปุม  เพื่อบันทึกไฟลใหมลงไป 
 

             1. ตั้งชื่อไฟล                                                                                              2. คลิกเมาสซาย 

 
 
 
เมื่อเราบันทึกไฟลตามขั้นตอนทั้งหมดแลวจะไดไฟลเปนนามสกุล .blend ซึ่งสามารถใชทํางานกับเฉพาะ

โปรแกรม Blender เทานั้น ไมสามารถนําไปเปดดวยโปรแกรมอื่นๆ โดยตรงได 
 

NOTE 
ถาตองการบันทึกไฟลเดิมที่กําลังทํางานเปนไฟลใหม ใหเลือกคําส่ัง File>Save As... หรือกดคีย <F2> แลวตั้ง

ชื่อใหมใหไฟลนั้น 

ถาตองการใชงานไฟล .blend ในโปรแกรมอื่น เราควรจะบันทึกไฟลเปนนามสกุลที่สามารถใชงานกับโปรแกรม

อื่นๆ ได แตหากตองการตองใชวิธีการ Export ไฟลแทน ซึ่งจะกลาวถึงตอไป 
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การเปดไฟล 
การเปดไฟลหรือการเรียกชิ้นงานที่ถูกสรางไวกอนหนา จะตองเปดเฉพาะไฟลนามสกุล .blend เทานั้น เนื่องจาก

ไฟลที่ถูกสรางจากโปรแกรม Blender จะถูกเก็บไฟลไวในนามสกุลนี้ โดยเปดไฟลดวยคําส่ัง Flie>Open... หรือกดคีย 
<F1> 

 
1. เปดไฟลดวยคาํสั่ง Flie>Open... 

 
2. เลือกไฟลจากโฟลเดอรที่ตองการ แลวคลิกเมาสซายปุม   

 
 

Page 39



การบันทึกไฟลเพ่ือนําไปใชงานในโปรแกรมอื่น (การ Export ไฟล)  
ในกรณีที่เราตองการนําไฟลงานจากโปรแกรม Blender ไปใชงานในโปรแกรม 3 มิติโปรแกรมอื่น สามารถทําได

โดยการ Export ไฟลแลวเลือกฟอรแมตไฟลตามโปรแกรมที่เราตองการใชงาน ดวยคําส่ัง File>Export…. 
 

1. คลิกเลือกคําสั่ง File>Export>แลวเลือกไฟลที่ตองการนําไปใชงาน (ในตัวอยางเลือกไฟล .3ds เพื่อนําไปเปดกับ
โปรแกรม 3DS Max) 

 
 
 

2. ตั้งชื่อไฟล   3. คลิกเลือก Export เพื่อทําการบันทึกไฟลเปนนามสกุลของโปรแกรมที่ตองการ 
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4. หลังจากนัน้ เราสามารถเปดใชงานไฟลที่เราเลือกบันทึกไดจากโปรแกรมอื่นๆ  
ดังตวัอยางขางลางเราเปดในโปรแกรม 3DS Max  

 
 

 
การนําไฟลนามสกุลอื่นมาทํางานในโปรแกรม Blender  

ในกรณีที่เราตองการนําไฟลงานจากโปรแกรมอื่นมาใชงานในโปรแกรม Blender ก็สามารถทําไดเชนเดียวกัน 

โดยเลือกคําส่ัง File>Import>… แลวเลือกไฟลที่ตรงกับฟอรแม็ตที่เรามีอยู ดังในตัวอยางเราเลือกไฟล .3ds เขามา 
 

1. คลิกเลือกคําสั่ง File>Import>แลวเลือกไฟลที่ตองการใชงาน (ในตวัอยางเลือกไฟล .3ds) 
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2. คลิกเลือกไฟลที่ตองการเปด                               3. คลิกปุม Import  

 
 

                               
4. คลิกปุม OK เพื่อทําการดึงไฟลนั้นเขามาในโปรแกรม 
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5. ไฟลที่เรียกเขามาจะเปดขึ้นในโปรแกรม Blender 
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บทที่ 3 
ทดลองทํางานกับโปรแกรม Blender 

 
สําหรับบทนี้ เราจะมาทดลองสรางงาน 3D แบบงายๆ กัน เพื่อเราจะเขาใจถึงวิธีการและหลักการสําคัญ ในการ

สรางงาน 3D โดยเราจะไดเรียนรูขั้นตอนในการทํางาน จนกระทั่งทําการประมวลผลดวยการเรนเดอร 
 

ทดลองสรางงานชิ้นแรกดวย Blender 
การสรางงานชิ้นแรกนี้ เราจะทําตามขั้นตอนในการสรางงาน 3D ดังที่ไดกลาวมาแลวในบทที่ผานมา โดยเราจะ

สรางลูกขางใหวิ่งหมุนไปมาบนพื้นและมีความยาวในการแสดงทั้งหมด 100 เฟรม ผลลัพธที่ออกมาจะเปนดังภาพ 

 
   

วิธีการสรางมีขั้นตอนทั้งหมด ดังนี้ 

    ขั้นที ่1 สรางโมเดล 

    ขั้นที ่2 ใสพื้นผิวและลวดลาย 

    ขั้นที ่3 สรางการเคลื่อนไหว 

    ขั้นที ่4 การประมวลผลงานดวยการเรนเดอร 

        
ขั้นที ่1 สรางโมเดล         ขั้นที ่2 ใสพืน้ผิวและลวดลาย 

           
ขั้นที ่3 สรางการเคลื่อนไหว            ขัน้ที ่4 การประมวลผลงานดวยการเรนเดอร 
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ขั้นที่ 1 สรางโมเดล 
เราจะสรางวัตถุรูปทรงลูกขางขึ้นมา และสรางอีกวัตถุหนึ่งใหเปนพื้นรองรับลูกขาง โดยเลือกใชการสรางวัตถุ

สําเร็จรูปแบบพื้นฐาน ดังภาพ 

 
สรางพื้นจากวตัถ ุPlane    สรางลูกขางจากวตัถ ุCone 
 

โดยกอนที่จะเริ่มสรางวัตถุใดๆ นั้น เมื่อเปดหนาตางการทํางานมาครั้งแรก โปรแกรม Blender จะเตรียมวัตถุ 

Cube 1 ชิ้นไวสําหรับใหเราใชงานไดเลย แตถาไมตองการใหกดคีย <Delete> ที่คียบอรดเพื่อลบทิ้งไปกอน 
 

 
 

กดคีย <Delete> แลวคลิกเมาสซายเลือก Erase selected Object(s) 
 

จากนั้นจึงเริ่มสรางโมเดลโดยขั้นตอนการสรางวัตถุมี 3 ขั้นตอน ดังนี้ 

• สรางพื้นรองรับลูกขางจากวัตถุ Plane 

• สรางลูกขางจากวัตถุ Cone 

• ปรับตําแหนงและขนาดของลูกขาง 

Page 45



 
สรางพ้ืนรองรบัลูกขางจากวัตถุ Plane 

 
เราจะสรางพื้นจากวัตถุ Plane โดยสรางในมุมมอง Top (มุมมองนี้จะชวยใหเราเห็นขอบเขตของวัตถุไดชัดเจน) 

สังเกตวาในทุกๆ จอภาพขณะสรางจะแสดงวัตถุ Plane ในมุมมองนั้นๆ ดวย ซึ่งชวยใหเราไดประมาณหรือกะขนาดและ

ตําแหนงได 
 

1. คลิกเมาสซายเลือกเมนู Add>Mesh>Plane             2. วัตถ ุPlane จะปรากฏบนวิวพอรต 
 

         
 

 
 
 
 
 
 
 
 

3. คลิกเมาสซายเลือกปุม  ใน Header ดานลางของววิพอรต 
เพื่อทําการขยายวัตถ ุPlane 

4. คลิกเมาสซายคางไวที่วงกลามสีขาวใน
วัตถ ุแลวลากเมาสเพื่อขยายวัตถ ุ
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สรางลูกขางจากวัตถุ Cone 
เราจะสรางลูกขางจากวัตถุ Cone โดยจะปรับแตงวัตถุใหมีรูปทรงเหมือนลูกขาง ดวยการดึงสวนบนของวัตถุ ดัง

ภาพ 

 
 

 
 

 

ลากเมาสขยายวัตถ ุ 5. คลิกเมาสซายคางไวที่แกนสี่เหลี่ยมแนวตัง้ดานบน 
แลวลากเมาสเพื่อยอวัตถุใหขนาดลดลงมาเฉพาะ
ดานบนและลาง 

1. คลิกเมาสซายเลือกเมนู Add>Mesh>Cone 
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2. คลิกเมาสซายที่ปุม OK เพื่อสรางวัตถตุาม
มาตรฐานที่โปรแกรมกําหนดมา 

3. วัตถ ุCone จะปรากฏบนวิวพอรต 

4. คลิกเมาสกลางคางไวเพื่อหมุนมุมมอง หลังจากนั้นกด
คีย <Ctrl+Alt>  คางไวแลวคลิกเมาสกลางคางไว
ตอจากนั้นใหขยบัเมาสเพื่อซูมเขามาใหเปนดังภาพ 

5. กดคีย <N> เพื่อเรียกหนาตาง Transform Properties ออกมาใชปรับแตงวตัถุเบ้ืองตน 
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ปรับตําแหนงและขนาดของลูกขาง 
เมื่อสรางวัตถุ Cone แลว ใหเราเลือกปรับตําแหนงและขนาดของลูกขาง โดยใชหนาตาง Transform 

Properties และเครื่องมือ Transformation มาชวยปรับแตง  จากวัตถุ Cone ที่มีสวนแหลมอยูดานลาง เราจะจับให

หงายขึ้น จากนั้นจะสรางสวนแหลมอีกดานขึ้นมาใหเปนลูกขาง 
 
 
 
 

 
 

 
 
 
 
 

 
 
 
 
 
 
 

1. คลิกเมาสซายที ่Rot X แลวพิมพคา 180 ลงไป จากนั้นกดคีย <Enter> เพื่อสั่งใหวตัถุ
หมุนรอบแกน X เทากับ 180 องศา สังเกตการเปลี่ยนแปลง 

2. ปรับขนาดของวัตถุใหเล็กลง โดยปรับในหนาตาง 
Transform Properties เราจะเปลี่ยนคา ScaleX, 
ScaleY และ ScaleZ เทากับ 0.55, 0.5 และ 0.5 

3. คลิกปุม  เพื่อจะเตรียมลากวัตถุ Cone ใหขึ้น
ไปวางอยูบนพื้น 
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4. คลิกเมาสซายคางไวที่ลูกศรแนวตั้ง จากนั้นลากเมาสเพื่อดึงวัตถ ุCone ขึ้นมาวางบนพื้น Plane 

5. หมุนมุมมองโดยการคลิกเมาสกลางคางไวแลวลากเมาส ใหมีมุมมองแบบตัวอยาง จากนั้นกดคีย <Tab> เขาสูการแกไข
วัตถ ุสังเกตวาเราจะเขาสูการทํางานงาน Edit Mode 

6. คลิกเมาสซายที่ปุม   เพื่อเขาสูการทํางานกับจุด 
จากนั้นคลิกเมาสขวาเลือกจุดตรงกลางวัตถโุคน 

7. คลิกเมาสซายเลือกปุม  แลวคลิกที่เสนแกน
แนวตัง้คางไว จากนั้นดึงจุดที่เลือกขึ้นมาดังภาพ แลวกด
คีย <Tab> ออกจาก Edit Mode หรือออกจากการ
ปรับแตงวัตถุในสวนยอย 
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ขั้นที ่2 ใสพืน้ผิวและลวดลาย 
เมื่อเราสรางวัตถุเรียบรอยแลว เราจะตกแตงวัตถุใหมีสีสันดวยการใสพื้นผิวใหกับลูกขางและพื้น โดยกําหนดจาก

โหมด Shading ปรับใหพื้นผิวของวัตถุทั้งสองมีสีตางกัน ดังนี้ 

 
 

กําหนดลักษณะพื้นผิวของลูกขาง 
เราจะกําหนดใหลูกขางเปนสีน้ําเงิน และมีการปรับคามันวาวในชอง Specular Shading ดังตัวอยางตอไปนี ้
 
 
 

 8. กดคีย <0> ทีแ่ปน Numpad หรือคลิก View>Camera เปลี่ยนใหเปนมุมมองจากกลอง (เพื่อจัดใหวัตถุทัง้สองเขามาอยู
ในกรอบของกลอง เนื่องการการเรนเดอรชิ้นงานจะใชมุมมองจากกลองเปนหลัก) 
 

 9. จากนั้นใชเมาสลากวัตถ ุโดยคลิกคางไวที่แกนลกูศรตามเสนทางที่ตองการ เพื่อปรับใหวตัถุมาอยูที่มุมของพื้น Plane 
(เตรียมสรางจุดเริ่มตนในการเคลื่อนที)่ 
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1. คลิกเมาสขวาเลือกลูกขาง 

2. คลิกเมาสซายเลือกปุม  เพื่อเขาสูการใสพื้นผิว 
3. คลิกเมาสซายเลือกปุม   เพื่อ
สรางพื้นผวิใหม 

4. คลิกที่ชอง   ใน Col เพื่อใสสีใหกับลูกขาง 5. คลิกเมาสซายเลือกสีใหลูกขาง (สีน้ําเงิน) 
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กําหนดลักษณะพื้นผิวของพื้น 

เราจะกําหนดใหพื้นเปนชมพู ดังตัวอยางตอไปนี้ 
 
 
 

 
 
 
 
 

 

6. ปรับคาความมันวาวเพิ่มขึ้น โดยคลิกเลือกแท็ป Shaders แลวเลื่อนสไลดบารเพิ่มคา Specular Shading ใหการ
สะทอนแสงของวตัถุมีมากขึ้น 

1. คลิกเมาสขวาเลือกพื้นแลวกดปุม  เพื่อสรางพื้นผิวใหม 

2. คลิกเมาสเลือกสีชมพูใหกับพื้น 
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ขั้นที่ 3 สรางการเคลื่อนไหว 
สําหรับหัวขอนี้ เราจะสรางลูกขางใหหมุนรอบตัวเองตลอดเวลา และในขณะที่หมุนอยูนั้น จะสรางใหเคลื่อนที่บน

พื้นดวย โดยจะใหเคลื่อนที่จากมุมของพื้นมายังบริเวณตรงการ โดยใชหลักการสรางคียเฟรม (เฟรมหลักที่มีการบันทึกการ

เปล่ียนแปลงวัตถุ เชน ตําแหนงใหม การวางตัวของวัตถุใหม) ทั้งหมด 2 คียเฟรม จากนั้นเมื่อเสร็จแลวโปรแกรมจะคํานวณ

การเคลื่อนที่จากคียเฟรมทั้งสองเอง แลวแสดงผลออกมาเปนการเคลื่อนที่ๆ ตอเนื่องกันจนกระทั้งครบ 100 เฟรม ดังนี้ 
 

 
 

โดยขั้นตอนการสรางการเคลื่อนไหวม ี2 ขั้นตอน ดังนี้ 

• เตรียมหนาตางสําหรับทํางานแอนิเมชั่น 

• สรางการเคลื่อนที่ใหกับลูกขาง 
 

เตรียมหนาตางสําหรับทํางานแอนิเมชั่น 
สําหรับการทํางานนี ้เราจําเปนตองใชงานหนาตาง Timeline มาชวยสรางการเคลื่อนที่ของลูกขาง โดยมีวิธีการ

ดังนี้ 
 

 
 
  1. วางเมาสที่บริเวณดานซายของหนาตางการทํางาน แลวคลิก
เมาสขวาจะปรากฏปอบอัพ จากนัน้คลิกเมาสซายเลือก Split Area 
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2. จะพบเสนแนวนอนปรากฏขึ้นมา ใหเลือกเมาสกําหนดตําแหนง 
แลวคลิกเมาสซายเพื่อแบงหนาจอ 

3. คลิกเลือกหนาตาง Timeline ท่ี Window Type 
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หลังจากนัน้หนาตาง Timeline จะปรากฏ 
 
สรางการเคลื่อนที่ใหกับลูกขาง 
 เราจะเริ่มเขาสูการสรางการเคลื่อนที่ โดยใชวิธีสรางคียเฟรมใหกับการเคลื่อนที่แตละจุด โดยกําหนดใหเฟรม 1 

เปนคียเฟรมเริ่มตน และใหเฟรม 100 เปนคียเฟรมที่ 2 ที่เก็บคาการเคลื่อนที่ของลูกขาง ดังวิธีตอไปนี้ 

 
 
1. เม่ือคลิกเลือกลูกคา ใหตัง้คาความยาว
การแสดงเปน 100 เฟรม โดยพิมพคา 100 
ลงในชอง End 

2. จากนั้นเริ่มทํางานในเฟรม 1 โดยพิมพคา 1 แลวกดคีย <I> 
เลือก LocRotScale เพื่อสรางคียเฟรมสําหรับการเคลื่อนที่ทั้ง
เคลื่อนยาย หมุน และเปลี่ยนขนาด 
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3. พิมพเฟรม 100 เพื่อสรางคียเฟรมที่ 2 

4. ปรับตําแหนงลูกขางดวยการใชเครื่องมือ  ลากลูกขางมาวางไวกลางพื้น 5. คลิกเลือกปุม   เพื่อกําหนดใหโปรแกรม
สรางคียเฟรมใหเราอัตโนมัต ิ

6. คลิกเลือกปุม  ที ่Header แลวหมุนวัตถุ
รอบแกน z 

7. จากนั้นทดลองกดปุม  เพื่อตรวจสอบการ
เคลื่อนไหว 
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ลูกขางจะมีการเคลื่อนที่ตามที่เราสรางไว 
 

ขั้นที่ 4 การประมวลผลงานดวยการเรนเดอร 
สุดทายเราจะทําการประมวลผลงานหรือเรนเดอรใหไดไฟลภาพยนตร โดยจะเลือกนามสกุล avi และกําหนด

คุณสมบัติตามคุณสมบัติของไฟลแอนิเมชั่นที่ใชเลนกับเครื่องคอมพิวเตอร ดังวิธีตอไปนี้ 
 

 
 
 
 
 
 

1. คลิกเลือกปุม  แลวเลือกปุม  เขาสูการ
เรนเดอร 

2. คลิกเลือกปุม   เพื่อตั้งคาคุณสมบัติ
วิดีโอใหเหมาะสมกับการใชงานกับเครื่อง
คอมพิวเตอร 
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3. เลือกไฟลผลงานใหเปนรูปแบบไฟลวดิีโอ โดย
คลิกเลือกที่แท็ป Format เลือก Avi Codec 

4. จะปรากฏหนาตางใหเลือกรูปแบบการบีบอัด
ไฟลวดิีโอ ในทีน่ี้เราจะไมทําการบีบอัดใดๆ ใหคลิก
เลือกปุม OK 
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5. เลือกตั้งโฟลเดอรที่จะเก็บไฟล 
 

 
 
 
 
 
 
 
 

6. เม่ือเลือกโฟลเดอรแลวใหตั้งชื่อไฟล 
จากนั้นคลิกปุม Select Output Picture 

7. จากนั้นคลิกปุม   เพื่อทําการ
เรนเดอร 
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รอสักครูใหโปรแกรมเรนเดอรจนจบ 
 

หลังจากการเรนเดอร เราจะไดไฟลวิดีโอที่แสดงการเคลื่อนที่ของลูกขางที่หมุนอยูบนพื้น โดยสามารถเปดไฟล

วิดีโอนี้ไดที่โฟลเดอรที่เราเลือกเก็บไฟลไว 
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บทที่ 4 
ทํางานกับวัตถุ 

 
สําหรับบทนี้ เราจะไดทําความเขาใจและเรียนรูวิธีการทํางานกับวัตถุ หรือจัดการกับวัตถุ ซึ่งกระบวนการเหลานี้มี

สวนในการสรางและปรับแตงวัตถุ 3 มิติอยางมาก เนื่องจากเราจําเปนตองทํางานกับสวนประกอบยอยของวัตถุเพื่อใหได

โมเดลขึ้นมา และเราตองรูจักการเคลื่อนยายตําแหนง หมุน ยอ/ขยาย และวิธีการอื่นๆ เพื่อปรับแตงโมเดลใหไดตาม

ตองการ 
 

รูจักโหมดการทํางานกับวตัถุในโปรแกรม 
ในหัวขอนี้เราจะมารูจักกับโหมดการทํางานในโปรแกรม Blender ซึ่งจะแบงแตละโหมดตามการทํางานกับวัตถุ 

เพื่อใหการปรับแตงวัตถุเปนไปอยางสะดวกมากขึ้น โดยแบงเปน 6 โหมด ดังนี้ 
  โหมดที ่1 Object Mode 

  โหมดที ่2 Edit Mode  

  โหมดที ่3 UV Face Select 
  โหมดที ่4 Vertex Paint 
  โหมดที ่5 Texture Paint 
  โหมดที ่6 Weight Paint 

เราสามารถเลือกโหมดการทํางานไดที่ Header ของวิวพอรต โดยคลิกเมาสซายเลือกในชอง  

 ที่อยูขางหัวขอ Object ดังนี้ 

 
 

คลิกเมาสเพื่อเลือกการทํางานในโหมดตางๆ 

Page 62



เมื่อเราคลิกเลือกแตละโหมดนั้น ใหสังเกตวาในหนาตาง Buttons Windows จะเปลี่ยนเครื่องมือไปตามโหมด

ที่เลือก ทั้งนี้เพื่อใหเราเรียกใชเครื่องมือสําหรับปรับแตงวัตถุไดสะดวกนั้นเอง 
 

โหมดที่ 1: Object Mode  
Object Mode คือโหมดที่ใชจัดการเรื่องทั่วไปเกี่ยวกับวัตถุ ซึ่งเปนโหมดมาตรฐานที่เมื่อเปดโปรแกรมมาก็จะอยู

ในโหมดนี้ เราสามารถใชโหมดนี้ในการเลือกวัตถุตั้งแต 1 ชิ้น หรือหลายชิ้นพรอมกัน การเคล่ือนยายวัตถุไปยังที่ตางๆ การ

หมุนวัตถุ การเปลี่ยนขนาดวัตถุใหใหญขึ้นหรือเล็กลง ซึ่งคําส่ังตางๆ จะมีผลกระทําตอวัตถุทั้งชิ้น ไมสามารถเลือกทําเพียง

สวนใดสวนหนึ่งของวัตถุไดภายใตโหมดการทํางานนี้ 

 
 

ลักษณะการทํางานใน Object Mode จะเปนการทํางานกับวัตถุโดยตรง 
 

โหมดที่ 2 Edit Mode 
Edit Mode คือโหมดที่ใชปรับแตงรูปทรงของวัตถุชิ้นใดๆ ที่เราเลือกอยูขณะนั้น แตไมสามารถปรับแตงวัตถุครั้ง

ละหลายชิ้นพรอมกันได ตองทําครั้งละชิ้นนั่นเอง เนื่องจากเปนการปรับแตงที่สวนประกอบยอยของวัตถุ สวนประกอบ

เหลานั้นไดแก 

    Vertex  คือจุดที่ประกอบกันเปนวัตถุ 

    Edge   คือเสนขอบหรือดานของวัตถุ 

    Face   คือแผนพื้นผิวที่ประกอบกันเปนวัตถุ 
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ตัวอยาง เราจะทดลองปรับแตงจุดของวัตถุรูปทรงลูกบาศกใน Edit Mode โดยใหเราคลิกเลือกปุม    

(Vertex Select) ใน Header ของวิวพอรต จากนั้นคลิกเมาสขวาเลือกจุดใดๆ ของวัตถุ แลวคลิกและลากเมาสซายเพื่อ

ปรับแตงรูปทรง ผลลัพธก็จะเกิดขึ้นเฉพาะในสวนของจุดเทานั้นเอง และนี่คือหนาที่โดยรวมของโหมดนี้ 
 

2. คลิกเมาสขวาเลือกจุดของวตัถ ุ
 

 
 

1. เม่ือทํางานใน Edit Mode ใหคลิกเลือกปุม  เพื่อเขาสูการปรับแตงจุด 
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3. คลิกและลากเมาสซายเพื่อปรับแตงรูปทรง 

 

ในกรณีที่ตองการเลือกสวนประกอบของวัตถุครั้งละจํานวนมากในเวลาเดียว สามารถทําไดโดยการกดคีย <B> 

เคอรเซอรจะเปลี่ยนเปนเสนพิกัดใหเราคลิกเมาสคางเลือกทํางานกับสวนประกอบของวัตถุไดครั้งละมากๆ ในสวนที่

ตองการ ดังภาพ 

     
 
 
 
 

นอกจากนั้นเรายังสามารถเลือกวัตถุดวยการถูเมาสในสวนที่ตองการเลือกไดอีกเชนกัน ทังยังสามารถปรับขนาด

เคอรเซอรของเมาสใหมีขอบเขตที่กวางขึ้น หรือแคบลง เพื่อกําหนดขนาดของเมาสในการเลือกวัตถุไดอีกดวย โดยการกด

คีย <B> ติดกัน 2 ครั้ง จากนั้น เมาสจะเปลี่ยนเปนเสนวงกลมที่มีอาณาเขตในการเลือก จากนั้นใหปรับขนาดไดโดยการ

สกอลเมาสปุมกลาง ถาสกอลขึ้นขนาดเมาสจะแคบลง แตถาสกลอลงขนาดเมาสจะกวางขึ้น จากนั้นสามารถคลิกเมาส

ขวาคางไวแลวถูไปบนวัตถุเพื่อเลือกสวนที่ตองการได  

2. กดคีย <B> เพื่อเขาสูการเลือกสวนประกอบของ
วัตถุแบบครั้งละมากๆ 

1. คลิกเมาสคางไวแลวลากผานสวนประกอบของวัตถุ
ที่ตองการเลือก (ผลลัพธเปนดังภาพ) 
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Note 

 สําหรับการทํางานในโหมดนี้ จะไมสามารถเคลื่อนยายวัตถุทั้งกอนได เนื่องจากการเลือกดวยจุดหรือพื้นผิวอาจ

ทําใหเราเลือกวัตถุไมครบทั้งกอน ซึ่งเมื่อมีการเคลื่อนยายอาจทําใหวัตถุผิดรูปและเสียได ดังนั้นถาเราตองออกจากโหมดนี้

เสียกอน โดยใหเลือกทํางานกับ Object Mode แทน 
 

 

 
 
 
 
 
 
 
 
 

2. กดคีย <B> ติดกนั 2 ครั้งเพื่อเขาสูการเลือก
สวนประกอบของวัตถุแบบกําหนดขนาดเมาส 

1. ปรับขนาดเมาส โดยในตัวอยางสกอลเมาสปุม
กลางลง เพื่อใหขอบเขตเมาสมีขนาดใหญขึน้ 

3. คลิกเมาสขวาคางไว แลวเลือกสวนประกอบของ
วัตถุตามตองการ เม่ือตองการเลิกใชเครื่องมือนี้ 
ใหคลิกเมาสขวา เพื่อออกจากการทํางาน 
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โหมดที่ 3 Sculpt Mode 
 Sculpt Mode เปนโหมดใหมที่ใชสําหรับปรับแตงวัตถุ คลายการปนวัตถุ โดยใชแปรงที่สามารถปรับพื้นผิว จุด

ควบคุมวัตถุ ใหเปนรูปทรงตางๆ ไดอยางงายดาย เพียงกําหนดแรงผลักของแปรงในการดันพื้นผิวเขาไปหรือดึงพื้นผิวขึ้นมา 

ชวยใหการปรับแตงวัตถุทําไดอยางอิสระมากขึ้น 

 
 

โหมดที่ 4 Vertex Paint  
Vertex Paint เปนโหมดที่ใชสําหรับการเลือกกําหนดสีหรือลวดลายที่ตําแหนงจุดตางๆ ของวัตถุที่เราเลือก 

มักจะใชในการสรางตัวละครประกอบเกม 
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โหมดที่ 5 Texture Paint  
Texture Paint เปนโหมดที่ใชสําหรับการวาดและกําหนดลวดลายใหกับพื้นผิววัตถุที่เราเลือก โดยที่เราสามารถ

สรางลวดลายขึ้นมาใชงานเองได 

 
 
 

โหมดที่ 6 Weight Paint  
Weight Paint เปนโหมดที่ใชสําหรับใหน้ําหนักกับวัตถุโดยอิงตามจุด Vertex ของวัตถุ และใหน้ําหนักดวยวิธี

เปรียบกับคาสีที่เราระบายลงไปยังวัตถุ 
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จาก 6 โหมดที่รูจักไปนั้นจะเห็นไดวาแตละโหมดจะมีจุดประสงคหลักที่จะใชอยางเจาะจง ดังนั้นเมื่อจะทํางาน

ใดๆ กับช้ินงานควรคํานึงถึงโหมดที่จะใชดวย ซึ่งในเนื้อหาบทเรียนของเราจะใชงาน 2 โหมดสําคัญเปนหลัก คือ Object 

Mode และ Edit Mode จะครอบคลุมการจัดการวัตถุและการปรับแตงรูปทรงในการสรางโมเดลนั่นเอง 
 

การจัดการกบัวัตถุ 
การทํางานกับวัตถุเปนการทํางานกับโมเดลโดยตรง ซึ่งจะเนนไปที่การควบคุมวัตถุ การรวมกลุม การคัดลอก 

และการจัดการวัตถุ โดยรูปแบบการทํางานเหลานี้เราควรผึกใชใหคลอง รวมทั้งเรียนรูคียลัดตางๆ เพื่อจะสามารถสราง

โมเดลไดเร็วขึ้น 
 

การเลือกวัตถุ 
ในโปรแกรม Blender จะใชวิธีการเลือกวัตถุไดหลายรูปแบบ ทั้งเลือกเฉพาะวัตถุ เลือกบางชิ้นที่ตองการหรือ

เลือกทั้งหมด ดังวิธีการตอไปนี้ 
 
การเลือกวัตถุทั่วไป 
วิธีการการคลิกเลือกวัตถุสามารถทําไดโดย ใหคลิกเมาสขวาเลือกวัตถุที่ตองการ ซึ่งถาเปนการทํางานใน 

Object Mode ก็จะเปนการเลือกวัตถุทั้งชิ้น แตถาเปนการทํางานใน Edit Mode ก็จะเปนการเลือกสวนประกอบยอย

ของวัตถุ และเมื่อวัตถุถูกเลือก เราจะพบเสนสีชมพูลอมรอบวัตถุนั้น 
 

 
การเลือกวัตถุใน Object Mode    การเลอืกวตัถุใน Edit Mode 
 

ในกรณีที่ตองการเลือกวัตถุหรือสวนประกอบยอยของวัตถุครั้งละหลายๆ ชิ้น ใหเรากดคีย <Shift> คางไว 

จากนั้นคลิกเมาสปุมขวาเลือกวัตถุตามตองการ 
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คลิกเมาสขวาเลือกวัตถุชิ้นแรกกอน 
 

  
กดคีย <Shift> คางแลวกดเมาสขวาเพื่อเลือกวัตถุอีกชิ้นหนึ่ง 
 

ในกรณีที่ตองการยกเลิกการเลือกวัตถุ ใหเรากดคีย <A> 1 ครั้ง ซึ่งสามารถใชวิธีนี้ไดทั้งการยกเลิกการเลือกวัตถุ

เพียงชิ้นเดียวและกับการเลือกวัตถุครั้งละหลายชิ้น 

แตถาขณะนั้นเราเลือกวัตถุหลายชิ้นอยู และตองการยกเลิกการเลือกวัตถุใดวัตถุหนึ่งออกไป ใหกดคีย <Shift> 

พรอมกับคลิกเมาสขวาที่วัตถุที่ตองการยกเลิก 

  
วัตถุถูกเลือกหลายชิ้น 
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กดคีย <Shift> คางแลวกดเมาสขวาเพื่อเลือกยกเลิกการเลือกวัตถุทีต่องการ 
 

การกดคีย <A> สําหรับการเลือกวัตถุ สามารถใชงานได 2 รูปแบบ นั้นคือ ถาเรากดคีย <A> ครั้งที่ 1 (ขณะที่มี

วัตถุถูกเลือกอยู) จะเปนการยกเลิกการเลือกวัตถ ุและเมื่อเรากดคีย <A> ครั้งที่ 2 จะเปนการเลือกวัตถุทั้งหมดในจอภาพ 

 
วัตถุถูกเลือกอยู 
 

 
กดคีย <A> ครั้งที่ 1 เปนการยกเลิกการเลือกวัตถุ 
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กดคีย <A> ครั้งที่ 2 เปนการเลือกวัตถุทัง้หมด 
 
การเลือกวัตถุดวยการกําหนดขอบเขต 

วิธีการกําหนดขอบเขตนั้น เราจะใชการลากเมาสพาดผานวัตถุ ซึ่งถาเสนประที่เกิดจากการลากเมาสผานไปบน

วัตถุใด วัตถุนั้นจะถูกเลือก  

โดยวิธีการเลือกนั้น ใหเรากดคีย <B> จะพบวาเกิดเสนประที่ตัดกัน ณ จุดที่ตัวชี้เมาสอยู จากนั้นลากคลิกเมาส

ซายคางไว แลวลากเมาสผานวัตถุหรือลากครอบวัตถุใดก็ไดที่ตองการ ดังตัวอยางภาพ 

 
1. เม่ือกดคีย <B> จะพบวาเกิดเสนประ 2 เสนตัดกัน 

 
2. คลิกและลากเมาสผานวัตถทุี่ตองการเลือก (จะเลือกใหผานกี่วัตถกุ็ไดตามตองการ) 
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3. วัตถุที่เสนประลากผานจะถูกเลือก 

 

ในกรณีที่ตองการยกเลิกการเลือกวัตถุ ใหเรากดคีย <B> จากนั้นลากคลิกเมาสขวาคางไว แลวลากเมาสผานวัตถุ

หรือลากครอบวัตถุใดก็ไดที่ตองการยกเลิกการเลือก 

 
กดคีย <B> แลวคลิกเมาสขวาลากผานวัตถ ุ
 

 
วัตถุจะถูกยกเลิกการเลือก 
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การเคลื่อนยาย หมุนและยอ ขยายวัตถุ 
สําหรับการรเคลื่อนยาย หมุนและยอ/ขยายวัตถุ เราจะเลือกใชกลุมเครื่องมือ Transformation ซึ่งเปน

เครื่องมือสําหรับหมุนและยอ/ขยายวัตถุที่เราเลือก โดยกลุมเครื่องมือนี ้ไดแก 

     Translate Manipulator สําหรับเคลื่อนยายวัตถุ 

     Rotate Manipulator สําหรับหมุนวัตถุ 

     Scale Manipulator สําหรับยอ/ขยายวัตถุ 

กอนที่เราจะเริ่มตนใชเครื่องมือเหลานี้ ใหเปล่ียนมุมมองเปน Perspective กอนโดยกดคีย <5> ที่ Num Pad 

เพื่อจะไดเห็นวัตถุไดทุกองศา 
 

 
คลิกเมาสกลางคางไวแลวหมุนมุมมองใหกลายเปนรูปแบบ Perspective 
 

เคล่ือนยายวัตถุดวย Translate Manipulator 
เราสามารถเคลื่อนยายวัตถุที่เราเลือกไปยังตําแหนงอื่นๆ ในวิวพอรตได โดยการใชเครื่องมือ Translate 

Manipulator โดยคลิกปุม   ที่ Header ของวิวพอรต หรือกดคีย <Ctrl+Alt+G> จะมีสัญลักษณเครื่องมือ

เคล่ือนยายปรากฏใหเห็นเปนแกน 3 แกน คือแกน X สีแดง, แกน Y สีเขียว และแกน Z สีน้ําเงิน จากนั้นเราสามารถยาย

วัตถุไดโดยคลิกและลากเมาสซายบริเวณแกนที่ตองการ เพื่อเคล่ือนยายวัตถุ 

 
1.คลิกเลือก Translate Manipulator 
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2. คลิกและลากเมาสซายเพื่อเคลื่อนยายวัตถ ุ

 

ถาเราคลิกซายที่แกนใดแกนหนึ่งแลวลากเมาส ก็จะเปนการเคลื่อนยายวัตถุในแนวแกนที่เราเลือก แตถาคลิก

ซายคางที่วงกลมสีขาวตรงกลางแลวลาก จะเปนการเคลื่อนยายวัตถุอิสระไดทุกแนวในขณะเดียวกัน  

 
คลิกเมาสซายที่วงกลม แลวลากเมาสไดอิสระ 

 

นอกจากการเคลื่อนยายวัตถุดวยวิธีการเลือกเครื่องมือ    Translate Manipulator แลว เรายังสามารถ

เคล่ือนยายวัตถุอยางอิสระได เพียงกดคีย <G> จากนั้นลากเมาสไปมาเพื่อเคลื่อนยายวัตถุ เมื่อลากเมาสยายตําแหนงตาม

ตองการแลว ใหคลิกเมาสซายอีกครั้ง เปนการยืนยันการเปลี่ยนแปลง และสามารถคลิกเมาสขวาเพื่อยกเลิกการ

เปล่ียนแปลง 

 
กดคีย <G> แลวลากเมาสเพื่อเคลื่อนยายวัตถ ุ
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ขณะเดียวกันถาเราตองการยายวัตถุตามแกนใดแกนหนึ่ง ใหเรากดคีย <G> จากนั้นกดคีย <X> หรือ <Y> หรือ 

<Z> เพื่อเลือกแกนที่ตองการเคลื่อนยาย แลวใชเมาสซายคลิกลากเพื่อยายตําแหนงเฉพาะแกนนั้นๆ 

 
 

หมุนวัตถุดวย Rotate Manipulator 

เราสามารถหมุนวัตถุที่เราเลือกได โดยการใชเครื่องมือ Rotate Manipulator  โดยคลิกปุม   ที่ Header 

ของวิวพอรต หรือกดคีย <Ctrl+Alt+R> จะมีสัญญลักษณเครื่องมือสําหรับหมุนวัตถุปรากฏใหเห็นเปนเสนวงกลมรอบวัตถุ 

โดยสีของแกนยังคงเหมือนเดิม สําหรับการใชงานใหคลิกเมาสซายคางไวที่แกนใดแกนหนึ่งแลวลาก จะเปนการหมุนวัตถุ

ในแนวแกนนั้นๆ 
 

 
1. เลือก Rotate Manipulator 
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2. คลิกเมาสซายคางไว แลวลากเมาสไดอิสระ 

 

อีกทางเลือกหนึ่งในการหมุนวัตถุ ใหคลิกซายที่วงกลมขาวนอกสุดจะเปนการหมุนวัตถุในแนวระนาบกับสายตา

ผูใช ซึ่งไมยึดติดกับแกนใด 
 

นอกจากการหมุนวัตถุดวยวิธีการเลือกเครื่องมือ    Rotate Manipulator แลว เรายังสามารถหมุนวัตถุ

อยางอิสระได เพียงกดคีย <R> จากนั้นลากเมาสไปมาเพื่อหมุนวัตถุ เพื่อเลือกแกนที่ตองการ แลวใชเมาสซายคลิกลากเพื่อ

หมุนรอบเฉพาะแกนนั้นๆ เมื่อลากเมาสหมุนวัตถุตามตองการแลว ใหคลิกเมาสซายอีกครั้ง เปนการยืนยันการเปลี่ยนแปลง 

และสามารถคลิกเมาสขวาเพื่อยกเลิกการเปลี่ยนแปลง 

 กดคีย <R> แลวลากเมาสเพื่อหมุนวัตถ ุ
 
ถาเราตองการหมุนวัตถุรอบแกนใดแกนหนึ่ง ใหเรากดคีย <R> จากนั้นกดคีย <X> หรือ <Y> หรือ <Z> 

  
กดคีย <R> จากนั้นกดคีย <X> เพื่อหมุนวัตถรุอบแกน X 
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ยอ/ขยายวัตถุดวย Scale Manipulator 

เราสามารถยอ/ขยายวัตถุที่เราเลือกได โดยการใชเครื่องมือ Scale Manipulator โดยคลิกปุม   ที่ Header 

ของวิวพอรต หรือกดคีย <Ctrl+Alt+S> สัญญลักษณการควบคุมวัตถุจะเปลี่ยนไปเปนเครื่องมือปรับขนาดวัตถุ มีรูปเปน

กลองส่ีเหลี่ยมโดยมีสีตามแนวแกนเหมือนเดิม การใชงานนั้นใหคลิกเมาสซายเลือกแนวแกนใดๆ และลากเมาสคางไป

ดานขวาเพื่อขยายขนาด และดานซายเพื่อยอขนาด 

 
 

คลิก Scale Manipulator 
 

 ลากเมาสเพื่อยอวัตถ ุ

 ลากเมาสเพื่อขยายวัตถ ุ
  

อีกทางเลือกหนึ่งในการยอขยายวัตถุ คือเลือกกระทํากับวงกลมขาวตรงกลางเพื่อปรับขนาดวัตถุในทุกแนวแกน

โดยรักษาอัตราสวนไวดวย 
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 ยอขนาดโดยรักษาอัตราสวนไว 
 

  ขยายขนาดโดยรักษาอัตราสวนไว 
 

นอกจากการยอ/ขยายวัตถุดวยวิธีการเลือกเครื่องมือ   Scale Manipulator แลว เรายังสามารถยอ/ขยาย

วัตถุอยางอิสระได เพียงกดคีย <S> จากนั้นลากเมาสไปมาเพื่อยอ/ขยายวัตถุ เมื่อลากเมาสยอ/ขยายวัตถุตามตองการ

แลว ใหคลิกเมาสซายอีกครั้ง เปนการยืนยันการเปลี่ยนแปลง และสามารถคลิกเมาสขวาเพื่อยกเลิกการเปลี่ยนแปลง 
 

  กดคีย <S> แลวลากเมาสเพื่อยอ/ขยายวัตถ ุ
 

ขณะเดียวกันถาเราตองการยอ/ขยายวัตถุตามแกนใดแกนหนึ่ง ใหเรากดคีย <S> จากนั้นกดคีย <X> หรือ <Y> 

หรือ <Z> เพื่อเลือกแกนที่ตองการ แลวใชเมาสซายคลิกลากเพื่อยอ/ขยายเฉพาะแกนนั้นๆ 
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กดคีย <S> จากนั้นกดคีย <X> เพื่อยอ/ขยายวัตถใุนแกน X 
 

รายละเอียดเพ่ิมเติมสําหรับการใชเครื่องมือ Transformation  

เราสามารถซอนเครื่องมือจัดการวัตถุไดโดยการคลิกเมาสซายที่ปุม    ใน Header ของวิวพอรต และคลิกอีก

ครั้งเพื่อเรียกกลับคืนมา 

 
 

เครื่องมือจัดการวัตถ ุ

 
คลิกเพื่อซอนเครื่องมือจัดการวัตถ ุ
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หากตองการแสดงเครื่องมือจัดการวัตถุทุกเครื่องมือพรอมกัน ใหกดคีย <Shift> คางไวและคลิกเมาสซายเลือก

เครื่องมือทั้งหมดใน Header ก็จะปรากฏตัวควบคุมทั้งหมดรอบวัตถุ โดยเราสามารถเคลื่อนยาย หมุน หรือปรับขนาดโดย

ไมตองสลับโหมดอีก ซึ่งโหมดเครื่องมือรวมที่เราเลือกอยูนี้ จะเรียกวาโหมด “คอมโบ (Combo)” หรือเครื่องมือผสมนั่นเอง 

 
กอนคลิกเลือกโหมดคอมโบ 
 

  
หลังคลิกเลือกโหมดคอมโบ 

 
กอนคลิกเลือกโหมดคอมโบ     หลังคลิกเลือกโหมดคอมโบ 
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เราสามารถเลือกโหมดเครื่องมือตางๆ ไดอีกวิธ ีดวยการกดคีย <Ctrl+Spacebar>  จะปรากฏปอบอัพใหเลือก

โหมดเครื่องมือที่ตองการ หรือใชซอน/แสดงเครื่องมือได 

 
 

 
การยึดแนวแกนในการจัดการวัตถุ 

ตอมาเราจะทําความรูจักกับการยึดแนวแกนในการจัดการวัตถุ หรือที่เรียกวา “Transform Orientation” ใช

สําหรับกําหนดการยึดแกนวัตถุและจะมีผลตอมุมมองของผูใชในการทํางาน โดยจะทํางานรวมกับกลุมเครื่องมือ 

Transformation เสมอ วิธีการกําหนดใชงาน Transform Orientation สามารถทําไดโดยการคลิกซายที่ปุม  

 ในชอง  หรือกดคีย <Alt+Spacebar> 

 
 

คลิกซายที่ปุม  หรือกดคีย <Alt+Spacebar> 
 

เครื่องมือ Transform Orientation จะมีรูปแบบการทํางานทั้งหมด 4 รูปแบบใหเลือกใช ไดแก View, 
Normal, Local, Global 

 
การยึดแนวแกนแบบ Global 
หากเราเลือกใชรูปแบบ Global ซึ่งเปนคาตั้งตนของโปรแกรม การยึดแนวแกนจะยึดตามแกนของวิวพอรตเปน

หลัก สังเกตไดจากเสนแกนตางๆ เมื่อเลือกใชโหมดเครื่องมือ Transformation ใดๆ แกนของเครื่องมือจะตรงกับแกนของ

วิวพอรตเสมอ 
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เม่ือคลิกเลือก Global แกนของเครื่องมือจะตรงกับแกนของววิพอรต 
 

การยึดแนวแกนแบบ Local 
หากเราเลือกใชรูปแบบ Local การยึดแนวแกนจะยึดที่แกนของตัววัตถุที่เลือกอยูนั้นเปนหลัก เมื่อวัตถุมีการหมุน 

แกนของเครื่องมือจะเปลี่ยนไปตามแกนวัตถุ โดยไมสนใจเสนแนวแกนหลักของวิวพอรตจะเปนอยางไร 

 
เม่ือคลิกเลือก Local แกนของเครื่องมือจะเปลี่ยนไปตามแกนวัตถ ุ

 
การยึดแนวแกนแบบ Normal  

หากเราเลือกใชรูปแบบ Normal นั้น การยึดติดวัตถุจะยึดติดกับเสน Normal ซึ่งเปนเสนอางอิงในการปรับแตง

รูปทรง โดยเสน Normal นี้จะมีทิศทางตั้งฉากกับพื้นผิววัตถุแตละแผน สําหรับรูปแบบ Normal นี้ เหมาะสําหรับใชตอน

ปรับแตงพื้นผิววัตถุชนิด Mesh 
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เม่ือคลิกเลือก Normal แกนเครื่องมือจะมีทิศทางตัง้ฉากกับพื้นผิววตัถ ุ

 
 
การยึดแนวแกนแบบ View 

หากเราเลือกใชรูปแบบ View การยึดแนวแกนจะยึดที่มุมมองปจจุบันเปนหลัก และตั้งแนวระนาบ XY สูสายตา

ผูใช สวนแกน Z จะตั้งฉากกับสายตาหรืออยูในแนวพุงออกจากหนาจอ ไมวาจะหมุนมุมมองไปทางใด ระนาบนี้จะอยู

เหมือนเดิมเสมอ 

 
เม่ือคลิกเลือก View แกน Z จะอยูในแนวพุงออกจากหนาจอ 
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การคัดลอกวัตถุ 
การคัดลอกวัตถุในโปรแกรม Blender จะใชคําส่ัง Duplicate โดยวิธีการคัดลอกวัตถุอยางงายคือ ใหคลิกเมาส

ขวาเลือกวัตถุที่ตองการคัดลอก จากนั้นเลือกเมนู Object>Duplicate หรือกดคีย <Shift+D> เมื่อเลือกแลวทดลองเลื่อน

เมาสก็จะพบวัตถุสําเนาปรากฏใหเราเลือกตําแหนงวัตถุจะวาง ใหคลิกเมาสซายเพื่อวางวัตถ ุดังตัวอยางภาพ 
 

1. คลิกเมาสขวาเลือกวัตถ ุ

 
2. คลิกเลือก Object>Duplicate 

 
 

3. เม่ือเลื่อนเมาส วัตถุใหมจะปรากฏ 
 

หากเราทําการคัดลอกวัตถุในมุมมอง Perspective เราจะวางวัตถุสําเนาไดอยางอิสระโดยไมยึดติดระนาบหรือ

แกนใด แตสําหรับบางครั้งเราอาจตองการการวางอยางเปนระเบียบมากกวานี้ สามารถทําได 2 วธิีดังนี ้

Page 85



วิธีที่ 1 : กดคียลัดเลือกแกน หากเราตองการใหวัตถุสําเนาวางตัวยึดตามแนวแกนใดแกนหนึ่ง เมื่อเราเลือก

คําส่ัง Duplicate แลว ใหกดคีย <X> หรือ <Y> หรือ <Z>  เพื่อยึดวัตถุใหอยูในแนวที่ตองการ แลวคลิกเมาสซายวางวัตถุ 

เราจะไดการวางตัวที่ไมคลาดเคลื่อน 

 
เลือกคําสั่ง Duplicate แลว กดคีย <X> เพื่อคัดลอกวัตถุออกมาในแกน X 

 

วิธีที่ 2 : เปล่ียนมุมมองการทาํงาน อีกวิธีหนึ่งในการรักษาระนาบของการคัดลอกวัตถุคือ การเปลี่ยนมุมมอง

เปนแนวระนาบอื่นๆ แทน ซึ่งไดแก มุมมอง Top, Side, Front นั่นเอง ก็จะทําใหการวางตัวอยูในระนาบเดียวกัน 

 
เลือกคําสั่ง Duplicate คัดลอกวัตถใุนมุม Top 

 
การคัดลอกวัตถุเพ่ือสรางวัตถุตนแบบ 

การคัดลอกวัตถุเพื่อสรางวัตถุตนแบบหรือการ “Duplicate Linked” เปนการคัดลอกวัตถุที่คลายกับการ

คัดลอกวัตถุปกติ ซึ่งการคัดลอกแบบปกติจะทําใหวัตถุใหมที่ไดมานั้นมีคุณสมบัติเหมือนวัตถุตนแบบทุกประการ เชน 

รูปทรง ลวดลายพื้นผิวเหมือนกัน   
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แตสําหรับการ Duplicate Linked วัตถุใหมที่คัดลอกมาจะสามารถเปลี่ยนแปลงไดตามการเปลี่ยนแปลงของ

วัตถุตนแบบ กลาวคือเมื่อเราทําการเปลี่ยนแปลงใดๆ กับวัตถุตนแบบ วัตถุอีกชิ้นก็จะเปลี่ยนแปลงตามไปดวย และนี่คือ

ความแตกตางของคําส่ัง Duplicate linked กับ Duplicate ทั่วไป ซึ่งการ Duplicate ทั่วไปไมสามารถทําได 
 
คัดลอกดวยคําส่ัง Duplicate 

 
 

คัดลอกดวยคําสั่ง Duplicate Linked   

 
 
 
วิธีการ Duplicate Linked สามารถทําไดโดยการเลือกเมนู Object>Duplicate Linked หรือกดคีย <Alt+D> 

จากนั้นดึงวัตถุใหมออกมาเหมือนกับการคัดลอกวัตถุทั่วไป ดังภาพ 

 
ทําการ Duplicate Linked คัดลอกวัตถุใหม 

 

วัตถ ุ2 ชิ้น ที่คัดลอกดวยคําสั่ง 
Duplicate 

เม่ือเปลี่ยนวัตถุตนแบบ วัตถทุี่
คัดลอกใหมจะไมเปลี่ยนตาม 

วัตถ ุ2 ชิ้น ที่คัดลอกดวยคําสั่ง 
Duplicate Linked 

เม่ือเปลี่ยนวัตถุตนแบบ วัตถทุี่
คัดลอกใหมจะเปลี่ยนตาม 
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เมื่อมีการปรับแตงวัตถุ โดยใหเขาไปแกไขวัตถุในระดับสวนประกอบยอย หรือใน Edit Mode เราจะพบการ

เปล่ียนแปลงที่ถายทอดกันจากวัตถุตนแบบไปยังวัตถุใหม ซึ่งการคัดลอกปกติไมสามารถปรับแตงได 
 

 
ปรับแตงวัตถุตนแบบใน Edit Mode วัตถุที่คัดลอกออกมาใหมจะเปลี่ยนตามวัตถตุนแบบ 

 
NOTE 
การปรับแตงที่จะทําใหเปล่ียนแปลงไดนั้น ตองเปลี่ยนแปลงกับเฉพาะสวนประกอบยอยของวัตถุเทานั้น ซึ่ง

ทํางานไดใน Edit Mode 

 

 
 
การยึดติดวัตถุเขาดวยกัน 

เปนการทํางานอีกรูปแบบหนึ่งที่ใชวัตถุหลักเปนจุดศูนยกลางในการทํางาน หรือเปนเหมือนศูนยควบคุมวัตถุอื่นๆ 

ใหยึดติดกับวัตถุหลัก โดยเมื่อมีการเคลื่อนที่วัตถุหลักไปทางใด วัตถุอื่นๆ ที่ยึดติดกับวัตถุหลักนั้นก็จะเคลื่อนที่ตามไปดวย 

เชน ตัวถังรถยนตกับลอรถยนต ถาตัวถังรถยนตเปนวัตถุหลัก เรียกวา “Parent” ลอรถนั้นก็จะเปนสวนที่ถูกกระทําใหยึด

ติด โดยจะเรียกวา “Children” 

โปรแกรม Blender จึงเปรียบเทียบวัตถุทั้ง 2 นี้เสมือนกับพอแมและลูกนั่นเอง โดยจะใชคําส่ัง Parent เพื่อยึด

ติดวัตถุเขาดวยกัน ดังนี้ 
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รถยนตรกําลังเคลื่อนที ่
 

 
 

วัตถุหลัก    วัตถุลูก 
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วัตถุแมเคลื่อนทีท่ําใหวตัถุลูกเคลือ่นที่ดวย 
 

วิธีการสรางการยึดติดวัตถุเขาดวยกัน 
การใชคําส่ัง Parent นี้จะใชกับวัตถุตั้งแต 2 ชิ้นขึ้นไป ซึ่งเราจะตองเลือกในใจกอนวาจะใหวัตถุใดเปนแมและ

วัตถุใดเปนลูก จากนั้นทําตามขั้นตอนดังนี้ 

1. คลิกเมาสขวาเลือกวัตถุที่เปนลูกกอน ซึ่งจะเลือกกี่ชิ้นก็ได โดยการกดคีย <Shift> คางไวขณะคลิกเมาสขวา

เลือกวัตถุไปเรื่อยๆ จนชิ้นสุดทายที่เราเลือก 

2. เมื่อเลือกวัตถุตามตองการแลว ขณะกดคีย <Shift> คางอยู ใหคลิกเลือกวัตถุ 

ที่ตองการใหเปนวัตถุแม  

3. คลิกเมาสซายเลือกเมนู Object>Parent>Make Parent โดยมีคียลัดคือ <Ctrl+P>    

4. จะแสดงปอปอัพ ใหเราคลิกเลือก Make Parent เพื่อยืนยันการยึดวัตถุ 

ผลลัพธที่ปรากฏคือ จะแสดงเสนประที่โยงวัตถุทุกชิ้นเขาสูวัตถุแมที่เราเลือกเปนวัตถุสุดทาย แสดงใหเห็นวา

ขณะนี้วัตถุทั้งหมดไดยึดติดกับวัตถุแมหมดแลว  
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1. เลือกวัตถุลูก  
 

  
2. เลือกวัตถุแม 
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3. เลือกเมน ูObject>Parent>Make Parent 
 

 
 

4. เลือก Make Parent 
 

และเมื่อเราเลื่อนวัตถุที่เปน Parent วัตถุ Children จะเลื่อนตามทุกชิ้น แตถาเลื่อนเฉพาะวัตถุ Children วัตถุ 

Parent จะไมเล่ือนตามไปดวย และนี่คือหลักการยึดติดวัตถุของคําส่ัง Parent ซึ่งจะยังผลถึงการใชเครื่องมืออื่นๆ อยาง

การ Rotate และการ Scale อีกดวย 
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หมุนวัตถแุม วัตถุลูกก็จะหมุนดวย 

 

 
ปรับขนาดวัตถุแม วัตถุลูกก็จะปรบัตามดวย 

 

การสราง Children ใหเปน Parent ลําดับถัดมา 
คําส่ัง Parent นี้ยังสามารถทําไดหลายระดับดวยกัน กลาวคือ วัตถุที่เปน Children แลวนั้นก็สามารถเปน 

Parent ของวัตถุอื่นๆ ไดอีก โดยหลักการเลือกวัตถุและใชคําส่ัง Parent ที่เราไดเรียนรูขั้นตนนั่นเอง ดังตัวอยาง เราจะ

สรางใหหนึ่งในวัตถุลูกนั้นกลายเปน Parent สําหรับวัตถุยอยชิ้นอื่นๆ ดังภาพ 

 
 

วัตถุที่เปน Children แลวเปน Parent ของวัตถุอื่น 
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1. คลิกเมาสขวาเลือกวัตถุที่เปนลูกกอน 

2. เมื่อเลือกวัตถุตามตองการแลว ขณะกดคีย <Shift> คางอยู ใหคลิกเลือกวัตถุ Children ที่ตองการใหเปน 
Parent 

3. คลิกเมาสซายเลือกเมนู Object>Parent>Make Parent  

4. คลิกเลือก Make parent เพื่อยืนยันการยึดวัตถุ 

 
 

1. เลือกวัตถุลูกกอน 

 
 

2. เลือกวัตถ ุChildren ของกลุมแรกที่ตองการใหเปน Parent 
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3. เลือกเมน ูObject>Parent>Make Parent 
 

 
 

4. เลือก Make parent 
 

การเลือกวัตถุที่เปน Parent และ Children 
ตอมาเราจะเรียนรูวิธีการเลือกวัตถุที่เปน Parent และ Children เพื่อความสะดวกในการใชงาน ซึ่งเราสามารถ

เลือกวัตถุเปนระดับช้ันได ดังนี้ 

1. คลิกเมาสขวาเลือกวัตถุที่เปน Parent สูงสุดกอน  

2. จากนั้นคลิกเมาสซายเลือกเมน ูSelect>grouped>Children จะพบวาวัตถุที่เปน Children ทั้งหมดภายใต 

Parent นั้นจะถูกเลือก 
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1. เลือกวัตถุที่เปน Parent 
 

 
 

2. เลือกเมน ูSelect>grouped>Children 
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วัตถุที่เปน Children ทั้งหมดจะถูกเลือก 
 

เราสามารถใชคียลัดคือกดคีย <Shift+G> เรียกคําส่ัง Select Grouped ขึ้นมาอีกครั้งได เพื่อใชเลือกวัตถุ ซึ่ง

นอกจากการใชคําส่ัง Select>grouped>Children แลวยังมีลักษณะการเลือกอื่นๆ อีก ดังนี้  

Immediate Children จะเปนการเลือก Children ในระดับแรกสุดภายใต Parent ที่เลือกอยูเทานั้น 

 
 
 

 
 
 

Parent จะเปนการเลือกวัตถุ Parent ในระดับที่อยูเหนือ Children ที่เลือกอยู โดยคําส่ังนี้ เราจะตองคลิกเลือก

วัตถุที่เปน Children กอน 

 
 
 

คลิกเลือก Parent ที่ตองการกอน กดคีย <Shift+G> แลวเลือก Immediate 
Children สังเกตวา Children ในระดับแรก
สุดภายใต Parent จะถูกเลือก 

คลิกเลือก Children ที่ตองการกอน กดคีย <Shift+G> แลวเลือก Parent 
สังเกตวา Parent ของ Children ทีเ่ลือกอยู
นั้นจะถูกเลือกแทน 
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Objects on shared layers จะเปนการเลือกวัตถุที่มีการโยงกันในเลเยอรตางๆ ซึ่งเราจะกลาวถึงการทํางาน

กับเลเยอรในหัวขอตอไป 
 
การยกเลิกการทํา Parent 
คําส่ังในสวนสุดทายคือการยกเลิกการทํา Parent ของวัตถุที่ยึดติดกันอยู ซึ่งสามารถทําไดดังนี้  

1. เลือกวัตถุที่เปน Children (สามารถเลือกหลายวัตถุไดถาตองการยกเลิกการทํางาน Parent กับวัตถุนั้นๆ 

ดวย) 

2. จากนั้นเลือกเมน ูObject>Parent>Clear Parent... หรือกดคีย <Alt+P>  

3. จะมีปอปอัพปรากฏใหยืนยันวิธีการยกเลิก โดยคลิกเมาสซายเลือก Clear Parent จะเปนการยกเลิกพรอม

คืนคาคุณสมบัติตางๆ เชน ขนาดหรือตําแหนง ใหกับวัตถุ Children  

แตถาเลือก Clear and Keep Transformation จะเปนการยกเลิกเสนโยงอยางเดียว และเก็บคาคุณสมบัติที่

เปล่ียนแปลงของ Children เอาไว 
 

1. เลือกวัตถุที่เปน Children 
 

 
 

2. เลือกเมน ูObject>Parent>Clear Parent 
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วัตถุจะยกเลิกการ Parent 
 

การรวมวัตถุ 
นอกจากการยึดติดวัตถุเขาดวยกันดวยวิธีการสราง Parent และ Children แลว เรายังสามารถเลือกใหวัตถุที่

เราเลือกในวิวพอรตยึดติดกัน โดยโปรแกรมจะมองวาวัตถุหลายชิ้นที่ถูกรวมกลุมนั้นเปนวัตถุกอนเดียวกัน ซึ่งไมวาเราจะ

เปล่ียนแปลงวัตถุอยางไร วัตถุทั้งหมดก็จะถูกเปล่ียนแปลงตามกันทั้งหมด  

วิธีการรวมกลุมวัตถุเราจะใชคําส่ัง Join โดยคลิกเลือกวัตถุที่ตองการรวมกลุมกอน จากนั้นเลือกเมนู 

Oblect>Join Object หรือกดคีย <Ctrl+J> 

 
 

1. เลือกวัตถุหลายชิ้น 
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2. เลือก Object>Join Object 
 

 
 
3. วัตถุจะรวมกลุมกัน และเมื่อมีการเปลี่ยนตําแหนงทกุวัตถุจะเคลื่อนยายตามกัน 

 
การลบวัตถุ 

สําหรับการลบวัตถุในโปรแกรม Blender นั้นสามารถทําไดโดย ใหคลิกเลือกวัตถุที่ตองการลบ (หรือคลิกเลือก

หลายวัตถุก็ได) จากนั้นเลือกเมนู Object>Delete จะปรากฏคําส่ัง Delete Selected Object(s) ใหเราคลิกเมาสซาย

เพื่อยืนยันการลบวัตถุ นอกจากนั้นเรายังสามารถกดคีย <x> หรือคีย <Delete> เพื่อลบวัตถุไดเชนกัน 
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กดคีย <x> หรือคีย <Delete> เพื่อลบวัตถ ุโดยใหเลือก Delete Selected Object(s) 
 

การ Boolean วัตถุ 
อีกการทํางานหนึ่งที่นาสนใจสําหรับการทํางานกับวัตถุนั่นคือ การ Boolean วัตถุ ซึ่งเปนการนําหลักการ 

Boolean ทางคณิตศาสตรมาใชการการสรางและทํางานกับวัตถุของเรา โดยหลักการ Boolean มีดังนี้ 

 
 

สําหรับการ Boolean ในโปรแกรม Blender นั้น จะเปนการกระทํากับวัตถุตั้งแต 2 ชิ้นขึ้นไป โดยใหเราคลิก

เลือกวัตถุที่จะทําการ Boolean จากนั้นเลือกเมนู Object>Boolean Operation... จะปรากฏปอบอัพใหเราเลือก

รูปแบบการ Boolean  โดยใหเราคลิกเลือกตามตองการ  

ดังตัวอยางเราจะใชรูปทรง Cube หรือส่ีเหลี่ยมลูกบาศก 2 ลูกมาทําการ Boolean ดังตัวอยาง 

  
Cube 2 ลูกมาทําการ Boolean 
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1. คลิกเลือกวัตถุทั้ง 2 วัตถุ 

2. เลือกเมนู Object>Boolean Operation... หรือกดคีย <W> 

3. จะปรากฏปอบอัพใหเราเลือกรูปแบบการ Boolean ทดลองคลิกเลือก Intersect เปนการสรางวัตถุใหมจาก

สวนที่ซอนทับกันของวัตถุทั้งสอง 

4. ลากเมาสเลือกวัตถุตนแบบทั้งสองออก จะพบวัตถุใหมปรากฏบนวิวพอรต  

ซึ่งการ Boolean ชนิดอื่นก็ใชวิธีการเชนเดียวกัน 

     
 

1. เลือกวัตถุทั้ง 2 ชิ้น  2. เลือกเมน ูObject>Boolean Operation 
 

 
 

3. คลิกเมาสซายเลือก Intersect 4. เม่ือเลื่อนเมาสออกมา จะไดวตัถุใหมที่เกิดจากการ intersect 
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   วัตถตุนแบบ 
 

         
 
 
 
   
 

                                                
 
 
 
 
 

Intersect : สรางวัตถุจากสวน
ที่ซอนทับกัน 

Union : สรางวัตถุจากการ
รวมวัตถทุี่เลือกใหวัตถุเปนชิน้
เดียวกัน 

ถาเราคลิกเลือกวัตถุดานบนกอน 
จึงเปนการตัดวตัถุดานลางที่เลือก
ภายหลังออกไป 

ถาเราคลิกเลือกวัตถุดานลางกอน จึง
เปนการตัดวัตถดุานบนที่เลือก
ภายหลังออกไป 

Different : สรางวัตถุจากการตดัเอาสวนตางของวตัถุที่
เลือกภายหลังสุดออก 
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Add Intersect Modifer : สราง
วัตถุจากการรวมสวนที่เกิดจาก
การ Insect ของวัตถุทัง้สอง มา
รวมกับวัตถุที่ถูกเลือกเปนชิ้นแรก 

Add Union Modifer : สรางวตัถุ
จากการรวมสวนที่เกิดจากการ 
Union ของวตัถทุัง้สอง มารวมกับ
วัตถุทีถู่กเลือกเปนชิ้นแรก 

Add Diffrent Modifer : สรางวตัถุ
จากการรวมสวนที่เกิดจากการ 
Diffrent ของวัตถทุั้งสอง มารวม
กับวัตถุที่ถูกเลือกเปนชิ้นแรก 
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บทที่ 5 
สรางโมเดลแบบ Mesh 

 
หนึ่งในรูปแบบการสรางโมเดลของโปรแกรม Blender นั้นคือ การสรางโมเดลจากวัตถุที่มีโครงสรางแบบ Mesh 

ซึ่งเปนโครงสรางที่มีพื้นผิวเรียงตอกันจนเกิดเปนวัตถุ โดยถือเปนวัตถุพื้นฐานและเหมาะจะเปนวัตถุตนแบบที่จะนําไปสราง

วัตถุที่ซับซอนมากขึ้น 

 
รูจักับวัตถุแบบMesh 

โมเดลแบบ Mesh ใชเปนรูปแบบโมเดลพื้นฐาน โดยมีโครงสรางของพื้นผิวยอยที่เรียงตอกันจนกระทั่งเกิดเปน

วัตถุ 3 มิติ ในโปรแกรม Blender นั้น ไดจัดเตรียมวัตถุพื้นฐานใหกับเรา เพื่อใชเปนวัตถุตนแบบในการขึ้นโมเดลที่ซบซอน

ตอไป โดยในหัวขอนี้เราจะมาเรียกรูจักกับวิธีการสรางวัตถุ Mesh พื้นฐาน และชนิดของวัตถุ Mesh แตละชนิด ดังตอไปนี้ 

 
การสรางวัตถุ Mesh 

การสรางวัตถุ Mesh นั้น เราจะเลือกสรางจากเมน ูAdd>Mesh จากนั้นจะปรากฏรายชื่อชนิดวัตถุ Mesh 

ขึ้นมาใหเลือกสราง เมื่อคลิกซายเลือกชื่อวัตถุ วัตถุก็จะถูกสรางที่บนวิวพอรต ณ ตําแหนงของ Cross Hair Cursor โดยใน

ตัวอยางนี้เราจะเลือกสรางวัตถุ UVSphere ซึ่งเปนวัตถุรูปทรงกลม ดังวิธีการตอไปนี ้

  1. คลิกเมาสวาง Cross Hair Cursor ในตําแหนงที่ตองการสรางวัตถุ 

  2. เลือกเมนู Add>Mesh จากนั้นคลิกเมาสซายเลือกวัตถุที่จะสราง ในตัวอยางเลือก UVSphere หรือสามารถ

เรียกเมนู Add ไดดวยการกดคีย <Spacebar> 

  3. จะปรากฏปอบอัพถามถึงจํานวน Segment หรือเสนแบงพื้นผิวออกเปนสวนๆ ในแนวตั้ง, จํานวน Ring หรือ

เสนรอบวงแนวนอน และขนาดของรัศมีทรงกลม Radius ใหเราคลิกเมาสซายที่ปุม    เพื่อลดจํานวน หรือคลิกที่ปุม    

เพื่อเพิ่มจํานวน (หรือคลิกเมาสซางคางไวแลวลากเมาสไปทางซายเพื่อลด หรือคลิกเมาสซายคางไวแลวลากเมาสไป

ทางขวาเพื่อเพิ่มจํานวน)  ใหเราเลือกจํานวนที่ตองการแลวคลิกปุม   

  วัตถุก็จะถูกสรางที่บนวิวพอรต ณ ตําแหนงของ Cross Hair Cursor ซึ่งโดยคาตั้งตนจะอยูตรงกลางตําแหนงที่

แกนทั้ง 3 ตัดกันที่จุด Origin 
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1. คลิกเมาสวาง Cross Hair Cursor 

 
2. เลือกเมน ูAdd>Mesh>UVSphere 
 

 
3. ระบุจํานวน Segment, Rings และ Radius ตามตองการแลวกดปุม OK 
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วัตถุจะถูกสราง ณ ตําแหนง Cross Hair Cursor 

 
หลังจากที่เราสรางวัตถุ โปรแกรม Blender จะเปลี่ยนโหมดการทํางานเขาสู Edit Mode ซึ่งถาเราตองการ

ทํางานกับวัตถุทั้งชิ้นก็ใหเราคลิกเปลี่ยนโหมดเปน Object Mode ใน    หรือกดคีย <Tab> เพื่อ

เปนการสลับระหวาง Edit Mode กับ Object Mode 

 
          วตัถุที่อยูใน Edit Mode          วัตถุท่ีอยูใน Object Mode 

 
ชนิดของวัตถุ Mesh 

ดังที่กลาวไปแลววาโปรแกรม Blender ไดเตรียมวัตถุ Mesh พื้นฐานใหเราไดเลือกใชขึ้นโมเดลอยางรวดเร็ว 

ดังนี้ 
วัตถุ Plane 
เปนวัตถุที่มีรูปทรงเปนแผนระนาบ มักใชกับการทําเปนภูมิประเทศจําพวกพื้นดิน ทะเล ภูเขา หรือทําเปนพื้นหลัง

ของฉาก หรือเพดานหอง เปนตน จึงเห็นไดวา โมเดลใดที่มีโครงสรางมาจากแผนแบนราบ ก็สามารถใช Plane ในการขึ้น

รูปไดทั้งหมด 

                                  
ตัวอยางวตัถ ุ   ตัวอยางโมเดลทีส่รางจากวัตถุนี ้
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วัตถ ุCube 
เปนวัตถุรูปทรงกลองส่ีเหลี่ยม โดยเริ่มตนจะเปนลูกบากศซึ่งดานเทาทุกดาน แตสามารถปรับแตงความยาวแตละ

ดานไดอิสระ มักใชกับโมเดลที่มีรูปทรงพื้นฐานเปนส่ีเหลี่ยม เชน อาคาร หนังสือ กลอง เปนตน และ Cube นี้สามารถ

ปรับแตงรูปทรงเปนโมเดลที่ซับซอนกวาส่ีเหลี่ยมได 

                                 
 

ตัวอยางวตัถ ุ   ตัวอยางโมเดลทีส่รางจากวัตถุนี ้
 

วัตถ ุCircle 
เปนเสนวงกลม ซึ่งสามารถนําไปใชขึ้นโมเดลที่มีลักษณะเปนวงกลม เชน ลอรถ โดยที่เราสามารถเติมพื้นผิว

ภายในวงกลมไดภายหลัง  

 
ตัวอยางวตัถ ุ   ตัวอยางโมเดลทีส่รางจากวัตถุนี ้

 
วัตถุ UVsphere และ IcoSphere  
วัตถุทั้ง 2 ชนิดนี้เปนวัตถุทรงกลมเหมือนกัน แตจะแตกตางกันที่โครงสรางพื้นผิว ซึ่งถาสังเกตที่พื้นผิวยอยของ

วัตถุ UVsphere จะเปนพื้นผิวส่ีเหลี่ยม แตสําหรับวัตถุ IcoSphere จะเปนสามเหลี่ยม ดังนั้นเวลาปรับแตงรูปทรงก็จะ

แตกตางกันดวย แตผลลัพธภายนอกจะไดวัตถุทรงกลมเหมือนกัน  

วัตถุ 2 ชนิดนี้จะใชสําหรับขึ้นโมเดลที่มีพื้นฐานมาจากทรงกลม หรือวัตถุพื้นผิวโคงตางๆ เชน ลูกบอล ลูกโปง 

ผลไม หลอดไฟ หรือใชในการขึ้นโมเดลสวนหัวของมนุษย 

         
      ตวัอยางวตัถ ุUVsphere         ตวัอยางวตัถ ุIcoSphere           ตัวอยางโมเดลที่สรางจากวัตถนุี้ 

Page 108



วัตถ ุCylinder 
เปนวัตถุรูปทรงกระบอก ซึ่งสามารถใชขึ้นรูปโมเดลจําพวกเสาไฟ ตนไม ขวดน้ํา กระปอง เปนตน 

 
 

ตัวอยางวตัถ ุ  ตัวอยางโมเดลทีส่รางจากวัตถุนี ้
 

วัตถุ Cone 
มีลักษณะเปนวัตถุทรงกรวย เราสามารถขึ้นโมเดลจําพวกหลังคา จรวด หรือวัตถุที่มีปลายแหลมตางๆ ได เปนตน 

 
 

ตัวอยางวตัถ ุ   ตัวอยางโมเดลทีส่รางจากวัตถุนี ้
 

วัตถุ Grid 
มีลักษณะเปนแผนส่ีเหลี่ยมเหมือนกับ Plane แต Grid นั้นจะประกอบดวยจุด Vertex จํานวนมาก ซึ่งเรา

สามารถปรับแตงจุดแตละจุดเพื่อใหไดรูปทรงที่ตองการได 

   
ตัวอยางวตัถ ุ     ตัวอยางโมเดล 
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วัตถุ Monkey  

เปนวัตถุสําเร็จรูปที่มีรูปทรงเปนหนาลิง ซึ่งเปนรูปทรงที่ใช

สําหรับการทดสอบเรื่องแสงเงา หรือลวดลายพื้นผิว เนื่องจากรูปทรงนี้

มีซอกมุมและสวนเวานูนพอสมควร จึงสะดวกใชในการทดสอบบาง

เรื่องไดงายโดยไมตองเสียเวลาขึ้นรูปโมเดลใหม แตอยางไรก็ตาม 

รูปทรงหนาลิงนี้สามารถปรับแตงแกไขไดหากตองการใชเพื่อ

จุดประสงคอื่น เพราะมีคุณสมบัติเหมือนวัตถุ Mesh ชนิดอื่นๆเชนกัน 
 
 
วัตถุ Torus 
มีลักษณะเปนหวงคลายทรงโดนัท ประกอบดวยจุด Vertex จํานวนมาก ซึ่งเราสามารถปรับแตงจุดแตละจุด

เพื่อใหไดรูปทรงที่ตองการได 

                     
  ตัวอยางวัตถ ุ       ตัวอยางโมเดล 

 
รูจักกับโครงสรางและการปรับแตงพืน้ผิวของวัตถ ุMesh 

หัวขอนี้เราจะมาทําความรูจักกับโครงสรางวัตถุ Mesh และการปรับแตงวัตถุใน Edit Mode โดยเมื่อเราสราง

วัตถุขึ้นมาแลว โปรแกรมจะเขาสู Edit Mode อยางอัติโนมัติ ซึ่งจะทําใหเรามองเห็นสวนประกอบยอยของวัตถุไดชัดเจน 

และจากนี้ไปเราก็สามารถปรับแตงวัตถุจากสวนประกอบยอยของวัตถุได โดยมีทั้งหมด 3 สวนดวยกัน คือ จุด (Vertex), 

เสนขอบ (Edge) และพื้นผิวยอย (Face) สังเกตุวาสวนที่เราเลือกจะมี Highlight สีมวงแสดงบริเวณที่เราเลือก  

 จุด (Vertex)   จุดที่ถูกเลือกจะกลายเปนสีเหลือง 
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     เสนขอบ (Edge) เสนขอบที่ถกูเลือกจะกลายเปนสีเหลืง 

  พื้นผิวยอย (Polygon) พื้นผิวที่เราเลือกจะปรากฏจุดสีสม 

 

การเขาสูการแกไขวัตถุ Mesh 
เริ่มจากใหเราเขาสู Edit Mode กอน จากนั้นเราก็จะสามารถเลือกสวนประกอบยอยของวัตถุเหลานี้ในการ

ปรับแตงได จากการเลือกที่ปุม    สําหรับเลือกจุด (Vertex), เสนขอบ (Edge) และพื้นผิวยอย (Face) 

ตามลําดับ 

 
เม่ือเขาสู Edit Mode เราสามารถเลือกสวนประกอบยอยของวัตถุไดจากเครื่องมือนี้ 
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สวนสัญลักษณ     ใชสําหรับซอน/แสดงพื้นผิวที่อยูดานหลังดังภาพ โดยเมื่อเราเลือกใหแสดงพื้นผิวที่อยู

ดานหลังจะชวยใหเราสะดวกมากขึ้นในการปรับแตงวัตถุในระดับยอย ซึ่งจะทําใหเรามองเห็นความเปลี่ยนแปลงในสวน

ดานหลังของวัตถุไดชัดเจน 

 
ซอนพื้นผิวที่อยูดานหลังดังภาพ         แสดงพื้นผวิทีอ่ยูดานหลังดังภาพ 
 

เริ่มการปรับแตงวัตถุ 
ในการเลือกปรับแตงวัตถุนั้น เราจะใชวิธีคลิกเมาสปุมขวาไปยังสวนที่เราตองการเลือก เชน ถาเรากําลังอยูใน

สวนของ Vertex  เราสามารถคลิกขวาเลือกจุด Vertex   ที่ตองการ และใชเครื่องมือ Transformation 

ตางๆ (การเคลื่อนยาย การหมุน และการปรับขนาด) เขามาปรับแตงได ดังตัวอยางเราจะทดลองดึงจุดใดจะหนึ่งของวัตถ ุ

UVSphere ออกมา  

 

คลิกเมาสขวาเลือกจุด Vertex   ใชเครื่องมือ  เพื่อดึงจุดนั้นออกมา 

                     ผลลัพธหลงัการดึงจดุ 

เราสามารถเลือกจุดเพิ่มไดดวยการกดคีย <Shift> คางไวแลวคลิกเมาสขวาเลือกจุดอื่นเพิ่มเรื่อยๆ ตามตองการ 

ดังตัวอยาง 
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                  คลิกซายเลือกจุดหลายจุด 

 
       ใชเครื่องมือ   เพื่อดึงจุดทั้งหมดออกมา                 ผลลพัธหลังการดึงจดุ 
 

มีอีกวิธีหนึ่งที่ทําใหการเลือกสะดวกขึ้น คือการลากพื้นที่เลือกสวนที่ตองการ หรือเรียกวา Border Select ใหเรา

กดคีย <B> และคลิกเมาสซายลากพื้นที่ครอบคลุมสวนที่ตองการเลือก หรือกดคีย <Alt> ขณะลากเพื่อลบจุดที่ไมตองการ

ออก 

 
 

 
 

 
กดคีย <Alt> ขณะลากเพื่อลบจุดที่ไมตองการออก 

 

คีย <B> พรอมคลิกและลากเมาสซาย
ครอบคลุมสวนทีต่องการเลือก 

ผลลัพธหลงัการเลือก จุดใดที่อยูใน
ขอบเขตการเลือกและถูกเมาสลาก
ผานจะถูกเลือก 
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สําหรับวัตถุที่มีสวนประกอบจํานวนมากและซับซอน เราสามารถเลือกสวนเหลานั้นดวยวิธีการระบายสวนที่

ตองการ เรียกวา “Paint Select” วิธีการคือการกดคีย <B> 2 ครั้ง เมาสจะเปลี่ยนเปนรูปวงกลมมีกากบาทตรงกลาง 

จากนั้นใหคลิกเมาสซายระบายไปยังสวนตางๆ ของวัตถุไมวาจะเปน Vertex, Edge, หรือ Face  

 
 
 
 
 

นอกจากนั้นเรายังสามารถปรับขนาดหัวระบายได โดยการกดคีย <+> เพื่อเพิ่มขนาด และคีย <‐> เพื่อลดขนาด

ได ซึ่งวิธีนี้จะทําใหเราไดพื้นที่ๆ ตองการแมเปนวัตถุที่มีรายละเอียดมากก็ตาม 
 
การแสดงผลวัตถุในวิวพอรต 
โดยปกติเราจะเห็นวัตถุ Mesh ที่มีพื้นผิวและแสงเงาในวิวพอรต เปนคาตั้งตนของโปรแกรม ซึ่งเราสามารถเลือก

ใหแสดงเฉพาะโครงสรางของวัตถุได โดยการ คลิกเมาสซายเลือกปุม  (Draw Type) แลวเลือก Wireframe จะเห็นวัตถุ

เปนเพียงแคโครงสราง ซึ่งการแสดงโครงสรางนี้จะทําใหสะดวกในการเลือกดานและมุมของวัตถุในการปรับแตง และไมใช

การลบพื้นผิววัตถุ แตซอนไวเทานั้น 

 เลือก Draw Type แลวเลอืก Wireframe 
 

คีย <B> พรอมคลิกและลากเมาสซาย
ครอบคลุมสวนทีต่องการเลือก 

คลิกและลากเมาสซายเพื่อระบายใน
สวนทีต่องการเลอืก 
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   กอนเปลี่ยน    หลังเปลี่ยน 

 

การปรับแตงวัตถุ Mesh แบบตางๆ 
นอกจากการปรับแตงรูปทรงวัตถุดวยกลุมเคร่ืองมือ Transformation แลว เรายังสามารถเลือกใชคําส่ังตางๆ 

มาเพิ่มความหลากหลายในการปรับแตงวัตถุไดอีก เชน คําส่ัง Subdivide, Loop cut, Bevel, Extrude เปนตน ซึ่งคําส่ัง

เหลานี้จะอยูในสวนของ Editing ภายใตหนาตาง Button Window ของ Edit Mode โดยเราสามารถคลิกซายที่ปุม 

   หรือกดคีย <F9> ที่คียบอรดก็ได 

 
ขณะทํางานกับวตัถุใน Edit Mode ใหคลิกปุม  เขาสู Editing เพื่อปรับแตงวัตถ ุ

 

 
 
เพ่ิมรายละเอียดโครงสรางใหกับวัตถุดวย Subdivide 

Subdivide เปนการเพิ่มรายละเอียดโครงสรางใหกับวัตถุ เมื่อเราคลิกเลือกคําส่ัง Subdivide วัตถุจะมีจํานวน

โครงสรางเพิ่มขึ้นทั้ง Vertex, Edge, และ Face ซึ่งจุดประสงคของการใชคําส่ังนี้ก็คือ การทําใหวัตถุมีรายละเอียดมากขึ้น 

เพื่อการสรางโมเดลที่มีรายละเอียดมากขึ้นนั่นเอง 

 
กอนทํา Subdivide    หลังทํา Subdivide 
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วิธีการใช Subdivide สามารถทําไดโดยเลือก Vertex ทั้งหมดของวัตถุที่ตองการกอน (โดยเขาสู Edit Mode 

แลวกดคีย <A> 2 ครั้ง) จากนั้นใหคลิกเลือกปุม   ที่หัวขอ Mesh Tools ในหนาตาง Buttons Window และ

หากเราคลิก เลือกปุม Subdivide ซ้ําก็จะเปนการเพิ่มรายละเอียดใหกับวัตถุอีกระดับหนึ่ง 

 คลิกเลือกปุม  

 
เม่ือคลิกปุม  ซํ้าวัตถ ุMesh จะยิ่งละเอียดมากยิ่งขึ้น 

 

หากตองการยอนกลับการใชคําส่ังนี้ ใหกดคีย <Ctrl+Z> เพื่อยกเลิกการเพิ่มรายละเอียดครั้งลาสุด และสามารถ

กดคีย <Ctrl+Z> ซ้ําเพื่อยอนกลับการทํางานไปเรื่อยๆ 
 

ตัดแบงสวนตางๆของวัตถุดวย Loop/Cut 
Loop/Cut Menu เปนชุดคําส่ังสําหรับเพิ่มรายละเอียดโครงสรางดวยการตัดแบงสวนตางๆ ของวัตถุ ซึ่งตาง

จากคําส่ัง Subdivide ตรงที่คําส่ัง Subdivide จะเปนการเพิ่มรายละเอียดใหวัตถุตามโครงสรางเดิมหรือตาม

สวนประกอบยอยเดิม แตคําส่ังใน Loop/Cut Menu จะเปนการเพิ่มรายละเอียดของวัตถุแบบอิสระ 

        
กอนทํา Loop Cut       หลัง Loop Cut 
 

วิธีการใช Loop/Cut Menu สามารถทําไดโดยคลิกเลือกคีย <K> ซึ่งในเมนูนี้จะมีคําส่ังในการตัดแบงโครงสราง

วัตถุอยู 4 คําส่ังที่มีรูปแบบตางกันไปไดแก Loop Cut, Knife (exact), Knife (midpoint) และ Knife (multicut) 
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Loop Cut เมื่อเลือกคําส่ังนี้แลวจะปรากฏเสนรอบโครงสรางวัตถุขึ้นมา เพื่อใหเราเลือกตัดตามกรอบนอกของ

วัตถุนั่นเอง ใหเราเลื่อนเมาสเพื่อเลือกแนวที่จะตัด แลวคลิกเมาสซาย 1 ครั้ง จากนั้นเลื่อนเมาสเพื่อเลือกตําแหนง และคลิก

อีก 1 ครั้ง เพื่อทําการตัด ก็เปนอันเสร็จส้ินการตัดแบงดวยคําส่ังนี ้โดยหลังจากการตัดวัตถุก็จะมี Vertex, Edge, และ 

Face เพิ่มขึ้นจากการตัดในครั้งนี้ (ซึ่งการใช Loop Cut สามารถกดคีย <Ctrl+R> ไดโดยตรง โดยไมตองกดคีย <K> แลว

คอยเลือกคําส่ัง) 

 
 

 
 
 
 

 
 
 

Knife (exact) เปนคําส่ังที่เราสามารถเลือกตําแหนงการตัดแบงไดอยางอิสระ โดยเมื่อเลือกวัตถุสวนที่ตองการ

ตัดแลว ใหเริ่มตัดจากการคลิกซายที่พื้นที่วาง และเลือนเมาสพาดวัตถุเพื่อเลือกแนวตัด จากนั้นคลิกซายเพื่อยืนยันแนวตัด 

แลวกดคีย <Enter> เพื่อทําการตัด โปรแกรมก็จะตัดโครงสรางวัตถุตามแนวที่เราเลือก โดยที่จะเพิ่มโครงสรางยอยๆ 

ขึ้นมาเพื่อรักษาสวนประกอบที่เปนส่ีเหลี่ยมและสามเหลี่ยมเอาไว 

1. กดคีย <K> แลวเลือกแนวของเสนรอบ
โครงสรางวตัถ ุเม่ือเลือกแลวคลิกเมาสซาย 1 ครั้ง 

2. เลื่อนเมาสเพื่อเลือกตําแหนง และคลิกเมาส
ซายอีก 1 ครั้ง เพื่อทําการตัด 

3. วัตถุหลังการตดัดวยเครื่องมือ Loop Cut 
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Knife (midpoint) ซึ่งจะใชงานเหมือนกับ Knife (exact) แตสําหรับเครื่องมือ Knife (midpoint) จะตัดวัตถุ

เปนแนวตรงกลางระหวางจุด 2 จุดที่เราลากเครื่องมือผานไปนั่นเอง 

 
ขณะใช Knife (midpoint)     หลังการตัดดวย Knife (midpoint) 
 

Knife (multicut) เปนคําส่ังที่ทําใหเราสามารถตัดวัตถุไดครั้งละหลายเสน เมื่อเลือกคําส่ังนี้แลวจะมีชองให

กําหนดจํานวนเสนที่จะตัด เราสามารถกําหนดดวยการคลิกซายที่ลูกศรเพื่อเพิ่มหรือลดจํานวนหรือคลิกที่ตัวเลขเพื่อพิมพ

คา เมื่อกําหนดจํานวนแลว จะทําใหในการสั่งตัดครั้งเดียวของเรานั้น ไดจํานวนเสนตามที่กําหนดทันท ีซึ่งประหยัดเวลา

มากกวาการใชคําส่ังขางตน 
 

 

       
 
 
 
 

1. คลิกเมาสซายแลวลากเมาสผานพื้นที่สวนที่
ตองการตัด แลวคลิกเมาสซายอีกครั้ง 

2.กดคีย <Enter> เพื่อตัดวัตถุตามแนวที่เลือก 

1. เลือกวัตถุในสวนทีต่องการตดั แลวกดคีย 
<K> เลือก Knife (multicut) 

2. กําหนดจํานวนเสนที่จะตดั แลวคลิกปุม  
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ลบเหล่ียมของวัตถุใหโคงมนดวย Bevel 
Bevel ปนคําส่ังที่ใชสําหรับการลบเหลี่ยมหรือมุมของวัตถุ ใหมีความโคงมนมากขึ้นนั่นเอง โดยการทํางานดวย

คําส่ัง Bevel นั้น เราจะตองอยูภายใต Edit Mode เสียกอน สวนการเรียกคําส่ังขึ้นมาใชนั้นใหกดคีย <W> ที่คียบอรด 

โดยในตัวอยางเราจะปรับใหวัตถ ุCube ใหมีมุมที่โคงมนมากขึ้น ดังภาพ 
 

 
กอน Bevel        หลัง Bevel 

1. เมื่อวัตถุอยูใน Edit Mode ใหกดคีย <W> เพื่อเรียกใชเครื่องมือ Bevel ปอบอัพ Specials จะปรากฏขึ้นมา 

ใหคลิกเมาสซายเลือกที่คําส่ัง Bevel 

2. เล่ือนเมาสไปทางซายหรือขวาเพื่อกําหนดระยะของการทํา Bevel เมื่อไดระยะแลวใหคลิกซายเพื่อยืนยัน 

จากผลลัพธจะเห็นไดวาขอบมุมตางๆ มีความโคงมนตามระยะที่เรากําหนดไว ซึ่งเราสามารถกําหนดใหมีความ

โคงมนที่ละเอียดขึ้นไดโดยทําซ้ําตามขอ 1 และ 2 ตามเดิม 

 
 

 
 

      
  

3. คลิกและลากเมาสซายเพื่อกําหนดสวนที่
ตองการตัด แลวคลิกซายเพื่อยืนยัน 

หลังการตดัดวย Knife (multicut) จะไดจํานวน
สวนยอยตามตัวเลขที่กําหนด 

1. กดคีย <W> แลวคลิกเมาสซายเลือก Bevel 2. เลือกเมาสเพื่อกําหนดระยะของการ
ทํา Bevel เม่ือไดระยะแลวใหคลิกซาย

Page 119



  
 
 

ปรับสวนประกอบของวัตถุใหยืดออกหรือถูกผลักเขาไปดวย Extrude  
Extrude เปนคําส่ังที่ใชสําหรับปรับแตงสวนประกอบของวัตถุใหขยายหรือถูกผลักเขาไปในรูปแบบตางๆ ซึ่ง

คําส่ังนี้จะอยูภายใต Edit Mode ในตัวอยางนี ้เราจะทําการเลือก Face ของวัตถุขึ้นมา 1 Face จากนั้นเรียกใชคําส่ัง 

Extrude เพื่อใหไดผลลัพธดังภาพ  

 
กอน Extrude      หลัง Extrude 

1. เขาสูการ Extrude ดวยการกดคีย <E> ที่คียบอรด    

2. จากนั้นจะเห็นเสนแกนที่จะเล่ือนพื้นผิวขึ้นมา เราอาจใชแนวแกนตามทิศทางของพื้นผิว หรือล็อคการทํางาน

กับแตละแกนตองการไดดวยการกดคีย <X> <Y> หรือ <Z> ตามตองการได จากนั้นเลื่อนเมาสเพื่อกําหนดการขยายหรือ

หดเขาของวัตถ ุและคลิกซายเพื่อยืนยันการเปลี่ยนแปลง 

  1. กดคีย <E> 

 
 

 
 
 
 

2. กดคีย <Y> ลอ็กแกน Y แลวเลื่อนเมาส
ทําการ Extrude เฉพาะพื้นที่ๆ เลือก 
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เราสามารถเลือกสวนประกอบยอยของวัตถุไดครั้งละมากกวา 1 สวนได เชน เลือก Face 2 หนาพรอมกันดวย

การกดคีย <Shift> แลวคลิกเมาสซายทําการเลือก จากนั้นใหใชคําส่ัง Extrude จะพบตัวเลือกคือ  Region และ 
Individual Faces  

 
ทําการ Extrude พรอมกันในหลายๆ สวนประกอบยอย 

 

• Region จะทําใหการ Extrude สงผลตอทั้ง 2 หนาในทิศทางเดียวกัน 

• Individual Faces จะทําใหการ Extrude สงผลตอแตละดานในทิศทางตามที่พื้นผิวนั้นๆ สามารถไปได 
 

       
 
 
 
 
 

ตกแตงวัตถุใหโคงมนดวยวิธีการ Subdivision Surface 
สําหรับวัตถุบางชนิดที่เราใชโปรแกรม Blender สรางเพื่อเลียนแบบนั้น อาจเปนวัตถุที่มีความโคงมน แตถา

สังเกตจากวัตถุพื้นฐานที่ถูกสรางขึ้น หากเราเรนเดอรวัตถุนั้น ก็จะเห็นวาพื้นผิววัตถุเปนพื้นผิวแบนวางตอกัน ซึ่งปญหานี้

เราสามารถแกไดดวยวิธีการ Subdivision Surface 

Region: พื้นผิวแตละพื้นผิวที่เลือก
จะถูกยืดไปทางเดียวกัน 

Individual Faces: พื้นผิวแตละพื้นผิวที่ถูกเลือกจะถูก
ยืดในแนวตั้งฉากกับพื้นผิวเดิม 
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โดยหลักการของ Subdivision Surface นี้จะเพิ่มจํานวนพื้นผิวใหหนาแนนมากขึ้น ซึ่งจะทําใหโครงสรางเดิมที่

เปนเหลี่ยมมากมีความโคงมนขึ้นตามระดับที่เราตองการได จากรูปตัวอยางเปนการเปรียบเทียบวัตถุชนิดเดียวกันที่เปน

วัตถุตนฉบับและวัตถุที่ผานคําส่ัง Subdivision Surface มาแลว ซึ่งใหผลการแสดงพื้นผิวที่นุมนวลกวา 
 

 
กอนทําการ Subdivision Surface  หลังทําการ Subdivision Surface 
 

จากภาพจะเห็นวาเมื่อมีการแกไขวิธีการ Subdivision Surface จะทําใหวัตถุมีความโคงมนมากขึ้น โดยขั้นตอน

การทํางานมีดังนี้ 

1.  ขณะเลือกวัตถุอยูนั้น ไมวาเราจะทํางานในโหมดใดก็ตาม ใหเราคลิกปุม  ที่หัวขอ Modifier ใน 

Buttons Window จากนั้นเลือก Subsurf 

2.  จากนั้น จะปรากฏคาพารามิเตอรใหเราเลือกปรับแตงเกี่ยวกับพื้นผิวยอยของวัตถุ ใหเราคลิกปรับคา 

Levels เปน 2 หรือมากกวาถาตองการใหมีความโคงมนมากขึ้น 

3.  คลิกปุม  ที่หัวขอ Link and Materials เพื่อปรับใหพื้นผิวที่แบน มีความโคงมนแบบสมบูรณ 
 

 
1. ขณะเลือกวัตถ ใหคลิกปุม  จากนัน้เลือก Subsurf 
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2. ปรับคา Levels เปน 2 หรือมากกวา 

 

 
3. คลิกปุม  เพื่อปรับใหพื้นผิวใหโคงมน 

 

คา Levels ที่เรากําหนดนั้น เปนเพียงการกําหนดความละเอียดพื้นผิวที่แสดงอยูของวัตถุในวิวพอรตเทานั้น หาก

เราตองการใหวัตถุจริงมีความละเอียดตามที่เห็นดวยเมื่อทําการประมวลผลภาพไปแลว ใหเรากําหนด Render Levels ซึ่ง
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มีวิธีการกําหนดเหมือนกันกับ Levels ซึ่งคาของ Levels และ Render Levels นั้นไมจําเปนตองเทากัน ขึ้นอยูกับวาผูใช

ตองการความละเอียดในการแสดงผลเทาใด และความละเอียดในการประมวลผลภาพออกไปเทาใดเปนหลัก 
 

 
ปรับคาความละเอียดในววิพอรตไดที ่Levels ปรับคาความละเอียดในการเรนเดอรไดที ่Render Levels 

สาเหตุที่เราตองเขาไปกําหนดคาความละเอียดใน Render Levels อีกครั้งเนื่องจากการทํางานในวิวพอรต

บางครั้งอาจตองการประหยัด Resorce เพื่อใหลดการใชทรัพยากรของเครื่องในการแสดงภาพที่มีความละเอียดสูง 

เพราะวาถาเครื่องถูกใชงานทรัพยากรมากๆ จะทําใหเครื่องทํางานชา 

ดังนั้นถาเราตองการปรับหยัดทรัพยากรขณะทํางานก็ใหเลือกคา Levels ต่ําๆ ประมาณ 1 หรือ 2 แตในทาง

กลับกันหากตองการใหความละเอียดของวัตถุที่เราสรางมีความละเอียดมากๆ ในตอนเรนเดอร ก็ใหเลือกตั้งคาใน Render 

Levels สูงขึ้น ซึ่งสามารถเลือกไดมากกวา 2 จะชวยใหประหยัดทรัพยากรขณะทํางานได 
 
คําส่ัง Subdivision Surface นี้จะใชไดกับวัตถุ Mesh เทานั้น สวนวัตถุประเภทอื่นเชน Curve, Meta, Text 

เหลานี้จะไมสามารถใชคําส่ัง Subdivision Surface ได เนื่องจากคุณสมบัติของวัตถุไมรองรับกับคําส่ัง และไมมีความ

จําเปนในการใช Subdivision Surface กับวัตถุอื่นๆ ที่โครงสรางเปนสวนโคงอยูแลว  

แตหากตองการใชจริงๆ ก็เพียงแคแปลงวัตถุชนิดอื่นๆใหกลายเปน Mesh กอน ก็จะพรอมสําหรับการใชคําส่ัง 

Subdivision Surface ไดทันที ซึ่งจะกลาวถึงการแปลงวัตถุในบทของโมเดลรูปแบบอื่นตอไป 
 

ทดลองสรางโมเดลจากจากวัตถุ Mesh 
สําหรับในตัวอยางนี้ เราจะมาเรียนรูวิธีการสรางวัตถุโครงสราง Mesh โดยเราจะสรางเกาอี้ในลักษณะดังภาพ 
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  โดยมีขั้นตอนการสรางดังนี้ 

    ขั้นตอนที ่1 สรางที่นั่งและพนักพิง 

    ขั้นตอนที ่2 สรางที่วางแขนของเกาอี้ 

    ขั้นตอนที ่3 สรางขาเกาอี้และตกแตงเกาอี้ 

 
ขั้นตอนที่ 1   ขั้นตอนที ่2    ขั้นตอนที ่3 
 

ขั้นตอนที่ 1 สรางที่นัง่และพนักพิง 
สําหรับการสรางที่นั่งนั้น เราจะเริ่มตนใชวัตถุ Mesh แบบ Cube 

ซึ่งถาเปดโปรแกรมขึ้นมาจะมีเตรียมไวแลว โดยเราจะใชเครื่องมือ   

(Scale) จัดรูปทรงวัตถุใหมีลักษณะแบน จากนั้นจะใชคุณสมบัติ 

Subdivision Surface แบงพื้นผิวใหมีพื้นผิวยอยมากขึ้นเพื่อจะสรางพนัก

พิงตอไปดวยคุณสมบัติ Extrude ดังนี้   

1. เลือกใชเครื่องมือ   (Scale) ปรับรูปรางของวัตถ ุCube ให

มีลักษณะแบนเหมือนกับที่นั่งของเกาอี้ทั่วไป 

2. เขาสูการตกแตงสวนยอยของวัตถุดวยการกดคีย <Tab> เพื่อเขาสู Edit Mode แลวกดคีย <A> 2 ครั้งเพื่อ

เลือกทุกสวนของวัตถุ 

3. จากนั้นทําการแบงวัตถุใหมีพื้นผิวยอยมากขึ้นดวยการกดปุม   ในแท็ป Mesh Tool 2 ครั้งใหมี

พื้นผิวยอย 2 ระดับ 

4. คลิกเมาสเลือกปุม   เพื่อทํางานกับ Face แลวคลิกเมาสขวาเลือกพื้นผิวยอย 4 พื้นผิว (ตามตัวอยางรูป) 

โดยเลือกสวนดานนอกเพื่อเตรียมสรางพนักเกาอี้ 

Page 125



 

 
 
 
 
 

   
 
 
 

 
 
 
 
 
 

1. ใช   ปรับรูปรางวัตถใุหแบน 

2. กดคีย <Tab> เขาสู Edit Mode 
แลวกดคีย <A> 2 ครั้ง 

3. กดปุม  2 ครั้งใหมีพื้นผิวยอย 
2 ระดับ 

3.1 กดปุม   ครั้งที่ 1 3.1 กดปุม   ครั้งที่ 2 
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5. ตอไปเราจะสรางพนักเกาอี้จาก Face ที่เลือกโดยกดคีย <E> เพื่อเขาสูการ Extrude แลวคลิกเลือกการ 

Extrude แบบ Region  

6. จากนั้นลากเมาสใหพื้นผิวที่เลือกทั้งหมดถูกยืดขึ้นมา 

7. ขณะยังเลือกพื้นผิวทั้งส่ี ใหเราเลือกปุม   (Translate) เพื่อเล่ือนพื้นผิวใหเอนไปทางดานหลัง (ดังตัวอยาง

ภาพ) 
 

 

 
6. ลากเมาสใหพื้นผิวถูกยืดขึ้นมา    

 7. เลื่อนพื้นผิวใหเอนไปทางดานหลัง 
 

ขั้นตอนที่ 2 สรางที่วางแขนของเกาอี้ 

4. เลือก  เพื่อทํางานกับ Face แลวคลิก
เมาสขวาเลือกพื้นผิวยอย 4 พื้นผิว 

5. กดคีย <E> แลวเลือก Region 
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  ในขั้นตอนที ่2 นี้เราจะแบงพื้นผิวในสวนของพนักพิงเกาอี้ใหมีพื้นผิวเพิ่มขึ้น เพื่อจะสรางที่วางแขน 

จากนั้นเราจะดึงพื้นผิวที่สรางนั้นออกมาดวยการ Extrude แลวปรับการวางตัวของพื้นผิวใหเปนที่วางแขน ดังวิธีตอไปนี้  
 
 
 
 
 

  1. เราจะตัดพื้นผิวของพนักพิงเกาอี้ใหมีสวนสําหรับสรางที่วางแขน โดยกดคีย <K> เพื่อเขาสูการตัดพื้นผิว แลว

เลือก Loop Cut เพื่อเลือกตัดวัตถุตามหนาตัดของพื้นผิวเดิม  

  2. เลือกตัดพื้นผิวตามหนาตัดของพนักพิง โดยเลื่อนเสนสีมวงใหวางตัวดังตัวอยางภาพ แลวคลิกเมาสซายเพื่อ

เลือกแนวของหนาตัด  

  3. จากนั้นเลื่อนเสนสีเหลืองเพื่อวางตําแหนงการตัดพื้นผิว เมื่อไดตําแหนงที่ตองการแลวคลิกเมาสซายเพื่อตัด

วัตถุ 

  4. ทําตามขอที ่1‐3 เพื่อตัดวัตถุตามตัวอยางภาพ ทั้งนี้เพื่อสรางพื้นผิวยอยสําหรับสรางที่วางแขนของเกาอี้ 
 

 
1. กดคีย <K> แลวเลือก Loop Cut เพื่อเลือกตัดวัตถ ุ         2. เลื่อนเสนสีมวง แลวคลิกเมาสซายเลือกแนวของหนาตัด 

 
3. เลื่อนเสนสีเหลอืงตามตําแหนงท่ีตองการแลวคลิกเมาสซายตัดวัตถ ุ 4. ตัดวัตถสรางพืน้ผิวยอยสําหรับสรางท่ีวางแขนของเกาอี ้

 

  5. กดคีย <Shift> แลวคลิกเมาสขวาเลือกพื้นผิวสวนที่เราสรางจากขอ 1‐4 โดยเลือกทั้ง 2 ดาน จากนั้นกดคีย 

<E> แลวเลือก Individual Faces เพื่อเตรียมยืดพื้นผิวออกมาเปนที่วางแขน 
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  6. เล่ือนเมาสยืดพื้นผิวออกมาเล็กนอย จากนั้นใชเครื่องมือ  (Rotate) หมุนพื้นผิวสวนที่เลือกทีละขางใหทํามุม

ดังตัวอยางภาพ 

  7. เราจะใชวิธีการ Extrude ตามขอ 5 และปรับแตงพื้นผิวตามขอ 6 จนกระทั่งไดที่วางแขนตามตองการ 

 
 

 
7. ใชวิธีการ Extrude และปรับแตงพ้ืนผิว (ตามขอ 5-6) จนกระทั่งไดที่วางแขนตามตองการ 

5. คลิกเลือกพื้นผิวสวนที่เราสรางทั้ง 2 ดาน 
จากนั้นกดคีย <E> เลือก Individual Faces 

6.ยืดพ้ืนผิวออกมา จากนั้นใชเครื่องมือ  หมุนพื้นผิวสวนที่เลือกทีละขาง 
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ขั้นตอนที่ 3 สรางขาเกาอี้และตกแตงเกาอี้ 
  สําหรับขั้นตอนสุดทาย เราจะสรางขาเกาอี้ดวยการเลือกพื้นผิวที่มุม

ดานลาง 4 ดานแลวทําการ Extrude ดึงขาเกาอี้ลงมา จากนั้นจะใชคุณสมบัติ

พิเศษ Subsurf เพื่อสรางใหเกาอี้มีความโคงมนสวยงาม ดังนี้  

  1. คลิกเมาสขวาเลือกพื้นผิวในสวนดานใตของที่นั่งทั้งส่ีมุม  

  2. จากนั้นกดคีย <E> เลือก Individual Faces เพื่อเรียกใชการ 

Extrude แลวเลื่อนเมาสลากขาเกาอี้ลงมา 

  3. ตอมาเราจะสรางใหเกาอี้มีความเรียบ โคงมนสวยงามโดยคลิก

เลือกคุณสมบัติ Subsurf ในแท็ป Modifers แลวปรับคา Render Level เทากับ 4 เพื่อสรางใหผลงานหลังเรนเดอรมี

ความโคงมนและเรียบเนียน 

  หลังจากนั้นเมื่อเราสรางเสร็จแลว ใหทดลองกดคีย <F12> เพื่อทําการเรนเดอรดูผลงานที่เราสราง 
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1. เลือกพื้นผิวในสวนดานใตของทีน่ั่งทัง้สี่มุม     2. ทําการ Extrude แลวเลื่อนเมาสลากขาเกาอี้ลงมา 
 

 

 
 

3. เลือกคุณสมบัต ิSubsurf ในแท็ป Modifers 
แลวปรับคา Render Level เทากับ 4 
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ผลลัพธหลงัการเรนเดอร (กด <F12>) 
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บทที่ 6 
สรางโมเดลแบบ Curve และ Surface 

นอกจากการสรางวัตถุในโครงสราง Mesh แลว ยังมีโครงสรางของเสน Curve และพื้นผิว Surface ที่เหมาะกับ

การใชสรางโมเดลที่มีสวนโคงมากและมีรูปรางไมแนนอน โดยเราจะไดเขาใจถึงการทํางานกับเสน Curve และวิธีการขึ้น

โมเดลโดยใชเสน Curve เปนแบบ จากนั้น เราจะเรียนรูวิธีการขึ้นโมเดลจากกลุมวัตถุ NURBS ที่อยูภายใตเมนู Surface 

ในตอนทายของบทนี้ 

 
รูจักกับเสน Curve 
 การสรางวัตถุในโปรแกรม  นอกจากวัตถุ  ที่กลาวมาแลว เรายังสามารถสรางวัตถุจากเสน
  ชนิดตางๆ ได ซึ่งการทํางานกับเสน  เหมาะสําหรับการสรางวัตถุที่เนนความโคงมนมาก เราใช
ประโยชนจากเสน  ไดมากมายเชน การสรางใหเปนตัวอักษร โลโก หรืออาจจะใชเปนเสนทางในการสรางการ
เคลื่อนที่ของวัตถุก็ได ซึ่งตอไปน้ีเราจะมาเรียนรูจักการสรางและการปรับแตงเสนโคง เพื่อเปนพื้นฐานสําหรับการขึ้น
โมเดลตอไป 
ชนิดของเสน Curve 

เสน Curve ในโปรแกรม Blender มีทั้งหมด 5 ชนิด ซึ่งแตละชนิดจะมีโครงสรางเสน Curve และการปรับแตง

แตกตางออกไป แตเสน Curve ที่สรางมานั้นสามารถใชงานไดเหมือนกันหมด ดังนี้ 

   
Bezier Curve       Bezier Circle 
 

   
NURBS Curve       NURBS Circle 
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  Path 
 
สําหรับ Bezier Curve และ Bezier Circle เปนเสนโคงที่เหมาะสําหรับการสรางตัวอักษรและการออกแบบโลโก 

และยังสามารถใชในการสรางเสน Path เพื่อเปนเสนบังคับเสนทางในการทําแอนนิเมชั่นได เนื่องจากสามารถปรับ

รายละเอียดของรูปแบบหรือรูปรางของเสนไดงาย ดวยการดัดแขนของจุด แตสําหรับ NURBS Curve และ NURBS 

Circle เหมาะสําหรับการขึ้นรูปทรงที่มีรูปรางไมแนนอน เชน รูปทรงโคงอยางการสรางโมเดลเมาส หมอน ชอน เปนตน 
 

การสรางเสน Curve 
การสรางเสน Curve ทําไดโดยเลือกคําส่ังจากเมนู Add>Curve เราจะพบกับปอบอัพใหเลือกวาจะสรางเสน 

Curve ลักษณะใด สําหรับตัวอยางนี้ เราจะเลือกสรางเสน Curve แบบ Bezier Curve เพื่อศึกษาการทํางานและการ

ควบคุมเสน Curve ดวย Handle ดังขั้นตอนตอไปนี้ 

1. เลือกคําส่ังจากเมนู Add>Curve>Bezier Curve 

2. จากนั้นจะปรากฏเสน Curve บนวิวพอรต ใหเราคลิกเมาสขวาเลือกที่เสน Curve แลวจะปรากฏจุดควบคุม

หรือ Control Vertex และแขนควบคุมหรือ Handle 

 
 

สราง Bezier Curve โดยใชคําสั่ง Add>Curve>Bezier Curve 
 

  เสนโคง Bezier Curve จะปรากฏ 
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การปรับแตงเสน Curve 
หลังจากสรางเสน Curve แลว ส่ิงที่จําเปนตอมาสําหรับการสรางโมเดลนั้นคือการสรางโครงรางใหเปนไปตาม

โมเดลที่ออกแบบไว ดังนั้นคุณสมบัติและวิธีการปรับแตงเสนโคงจึงเปนอีกเรื่องหนึ่งที่เราตองฝกฝนใชงานใหคลอง เพื่อชวย

เราในการสรางรายเอียดของเสนโคงใหไดโครงรางตามตองการ  และกอนการปรับแตงใดๆ เราตองเขาสูโหมด Edit 

เสียกอนโดยการกด <Tab> 
 
ปรับแตรูปทรงของเสน Curve 
เราสามารถปรับแตงรูปทรงของเสน ณ ตําแหนงใดๆ ก็ได โดย

คลิกเมาสขวาคางไวที่จุดหรือ Handle ก็ได จากนั้นลากเมาสเพื่อปรับ

วางตําแหนงที่ตองการ ดังตัวอยางเราจะลากจุดปลายดานซายของเสน 

Curve ใหสูงขึ้น และปรับ Handle เพื่อจัดเสน Curve ใหเปนดังภาพ  

1. ทดลองทํางานกับจุด โดยคลิกเมาสขวาคางไวที่ปลายเสน 

Curve ดานซาย จากนั้นลากเมาสดึงจุดขึ้น (ดังตัวอยางภาพ) แลวคลิก

เมาสซายเพื่อวางจุด 

2. ทดลองทํางานกับ Handle โดยคลิกเมาสขวาคางไวที่แขนดานหนึ่งของ Handle จากนั้นลากเมาสลงมาเพื่อ

ดึงเสน Curve ใหโกงตัวขึ้น (ดังตัวอยางภาพ) แลวคลิกเมาสซายเพื่อวางแขนของ Handle 

 
1. คลิกเมาสขวาเลือกจุดดานซาย แลวลากเมาสดึงจุดขึ้น 

 
2. คลิกเมาสขวาคางไวท่ีแขนดานขวา แลวลากเมาสลงมาเพื่อดึงเสน Curve ใหโกงตัว

ขึ้น

 
 

2. คลิกเมาสขวาคางไวที่แขนดานขวา แลวลาก
เมาสลงมาเพื่อดึงเสน Curve ใหโกงตัวขึน้ 
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การตอเสน Curve ใหยาวขึ้น 
เนื่องจากการทํางานเพื่อสรางโมเดลนั้น จําเปนตองสรางเสน Curve ที่มีโครงรางที่ซับซอนขึ้น ดังนั้นเราจึง

จําเปนตองสรางเสนโคงใหมีความยาวมากขึ้น มีจุดและ Handle เพิ่มขึ้น เพื่อจะสามารถปรับแตงจุดตางๆ ไดดีขึ้น โดย

วิธีการตอเสน Curve ใหยาวขึ้นถือเปนวิธีหนึ่งที่จะชวยเพิ่มรายละเอียดของเสน Curve ได 

ซึ่งสามารถทําไดโดย ใหเรากดคีย <Ctrl> คางไว และคลิกเมาสซายยังบริเวณที่ตองการ ก็จะเกิดเสนที่ตอเติม

ออกไปอยางตอเนื่อง ดังตัวอยางภาพ 
 

 
 

 

 เราสามารถตอเสนไดอยางไมจํากัด 
 

หากเราตองการกะระยะและตําแหนงเสน Curve กอนตอเติม ใหกดคีย <E> จากนั้นลากเมาสเพื่อหาตําแหนงที่

ตองการและคลิกเมาสซายเพื่อกําหนดจุดที่เสนจะตอเติม ดังตัวอยางฃ 

กดคีย <Ctrl> คางไว แลวคลิกเมาสซายตอเสนออกไป 

Page 136



   
          ขณะที่เลือกจุดใดจดุหนึง่ที่ปลายเสนโคง ใหกดคีย <E> 

 
 
 
หากตองการยายจุดปลายของเสนที่เพิ่งตอเติมไป ใหกดคีย <G> แลวเลื่อนเมาสหาตําแหนงที่ตองการ จากนั้น

คลิกเมาสซายเพื่อวางจุดปลายอันใหม หรือเลือกใชวิธีเหมือนกับการปรับแตงจุดนั่นคือ คลิกเมาสขวาคางไวที่จุดนั้นแลว

ลากเมาสเพื่อหาตําแหนงใหม แลวคลิกเมาสซายเพื่อวางจุดก็ไดเชนเดียวกัน 

   
         ขณะที่เลือกจุดใดจดุหนึ่งทีป่ลายเสนโคง ใหกดคีย <G> 

 
 
 

หลังจากที่เราทดลองตอเสน Curve ใหยาวขึ้นแลว สังเกตวา Handle ที่เกิดขึ้นจากการตอเสนโคงนั้นจะวางตัว

ในแนวเดียวกันตลอด ซึ่งทําใหไมสะดวกในการปรับแตง ดังนั้นเรามีวิธีการแกไขให Handle เปล่ียนทิศทางไปตามเสนโคง

เพื่อความสะดวกในการปรับแตง และยังชวยใหเสน Curve มีความเรียบโคงอยางตอเนื่อง  

วิธีการใหเรากดคีย <A> 2 ครั้ง เพื่อเลือก Handle ทั้งหมด จากนั้นคลิกเลือกเมน ูCurve>Control 

Points>Automatic หรือกดคีย <Shift+H>  

  1. เลือกทุกจุดบนเสนโคงโดยกดคีย <A> 2 ครั้ง 
 

จุดใหมของเสนโคงจะปรากฏออกมา ใหเราเลือก
เมาสเพื่อหาตําแหนงที่ตองการ แลวคลิกเมาสซาย
เพื่อวางจุด 

ลากเมาสเพื่อหาตําแหนงใหมที่
ตองการ แลวคลกิเมาสซายเพื่อวางจุด 
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  3. Handle จะเปลี่ยนทิศทางไปตามเสนโคงทันท ี
 

จะเห็นผลลัพธวา Handle ทุกตัวไดปรับองศาเพื่อใหเสน Curve ดูตอเนื่องมากขึ้น และถาเราสรางเสน Curve 

ตอเติมหลังจากใชคําส่ังนี้ก็จะมีคุณสมบัติเดียวกันไปตลอด 
 
เปล่ียนเสน Curve ใหกลายเปนมุม 
หากตองการเปล่ียนเสนโคงเกิดเปนมุม ณ  จุดควบคุมใดๆ หรือเรียกวาเปนการเปลี่ยนใหเปน Vector โดยคลิก

เมาสขวาเลือกจุดที่ตองการ แลวเลือกคําส่ัง Curve>Control Points>Vector หรือกดคีย <V> จุดที่เราเลือกก็จะ

กลายเปนมุมทันที และสามารถปรับแขนความโคงทั้งสองขางอยางอิสระไดโดยไมขึ้นกับอีกขางหนึ่ง 

 
1. คลิกเมาสขวาเลือกจุดที่ตองการทําใหกลายเปนมุม   

 
 
 
 
 

2. เลือกคําสั่ง 
Curve>Control 
Points>Automatic 

2. กดคีย <V> สงัเกตวาเสน Curve ที่
อยูรอบขางจุดนัน้จะกลายเปนมุม 
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เพ่ิมจุดใหกับเสน Curve 
เราสามารถเพิ่มจุดควบคุมใหกับเสน Curve ณ ชวงใดๆ บนเสน Curve ก็ไดเพื่อความนุมนวลของเสนโคงไดหรือ

เพื่อจะเพิ่มรายละเอียดใหกับเสนโคงได ดังนี้ 

1. กดคีย <Shift> คางไว แลวคลิกเมาสขวาเลือกจุดในชวงเสนโคงที่เราตองการกอน  

2. จากนั้นกดคีย <W> และเลือก subdivide จากนั้นชวงของเสนโคงที่เราเลือกจะมีจุดควบคุมเพิ่มขึ้น 

     
 
 
 
 
 
ลบจุดบนเสน Curve 
ในการลบจุดควบคุมใดๆ สามารถทําไดเหมือนกับการลบวัตถุ นั่นคือใหคลิกเมาสขวาเลือกจุดที่ตองการลบ แลว

กดคีย <Delete> หรือคีย <X> จากนั้นเลือก Selected 

          
 
 
 
 
ในกรณีที่เรากดคีย <Delete> หรือคีย <X> เพื่อเลือกลบจุดนั้น เมื่อปอบอัพปรากฏ ถาเราเลือก All จะเปนการ

ลบเสน Curve ทั้งเสน 
 
เช่ือมจุดระหวางเสน Curve ใหเปนรูปทรงปด                         
เมื่อตองการเชื่อมตอเสนโคงที่เราสรางใหบรรจบเปนรูปทรงปด ใหคลิกเมาสขวาเลือกจุดปลายของดานใดดาน

หนึ่ง จากนั้นเลือกเมนู Curve>Toggle Cyclic หรือกดคีย <C> เราก็จะไดรูปทรงปดจากเสนที่สรางขึ้น 
 

1. เลือกจุดที่ตองการสรางจุด
ใหมระหวางชวงของจุดนั้น 
2. กดคีย <W> แลวเลือก subdivide 

เราจะไดจุดใหมที่เกิดขึ้นระหวาง 
2 จุดที่เราเลือก 

1. กดคีย <Delete> หรือคีย <X> 
จากนั้นเลอืก Selected 

2. จุดที่ไมตองการจะถูกลบไป 
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1. คลิกเมาสขวาเลือกจุดปลายของดานใดดานหนึ่ง 

 
 
 
 

ตรึงเสน Curve เขากับเสนกริด                    
การตรึงเสน Curve เขากับเสนกริดหรือเรียกอีกอยางวาการ Snap นั้น จะชวยเราในการจัดวางจุดบนเสนโคง 

โดยอางอิงกับเสนกริด ในกรณีที่เราตองทํางานที่เนนขนาด ระยะความหาง หรืองานใดๆ ที่จําเปนตองวางจุดและเสนโคงใน

ตําแหนงที่แนนอน ดังภาพแรกเราสรางเสน Curve อิสระขึ้นมา ซึ่งวางตัวไมตรงกับเสนกริด ถาเราซูมมาใกลก็จะเห็นได

ชัดเจน และภาพที่ 2 แสดงผลลัพธหลังการ Snap ซึ่งจะเห็นวาเมื่อเราซูมเขามา จุดทุกจุดของเสน Curve จะถูกตรึงเขากับ

เสนกริด 

 
กอนทําการ Snap 

 

 
หลังทําการ Snap 

 

โดยวิธีการ Snap สามารถทําไดดังนี้ 

1. กดคีย <A> 2 ครั้งเพื่อเลือกเสน Curve ทั้งเสน  

2. จากนั้นคลิกเลือกเมนู Curve>Snap>Selection‐‐‐>Grid ที่ Header ของวิวพอรตเพื่อส่ังใหโปรแกรมตรึง

ทุกจุดของเสน Curve เขากับเสนกริดที่ใกลที่สุด 

2. เลือกเมนู Curve>Toggle Cyclic หรือ
กดคีย <C> เราก็จะไดรูปทรงปดจากเสน 
Curve 
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1. กดคีย <A> 2 ครั้งเพื่อเลือกเสน Curve ทั้งเสน          2. เลือกเมน ูCurve>Snap>Selection--->Grid 
 
 

  จุดทุกจุดจะถูกตรึงเขากับเสนกรดิที่ใกลที่สุด 
 

Note:  
สําหรับการวาดเสน Curve นั้น ควรวาดในมุมมอง 2 มิติ เพื่อใหเราสามารถควบคุมจุดไดอยางแมนยํา ซึ่งการ

ควบคุมจุดจะทําไดยากในมุมมอง 3 มิติ  
 

การปรับแตงเสน Curve รูปแบบอื่น 
สําหรับการปรับแตงเสน Curve ชนิดอื่นๆ นั้น จะมีการทํางานคลายกับ Bezier Curve ที่ใชเปนตัวอยางดังที่

ผานมา แตสําหรับรายละเอียดที่แตกตางกันของเสน Curve แตละเสนนั้น มีดังนี ้ 

  Bezier Circle เนื่องจากเปนเสน Curve รูปทรงปดที่มี

พื้นที่ภายใน เราจึงสามารถเลือกแสดงหรือไมแสดงพื้นที่ในวงกลมไดโดย

การคลิกที่ปุม  ที่หัวขอ Curve&Surface สวนการจัดการรูปทรงของเสน 

Curve ชนิดนี้จะใชคําส่ังเหมือนกันกับ Bezier Curve ที่ไดเรียนรูสวนแรก  
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  NURBS Curve เปนเสน Curve ที่มีหลักการปรับแตงตาง

จาก Bezier Curve คือจะไมมี Handle ใหควบคุม แตจะใชคําส่ังตางๆ ใน

สวนของ Curve tools ภายใตสวน Editing ควบคุมแทน   

ซึ่งถาเราตองการใหเสน NURBS บรรจบจุดปลายของจุดควบคุม ให

คลิกเลือกคําส่ัง endpointU  
 

 
 

กอนคลิกปุม     หลังคลิกปุม  
 

  NURBS Circle เมื่อคลิกสรางก็จะไดรูปวงกลมเหมือนกับ Bezier Circle แตวิธกีารปรับแตงจะ

เหมือนกับ NURBS Curve คือไมมี Handle ใหใชปรับแตง ตองเลือกปรับแตงใน Curve tools แทน 

  Path ซึ่งมีหลักการปรับแตงเหมือน NURBS Curve ทุกประการแต Path จะมีรูปรางเบื้องตนเปน

เสนตรงใหเราสามารถปรับแตงไดเอง 
 

ตัวอยางการสรางโมเดลจากเสน Curve 
ในหัวขอนี้เราจะมาเรียนรูวิธีการสรางพื้นผิวขึ้นมาจากเสน Curve โดยจะสรางทอสงน้ําที่มีหนาตัดเปนรูป

ส่ีเหลี่ยม ดังภาพ 

 

เลือกใหแสดงพืน้ที่ปด คลิกปุม  เลือกใหแสดงเสน
ขอบในลักษณะดงัภาพ โดยที่
พื้นที่ปดถูกซอนไว 
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  จากภาพเพื่อใหไดวัตถุตามที่แสดงไว จึงมีวิธีการสราง 2 ขั้นตอนหลักๆ นั้นคือ 

    ขั้นตอนที ่1 สรางเสน Curve สําหรับโมเดลทอน้ํา 

    ขั้นตอนที ่2 ขึ้นโมเดลตามเสน Curve ที่เตรียมไว  

 
 

 ขั้นตอนที ่1     ขั้นตอนที ่2 
 

ขั้นตอนที ่1 สรางเสน Curve สําหรับโมเดลทอน้ํา 
เราจะสรางโมเดลทางยาวที่มีมุมฉากหักศอกและมีลักษณะกรวง โดยจะสรางเสน Curve รูปทรงปดเปนหนาตัด

ของทอหนาและเสน Curve ที่เปนแนวยาวของทอ เพื่อเตรียมไวสําหรับขึ้นโมเดลในขั้นตอนที่ 2 ตอไป  

โดยเราจะเลือกสรางจาก Bezier Curve เปนเสนทางของทอน้ํา และเลือก Bezier Circle เปนหนาตัดของทอน้ํา 

ซึ่งมีขั้นตอนการสรางดังนี้ 

 
 

1. เริ่มตนจากการสรางเสนทางเพื่อกําหนดแนวการวางพื้นผิวขึ้นมากอน โดยสราง Bezier Curve ดวย

การกดคีย <SpaceBar> แลวเลือกเมนู Add>Curve>Bezier Curve  

 สราง Bezier Curve จากเมน ูAdd>Curve>Bezier Curve 
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2. ใหเราสรางเสน Curve เปนเสนที่มีมุมฉาก โดยคลิกเมาสขวาที่จุดปลายดานหนึ่ง แลวลากมาวางในตําแหนง 

(ดังภาพ) จากนั้นเลือกจุดของ Bezier Curve ทั้งหมดแลวทําการสรางจุดใหมระหวางกลาง เพื่อใหไดเสน Curve ที่เปน

มุมฉาก  

 1. เลือกจุดดานขวาแลวลากขึ้นไปดานบน 

  
2. เลือกจุดทั้งสอง แลวสรางจุดใหมระหวางจุดทั้งสอง โดยกดคีย <W> แลวเลือก Subdivide 
 

 
3. เม่ือไดจุดใหม ใหเราเลื่อนจดุนัน้ไปวางใหเปนมุมของเสน Curve 
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4. กดคีย <A> 2 ครั้งเพื่อเลือกจุดทั้งหมด แลวกดคยี <V> เพื่อสรางเสนโคงใหเปนเสนมุมฉาก 

 
3. จากนั้นทําการ Snap เสน Curve ที่กลายเปนเสนมุมฉากใหเขากับเสนกริด โดยขณะเลือกเสน Curve ทั้งเสน

นั้น ใหเราคลิกเลือกเมนู Curve>Snap>Selection‐‐‐>Grid 

 
 
ตรึงเสนโคงใหเขากับเสนกริด 

 

4. เมื่อสรางเสร็จแลว ใหกดคีย <Tab> ออกจากการสรางเสน Bezier Curve แลวใหเราตอมาเราจะสรางหนา

ตัดของทอ โดยใช Bezier Circle ดวยการกดคีย <SpaceBar> แลวเลือกเมนู Add>Curve> Bezier Circle 

 สรางหนาตดัของทอจาก Bezier Circle 
 

5. สรางใหหนาตัดนั้นเปนรูปส่ีเหลี่ยมโดยเลือกจุดทั้งหมดของ Bezier Circle แลวกดคีย <V> 
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กดคีย <V> เพื่อเปลี่ยนวงกลมใหเปนสี่เหลี่ยม 

 
 
6. จากนั้นยอขนาดของหนาตัดโดยกดคีย <S> เพื่อใหมีขนาดพอดีกันการสรางทอ (ดังภาพ) เมื่อสรางเสร็จแลว 

ใหกดคีย <Tab> ออกจากการสราง 

 ปรับขนาดของเสนแนวยาวของทอและเสนหนาตดั 
 

ขั้นตอนที ่2 ขึ้นโมเดลตามเสน Curve ที่เตรยีมไว  
ขั้นตอนตอมาก็จะเปนการขึ้นโมเดลจากเสน Curve ทั้งสองที่เตรียมไว โดยจะใชหลักการ Bevel Object เพื่อให

ทั้งสองเสน Curve ทํางานรวมกันจนกระทั่งกลายเปนโมเดลในที่สุด โดยมีวิธีดังนี้ 

1. กําหนดรูปหนาตัดใหกับเสนทางที่เราสรางขึ้นมา โดยกดปุม   (Editing)  แลวคลิกเมาสขวาเลือกหนาตัด 

จากนั้นเขาไปเปลี่ยนชื่อของหนาตัดในแท็ป Link and Material โดยเลือกชื่อส้ันๆ งายๆ เพื่อจะระบุชื่อในขั้นตอนตอไปได

งาย ดังภาพ 

 
 

 
 

 

1.1 คลิกเมาสขวาเลือกหนาตัด แลวเขาสูการแกไข

ชื่อในปุม  
1.2 คลิกเมาสซายเพื่อเขาไปเปลี่ยนชื่อ  
ในตวัอยางเราพิมพ C ใหเปนชื่อใหมของหนาตัด 
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2.  ตอมาทําการสรางใหหนาตัดทํางานคูกับเสนแนวยาวของทอ โดยคลิกขวาเลือกเสน Curve ที่จะใชเปน

เสนทาง และในสวนของ Curve and Surface ใหเราคลิกซายที่ชอง  (Bevel Object) และพิมพชื่อวัตถุหนาตัด ซึ่งเราตั้ง

ชื่อใหใหมเปน C ลงไป แลวกดคีย <Enter> 
 

 
 
 
 
3. ผลลัพธที่ปรากฏคือรูปทรงหนาตัด (หรือเรียกวา Profile) ของเราจะทอดตัวตามแนวเสน curve ที่เปน

เสนทางที่กําหนดไว 

 
 
4. เมื่อเราเขาสู Edit Mode เพื่อจะแกไขหนาตัดหรือ Profile ก็จะ

สงผลตอพื้นผิวที่เราเพิ่งสรางขึ้นมานั้นดวย ดังภาพเราไดปรับแตงใหหนาตัด

รูปส่ีเหลี่ยมมีสวนโคงเวาเขาไปคลายรูปทรงขนมเปยกปูน 
 
 
 
 

 
เม่ือมีการแกไข Profile วัตถุจะเปลี่ยนตามรูปทรงของ Profile 

 
 
 
 
 
 

2.1 คลิกเมาสขวาเลือกเสนทางของทอ 2.2 คลิกเมาสซาย แลวพิมพ C ในชอง  
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ผลลัพธท่ีไดในการแสดงผลวัตถุรูปแบบท่ีตางกัน 

 
      การแสดงผลแบบ Solid         การแสดงผลแบบ Shaded      การแสดงผลแบบ Wireframe 
 
 

วัตถุที่สรางมานี้ เราสามารถเปลี่ยนเปนวัตถุ Mesh เพื่อนําไปใชตอไปได โดยคลิกเลือกวัตถุทอน้ํา แลวกดคีย 

<Tab> เขาสู Object Mode จากนั้นกดคีย <Alt+C>  ที่คียบอรด และคลิกซายเลือก Mesh เราก็จะไดวัตถุ Mesh ไวใช

งานทันที 

 กดคีย <Alt+C> แลวเลือก Mesh 
 
 

รูจักกับวัตถุ NURBS 
ในหัวขอนี้ เราจะรูจักกับวัตถุ NURBS ซึ่งเปนวัตถุอีกรูปแบบหนึ่งที่ใชในการขึ้นโมเดล โดยใชการสรางโครงรางให

วัตถุแบบ NURBS Curve  เพื่อใหกลายเปนโมเดลแลวจึงทําการปรับแตงใหไดรูปทรงที่ตองการ ซึ่งวัตถุ NURBS นี้จะอยู

ภายใตเมนู Surface ของโปรแกรม Blender 
 

วิธีการสรางวัตถุ NURBSและชนิดของวัตถุ NURBS  
วัตถุ NURBS มีวิธีการสรางวัตถุดังนี ้ใหเราคลิกเลือกคําส่ัง Add>Surface จะพบวา NURBS ที่โปรแกรมเตรียม

ไวใหเราเลือกใชมีทั้งหมด 6 ชนิด ไดแก  NURBS Curve, NURBS Circle, NURBS  Surface, NURBS Tube, NURBS 

Sphere และ NURBS Donut ซึ่งวัตถุทั้งหมดนี้เปนวัตถุแบบ NURBS เหมือนกัน แตจะตางกันตรงวิธีการขึ้นรูปโมเดล 

โดยเลือกใหเหมาะสมกับโมเดลตนแบบที่เราจะสราง 
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การทํางานกับ NURBS Curve 
เราจะมารูจักกับวัตถุ NURBS แบบแรกกอน นั้นคือเสน NURBS Curve ซึ่งเปนวัตถุที่เปนเสนโคง ซึ่งสามารถใช

สรางพื้นผิวที่ไรรูปแบบไดอยางอิสระ โดยวิธีการสรางคือคลิกเลือกคําส่ัง Add>Surface> NURBS Curve จะปรากฏเสน 

NURBS Curve ขึ้นมา ดังภาพ 
 

 เสน NURBS Curve 
 

สําหรับ NURBS Curve นั้น จะใชจุดในการควบคุมเสนโคงหรือใชจุดในการปรับรูปรางของเสนดวยการคลิก

เมาสปุมขวาเลือกจุดที่ตองการ แลวทําการยายจุดก็จะแตละจุดเพื่อควบคุมเสน NURBS Curve 

NURBS Curve NURBS Circle 

NURBS Surface NURBS Tube NURBS Sphere 

NURBS Donut 
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คลิกเมาสเลือกจุดที่ตองการ แลวลากเมาสเพื่อยายเสน Curve 
 

กําหนดคารายละเอียดของเสน NURBS Curve 
เราสามารถกําหนดคาตางๆ ใหกับเสน NURBS Curve ไดมากขึ้น โดย

ขณะที่เราอยูที่ Edit Mode ใหเราเลือกที่แท็ป Curves Tools แลวปรับคา

รายละเอียดของเสน NURBS Curve เพิ่มเติม เชน  
 
 
Endpoint U ใชสําหรับนําจุดเริ่มตนของเสน NURBS Curve มาวางไวที่จุดแรกที่ใชในการควบคุมเสน และนํา

จุดส้ินสุดของเสน Curve มาวางไวที่จุดสุดทายที่ใชในการควบคุมเสน 

 
เลือกปุม  ในแท็ป Curves Tools 

 

Order U จะเปนการกําหนดความโคงของเสน โดยถาคาเทากับ 2 ก็จะทําใหเสน NURBS Curve นั้นแนบไปกับ

เสนที่ใชควบคุม 

 
 

ปรับคา   เปน 2 
 

Weight จะเปนการกําหนดคาน้ําหนักในการควบคุมเสน ซึ่งถามีคานอย

น้ําหนักก็นอย การควบคุมใหเสนไปตามที่เราลากเมาสก็จะนอย แตถามีคามากแรง

ดึงก็จะมากตาม ซึ่งคามาตรฐานอยูที ่1.00  
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สรางจุดใหมใหกับ NURBS Curve 
นอกจากการใชเสน NURBS Curve ตามรูปทรงที่เราเพิ่งสรางขึ้นมาแลว เรายังสามารถเพิ่มเสน NURBS Curve 

ขึ้นมาได โดยคลิกเมาสปุมขวาเลือกจุดที่ปลายเสนขางใดขางหนึ่ง แลวกดแปน <Ctrl> คางไว จากนั้นคลิกเมาสปุมซายใน

ตําแหนงที่ตองการสรางจุดขึ้นมาใหม จะทําใหเราไดเสน NURBS Curve ใหมขึ้นมา  

 
 

 
 
 
 

ปรับตําแหนงของจุดที่ใชควบคุมเสน NURBS Curve  
เราสามารถปรับแตงเสน NURBS Curve นั้นไดโดยคลิกเมาสปุมขวา เลือกจุดที่ตองการ จากนั้นกดแปน <G> ที่

คียบอรดเพื่อเคลื่อนยายจุด หรือใชอุปกรณ Translate เพื่อยายจุดและเสน NURBS Curve ใหไดตามตองการ 

 
เคลื่อนยายและปรับแตงจดุไดเหมอืนกับการทํางานกับเสน Curve อื่นๆ 

 

ถาเราตองการสรางเสน NURBS Curve เพิ่ม แต

ไมตองการเสียเวลาปรับตําแหนงอีก ใหเราเลือกกดแปน 

<E> แทน โดยเมื่อกดแปน <E> เราจะไดเสน Curve ใหม

ขึ้นมาทันที และโปรแกรมยังใหเราไดเล่ือนเมาสไดอิสระเพื่อ

จะวางจุดที่ใชควบคุมเสน NURBS Curve โดยการลาก

1. คลิกเมาสขวาเลือกจุดปลายเสน 
NURBS Curve 

2. กดคีย <Ctrl> คางไว แลวคลิกเมาส
ซายในตําแหนงทีต่องการสรางจุดใหม 
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เมาสเพื่อหาตําแหนงที่ตองการ แลวคลิกเมาสปุมซายเพื่อวางจุด  
 

 
 
 
เพ่ิมจุดขึ้นระหวางเสน 

ถาเราตองการเพิ่มจุดขึ้นระหวางเสน NURBS Curve สามารถทําไดโดยคลิกที่จุดควบคุมเสน Curve ดานหนึ่ง 

และกดแปน <Shift> ที่คียบอรด แลวคลิกที่จุดอีกดานหนึ่งของเสน NURBS Curve นั้น จากนั้นใชคําส่ัง 

Surface>Segment>Subdivide ก็จะเปนการสรางจุดใหมในเสน NURBS Curve ที่เราตองการ  

 
คลิกเลือกจุดควบคุมสองจุดที่ตองการสรางจุดใหมระหวางนั้น แลวใชคําสั่ง Surface>Segment>Subdivide เพิ่มจุด 

เราจะไดจุดใหมเพิ่มเขามา 
 

โดยโปรแกรมจะแบงเสน NURBS Curve ออกเปนสองสวนโดยการสรางจุดใหมตรงกลางเสน NURBS Curve 

หรือเลือกกดแปน <W> แลวคลิกเมาสปุมซายเลือกคําส่ัง Subdivide เพื่อสรางจุดใหมไดเชนกัน (ซึ่งคลายกับการสรางจุด

ของเสน Curve ขางตนที่เรากลาวมา)  

นอกจากนั้นเรายังสามารถเลือกคําส่ัง Subdivide ซ้ําๆ ในเสน NURBS Curve นั้นได เพื่อแบงจุดยอยลงไปอีก 

หรือกดแปน <A> เพื่อเลือกจุดทั้งหมดในเสน Curve แลวใชคําส่ัง Surface > Segment > Subdevide เพื่อสรางจุดใหม

ขึ้นระหวางทุกๆ เสน NURBS Curve ยอยไดเชนกัน 
 

กดคีย <E> เลือกสรางจุดใหมและวางจุดตามตําแหนง
ตางๆ อยางอิสระในขัน้ตอนเดียว 
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ปรับความละเอียดของเสน NURBS Curve 
ถาเราสรางพื้นผิวขึ้นมาจากเสน NURBS Curve เราก็จะเรียกพื้นผิวนั้นวาพื้นผิว NURBS และเรายังสามารถ

เปล่ียนเสนเสน NURBS Curve หรือทําการ Convert ใหเปนวัตถุแบบ Mesh ได  

แตกอนที่เราจะ Convert ไดนั้น เราจําเปนตองปรับคา 

Resolution ของเสนกอน เพื่อกําหนดจุดและเสน NURBS Curve ยอย

ใหกันเสน NURBS Curve โดยดูที่คา Resolution ในสวนของแท็ป 
Curves Tools   

 
 

 
 
 
 
 

โดยคานี่จะเปนการกําหนดจํานวนจุดระหวางเสน NURBS Curve โดยคาที่โปรแกรมตั้งไวคือ 12 ทั้ง U และ V 

นั่นหมายความวาเมื่อเรา Convert เสน Curve นี้เปนวัตถุ Mesh เราจะไดจุดยอยๆ บนเสน Curve ยอยทั้งหมด 12 จุด 

นั่นเอง ซึ่งถาเราเลือกใหมีคา Resolution มาก ก็จะทําใหเรามีจุดยอยๆ มากตามลําดับ ทั้งนี้เมื่อมีจุดยอยมากขึ้นก็จะชวย

ใหเราปรับแตงวัตถุในระดับยอยไดมากขึ้นนั่นเอง 
 

 
 
 
 
 
การสรางเสน NURBS Curve  

ตอไปเราจะมาเรียนรูวิธีการสรางพื้นผิวจากเสน NURBS 

Curve กัน โดยใหเราสรางเสน NURBS Curve ตามตองการขึ้นมา

กอน 1 เสน ในตัวอยางเราจะสรางเสน NURBS Curve ในมุมมอง 

Top กอน โดยคลิกที่เมนู ADD>Surface>NURBS Curve จากนั้นให

กําหนดรูปทรงของเสน  
 

การคัดลอกเสน NURBS Curve 
เมื่อไดเสน NURBS Curve ตามตองการแลว ใหเรากดแปน <Tab> เพื่อออกจาก Edit Mode ในสวนนี้เราจะ

ทําการคัดลอกเสน NURBS CURVE ขึ้นมาอีกเสนหนึ่งในทิศทางคูขนานในการแกน Z ใหเราคลิกเมาสซายเลือกเสน 

NURBS CURVE แลวกดคีย <Shift+D> ลากเมาสดึงเสน NURBS CURVE ใหมขึ้นมา กดแปน Z ที่คียบอรด เพื่อบังคับ

ใหเสนนั้นเคล่ือนที่ขึ้นตามแกน Z เมื่อไดตําเหนงที่ตองการ ใหคลิกเมาสซาย 1 ครั้ง เราก็จะไดเสน NURBS CURVE ใหม

ขึ้นมา 

คา Resolution แสดงความละเอียดของ
เสนและจุดควบคมุ 
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1. กดคีย <Shift+D> แลวลากเมาสดึงเสน NURBS CURVE ใหมขึ้นมา กดแปน Z ที่คียบอรด เพื่อบังคับใหเสนนั้นเคลื่อนที่ขึ้น
ตามแกน Z 
 

  
 

การสรางพ้ืนผวิจากเสน NURBS Curve 
เปนการสรางพื้นผิวเชื่อมระหวางเสน NURBS Curve 

โดยเราจะเรียนรูผานตัวอยางที่ผานมา โดยเริ่มตนใหเรารวมเสน

ทั้ง 2 ใหเปนเสนเดียวกันกอน เพื่อจะสรางพื้นผิวเชื่อมระหวาง

เสนทั้ง 2 นี้ได ดวยการคลิกเลือกเสนทั้ง 2 กอน 
 
 
 
 

 
แตถาในหนาจอการทํางานของเราไมขึ้น Highlight ขณะเลือกเสน ก็สามารถสั่งใหแสดง Highlight ไดเมื่อมี

การคลิกเสน โดยใหคลิกที่ปุม   (Object) แลวคลิกปุม   ในแท็ป Draw สังเกตวาเมือเลือกเสนก็จะมี 

Highlight เปนสีชมพู 

 
คลิกเลือกเพื่อใหแสดง Highlight ที่เสน 

 

2. เม่ือคลิกเมาสซายเพื่อวางเสนเราก็จะ
ไดเสน NURBS CURVE ใหมขึ้นมา 

คลิกเมาสเลือกเสนทั้งสอง 
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ขั้นตอนที ่1 รวมเสน NURBS Curve ใหเปนวัตถุเดียวกัน เมื่อเลือกทั้ง 2 เสนแลวใหเรารวมเสนทั้ง 2 เปน

วัตถุเดียวกัน โดยคลิกคําส่ัง Object>Join Object หรือกดแปน <Ctrl+J> แลวคลิกเลือก Join Selected NURBS เสน

ทั้ง 2 ก็จะกลายเปนวัตถุเดียวกัน 

 
 

 
 
ขั้นตอนที ่2 สรางพ้ืนผิวระหวางเสน จากนี้เราจะทําการสรางพื้นผิวขึ้นมาระหวาง 2 เสน โดยเชื่อมพื้นผิว

ระหวางจุดตอจุดของเสนโคง โดยเขาสู Edit Mode แลวกดแปน <A> เพื่อเลือกจุดทุกจุดในเสน Nurbs Curve แลวใช

คําส่ัง Surface>Make Segment หรือกดคีย <F> เราก็จะเห็นวาระหวางเสน Nurbs Curve นั้น มีเสนที่เกิดมาใหมเชื่อม

ระหวางจุดของเสนทั้งสอง  

     
 

 
 
 
จากนั้นใหเราเขาไปแกไขเสน NURBS นี้โดยคลิกที่ปุม  

(Editing) แลวปรับคา Order U ใหเปน 2 เพื่อใหเกิดพื้นผิวที่

แนบกับจุดควบคุมเสน  NURBS Curve  
 
 
 
 

กดแปน <Ctrl+J> แลวเลอืก Join 
Selected NURBS 

เสนทั้ง 2 ก็จะกลายเปนวัตถุเดียวกัน 

1. เขาสู Edit Mode แลวกดคีย <A> 2 
ครั้งเพื่อเลือกจุดทั้งหมด 

2. เลือกเมน ูSurface>Make Segment 
หรือกดคีย <F> 

ปรับคา Order U = 2 
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และนี้เปนการสรางพื้นผิว Nurbs รูปแบบหนึ่งที่ใชการ Duplicate เสน Nurbs ใหขนาดนั้น จากนั้นรวมเสนให

เปนวัตถุเดียวกัน แลวใชคําส่ัง Make Segment เพื่อสรางพื้นผิว โดยวิธีนี้นิยมใชสรางวัตถุที่ตองมีโครงรางกอน เชน 

รถยนต เปนตน 
 

การสรางวัตถุจาก NURBS Circle 
ตอไปเราจะรูจักกับการสรางพื้นผิวอีกวิธีหนึ่ง โดยคราวนี้เราจะมารูจักกับการสราง

พื้นผิวดวย Nurbs Circle บาง โดยคลิกเลือก ADD>Surface>NURBS Circle เสน NURBS 

Circle จะมีลักษณะเปนเสนวงกลม โดยวิธีการปรับแตงจุด เสน และพื้นผิวก็จะมีการปรับแตง

ที่คลายกันกับ NURBS Curve สังเกตไดจากเครื่องมือตางๆ ใน Curve Tools ที่ไมตางกัน   
 

ทําการ Extrude เพ่ือสรางพ้ืนผิวใหกับ NURBS Circle 
การ Extrude เปนวิธีการสรางพื้นผิวจากโครงสรางของเสนที่เราเลือก ซึ่งเราจะลองกดแปน <E> ที่คียบอรด แลว

ลองเลื่อนเมาสไปมา จะพบวาเกิดพื้นผิวขึ้นมา เรียกวิธีการนี้วาการ “Extrude” หรือสามารถเรียกใชคําส่ังไดจาก 

Surface>Extrude และถาเราตองการกําหนดใหพื้นผิวนั้นแสดงออกมา ก็ใหเราคลิกเมาสปุมซายเพื่อทําการกําหนด

พื้นผิว แตถาไมตองการก็ใหคลิกเมาสปุมขวาเพื่อกลับสูเสน NURBS Circle เดิม 

 
กดคีย <E> แลวเลื่อนเมาสเพื่อทําการ Extrude สรางพื้นผิวใหกับเสน NURBS Circle 

 

ทดลองสรางโมเดลจาก NURBS Circle ดวยหลักการ Extrude 
สําหรับในตัวอยางนี้ เราจะมาเรียนรูวิธีการสรางพื้นผิวใหเปนวัตถ ุโดยเราจะสราง

ขวดน้ําจาก NURBS Circle ดังภาพ  

  โดยมีขั้นตอนการสรางดังนี้ 

    ขั้นตอนที ่1 สรางกนขวด 

    ขั้นตอนที ่2 สรางตัวขวดและคอขวด 

แสดงพืน้ผิวที่เกดิจาก
เสน NURBS Curve 
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    ขั้นตอนที ่3 สรางปากขวด 

    ขั้นตอนที ่4 ตกแตงและเก็บรายละเอียด 
 
 

  
 
 
 
ขั้นตอนที ่1 สรางกนขวด 
เราจะสรางขวดจากพื้นกนขวดดานลางใหเปนฐานกอน จึงจะขึ้นโมเดลไป

ถึงปากขวดได โดยเริ่มตนจากการเลือกเสน NURBS Circle จากนั้นสรางพื้นผิวที่

กนขวดดวยวิธีดังนี้  

1. ขยายพื้นผิวกนขวดโดยกดคีย <E> สรางพื้นผิวกอนเพื่อสรางพื้นผิว 

แลวกดคีย <S> ขยายออกมา จากนั้นคลิกเมาสปุมซายเพื่อกําหนดพื้นผิว  

2. เราจะปรับใหอยูในมุมมอง Perspective เพื่อดูพื้นผิวในอีกมุมมอง ซึ่ง

เราจะเห็นการเปลี่ยนแปลงในการ Extrude ไดชัดเจน จากนั้นเลือกจุดควบคุม

ภายนอกทุกจุดของเสน NURBS Circle แลวกดแปน <E> ดึงพื้นผิวขึ้นมาในแกน z โดยกดแปน <Z> จะปรากฏเสนสีฟา

แนวตั้งในแนวแกน Z เมื่อไดความสูงของพื้นผิวที่ตองการแลวใหคลิกเมาสปุมซายเพื่อกําหนดพื้นผิว  

จาก Extrude พื้นผิวในลักษณะนี ้เราสามารถทําการ Extrude ไดอยางอิสระไมวาจะตามแนวแกนใด ซึ่งถา

ตองการ Extrude ในแนวแกน X ก็ใหกดแปน <E>  แลวกดแปน <X> เพื่อสรางพื้นผิวแนวแกน X แตถาตองการวัตถุใน

แนวแกน Y ดึงวัตถุ ก็ใหกดแปน <E>  แลวกดแปน <Y> เพื่อสรางพื้นผิวแนวแกน Y 

ขั้นตอนที่ 1 ขั้นตอนที่ 2 

ขั้นตอนที่ 3 ขั้นตอนที่ 4 
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ขั้นตอนที ่2 สรางตัวขวดและคอขวด 
เราจะสรางสวนขอตัวขวด ซึ่งนอกจากจะสรางในมุมมอง 

Perspective แลว เรายังสามารถในมุม Front View ไดเชนกัน และมุมมองนี้

จะชวยใหเราเห็นสัดสวนของขวดที่เราจะสรางไดชัดเจนขึ้น โดยเลือกเมนู 
View>Front  

 
 
1. สรางตัวขวดโดยกดคีย <E> ดึงพื้นผิวขึ้นมาในแกน z โดยกดแปน 

<Z> จะปรากฏเสนสีฟาแนวตั้งในแนวแกน Z 

2. ยอปลายตัวขวดดวยการกดคีย <S> แลวลากเมาสเพื่อยอ จากนั้นคลิกเมาสซาย 1 ครั้งเพื่อกําหนดขนาดของ

ตัวขวด 

3. สรางคอขวดโดยกดคีย <E> ดึงพื้นผิวขึ้นมาในแกน z โดยกดแปน <Z> จะปรากฏเสนสีฟาแนวตั้งในแนวแกน 
Z 

 
 
 
 

1. ขยายพื้นผิวกนขวดโดยกดคีย <E> 
กอนแลวกดคีย <S> 

2.1 เลือกจุดควบคุมภายนอกทุกจุด
ของเสน NURBS Circle 

2.2 กดคีย <E> ดึงพื้นผวิขึ้นมา แลว
กดคีย <Z> เพื่อดึงพื้นผวิในแกน Z 

เปลี่ยนมุมมองมาเปน Front 

1. กดคีย <E> แลวกดคีย <Z> 
เพื่อดึงตัวขวดในแกน Z 

2. กดคีย <S> ยอตัวขวด 3. กดคีย <E> แลวกดคีย 
<Z> เพื่อดึงคอขวดในแกน Z 
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ขั้นตอนที ่3 สรางปากขวด 
ในสวนปากขวดนั้น เราจะยังคงใชวิธีเดิมนั้นคือการ Extrude ดังนี้ 

1.  สรางปากขวดโดยกดคีย <E> ดึงพื้นผิวขึ้นมาในแกน z  โดยกดแปน <Z>   แลวขยายปลายตัวขวดดวย

การกดคีย <S> แลวลากเมาสเพื่อยอ  

2.  จากนั้นให Extrude ปากขวดขึ้นมา 2 ครั้งตอกัน แลวกดแปน <S> ยอปากขวดสวนปลายเขามา 

3.  สรางดานในของปากขวด  โดยกดแปน  <5>เปล่ียนมาเปนมุมมอง  Perspective    กอนเพื่อใหเห็นการ

ทํางานไดชัดขึ้น แลวกดคีย <E> และ <S> ยอขนาดพื้นผิวเขาไป คลิกเมาสปุมซาย 1 ครั้ง  

4.  เมื่อเรายอปากขวดเขาไปแลว  เราจะดึงปากขวดซอนเขาไปขางใน  โดยกดแปน  <E>  และ  <Z>  เล่ือน

เมาสลงไปในขวด คลิกเมาสซาย 1 ครั้ง 

5.  และสุดทายเก็บสวนปลายพื้นผิวใหเขาไปในสวนปากขวด  โดยกดแปน  <E>  กดแปน  <s>  ขยายปาก

ขวดเขาไปแลว คลิกเมาสซาย 1 ครั้ง   

 
 

2. กดคีย <S> ยอตัวขวด 

2. ทําการ Extrude ปากขวดขึน้มาอีก 2 ครั้งตอกัน แลวกดแปน <S> ยอปากขวด 
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ขั้นตอนที ่4 ตกแตงและเก็บรายละเอียด 
สําหรับขั้นตอนนี้จะเปนการจัดรูปทรงและเก็บรายละเอียดในสวนที่ยังไมเรียบรอย นั่นคือสวนของกนขวดที่เรา

สรางในครั้งแรก ซึ่งถาปรับมุมมองมาก็จะพบวากนขวดยังมีชองวาอยู โดยวิธีการตกแตงขวดมีดังนี ้

1. จากขั้นตอนที่ผานมา เราก็จะไดรูปทรงขวดที่สรางจากเสน Nurbs Curve และเมื่อเรา

เล่ือนมุมมองมาที่กนขวด จะพบวาที่กนขวดนั้นมีชองวาที่พื้นผิวไมติดกัน เนื่องจากเราสรางขวดนี้

จากเสนวงกลมแลว Extrude ออกมา จึงทําใหมีรูหรือชองวางบริเวณกนขวด วิธีแกไขคือ ตองรวม

จุดรอบวงกลมนั้นใหกลายเปนจุดเดียว โดยเลือกจุดใดจุดหนึ่งในวงกลม แลวกดคีย <Shift+R> 

หรือเลือกคําส่ัง Select>Control Point Row เพื่อเลือกจุดในแถวเดียวกับจุดที่เราเลือก  
 

3. สรางดานในของปากขวด โดยกดคีย <E> และ <S> ยอขนาดพืน้ผิวเขาไป 

4. กดแปน <E> และ <Z> ดึงปากขวดซอนเขาไปขางใน 

5. กดแปน <E> กดแปน <s> ขยายปาก
ขวดเพื่อเก็บปลายปากขวด 
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กดคีย <Shift+R> เพื่อเลือกจุดแถวเดียวกันกับจุดที่เราเลือก 

 

สังเกตวาเมื่อใชคําส่ังนี้ จุดที่อยูแถวเดียวกันแนวตั้งจะถูกเลือก ให

เรากดแปน <Shift+R> อีกครั้ง การเลือกก็จะมาอยูในแถวแนวนอน ซึ่งนั่น

ก็คือจุดรอบวงของพื้นผิวทีเราตองการ  
 
 
 
 
 
3. นอกจากนั้น เรายังสามารถกลับไปปรับแตงวัตถุไดอีก โดยใช

คําส่ัง Extrude เริ่มจากกดคีย <A> เพื่อยกเลิกการเลือกจุดทั้งหมด แลวกด

คีย <B> เพื่อทําการเลือกจุดแบบเลือกพื้นที่ จะปรากฏเสนประในแนวตั้งและ

นอน คลิกเมาสซายคางไว แลวลากเมาสครอบบริเวณจุดที่เราตองการทั้งหมด 

จะเปนเลือกจุดเพื่อปรับแตงเพิ่มเติม  
 
 
 
 
 
 
 
 
4. เราสามารใชอุปกรณ Scale โดยกดแปน <S> เพื่อยอหรือขยายได หรือ

เล่ือนสวนที่เลือกขึ้นหรือลงดวย Translate เพื่อปรับรูปทรงขวดไดตามตองการ  
 
 
 
 
 
 
 
 
 

หลังจากปดชองวางตามคําสั่งที่เรากําหนด 

กดคีย <B> เพื่อทําการเลือกปรับแตง
เฉพาะพื้นที่ๆ ตองการ 
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การสรางวัตถุจาก NURBS แบบอื่นๆ 
ตอไปเราจะรูจักกับวัตถุ NURBS ที่เหลือ นั่นคือ NURBS Surface, NURBS Tube, NURBS Sphere และ 

NURBS Donut ซึ่งวัตถุทั้งหมดนี้ก็จะมีลักษณะของวัตถุและวิธีการปรับแตงที่เหมือนกัน 

 
 

วัตถ ุNURBS Surface 
เปนวัตถุที่แสดงพื้นผิวอิสระที่เราสามารถสรางและปรับแตงไดอยางอิสระ เชน เราจะคลิกเมาสปุมขวดเลือกวัตถุ 

NURBS  Surface แลวกดคีย <Tab> เขาสู Edit Mode แลวทดลองคลิกเมาสปุมขวดเลือกจุดใดจุดหนึ่งและลากเมาส

เพื่อเปล่ียนตําแหนงจุดใหม 

 
ทดลองเลือกจุดใดจุดหนึ่งและลากเมาสเพื่อเปลี่ยนตําแหนงจดุใหม 

 

ถาเราตองการเลือกจุดในแถวนั้นๆ ก็ใหคลิกเลือกจุดในแถวที่ตองการ แลวกดคีย <Shift+R> เราก็จะสามารถ

เลือกจุดไดทั้งแถวนั้น จากนั้นลองกดคีย <Shift+R> อีกครั้ง ก็จะเปนการเลือกระหวางแถวแนวนอนกันแนวตั้ง 

 
เลือกจุดทั้งแถวโดยกดคีย <Shift+R> แลวสามารถกดคีย <Shift+R> เพื่อสลับแนวของแถวที่เลือก 
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นอกจากนั้นเราสามารถทํางานรวมกันคําส่ัง Endpoint U โดย

คลิกเลือกที่ปุม Endpoint U ในแท็ป Curve Tools และคลิกเลือกปุม  

Endpoint V ก็จะเปนการแสดงพื้นผิวแบบเต็มโครงสรางของ Nurbs 
Surface    

 
 
 
 
 
 

 
      กอนเลือกปุม  (Endpoint U)          เม่ือกดปุม                      เม่ือกดปุม  (Endpoint V) 
 

ถาเราเลือกจุดในแถวใดๆ แลวกดคีย <E> ก็จะเปนการเพิ่มพื้นที่ผิวใหมขึ้นมา 

 
 
เลือกจุดในแถวดานซายของพื้นผิว   กดคีย <E> เพิ่มพื้นท่ีผิวใหมขึ้นมา 
 

เราสามารถเพิ่มจุดหรือแบงพื้นผิวใหมีสวนยอยมากขึ้นดวยคําส่ัง Subdevide โดยเราจะทดลองแบงทั้งพื้นผิว 

ใหคลิกเลือกคีย <A> เพื่อเลือกจุดของพื้นผิวทั้งหมด แลวกดคีย <W> แลวคลิกเลือกที่ Subdevide 

 

แสดงพืน้ผิวแบบเต็มโครงสราง 

กดคีย <W> แลวคลิกเลือกที่ Subdevide พื้นผิวจะถูกแบงยอยมากขึ้น 
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เรายังสามารถใชคําส่ัง Subdevide เฉพาะพื้นที่ได โดยเลือกพื้นผิวบางสวนดวยการกดคีย <B> แลวลากเมาส

ครอบสวนที่ตองการ  จากนั้นกดแปน <W> เลือก Subdevide พื้นที่สวนนั้น จากนั้นเราก็สามารถปรับแตงพื้นผิวได โดย

เลือกจุดที่ตองการ แลวใชอุปกรณ Transformation 

 
วัตถุ NURBS Tube, NURBS Sphere และ NURBS Donut  

เราจะใชวิธีการเดียวกันในการปรับแตงทั้งวัตถุ  NURBS Tube, NURBS Sphere และ NURBS Donut โดยแต

วัตถุก็เหมาะกับการขึ้นรูปโมเดลที่ตางกัน โดยโมเดลนั้นนั้นมีพื้นฐานจากวัตถุรูปทรงใดก็ใหเลือกใชตามความเหมาะสม 

เชน ถาตองการสรางหัวคน หัวสัตว ก็ใหใชวัตถุ NURBS Sphere ได โดยเลือกวัตถุ แลวกดแปน TAB เขาสู Edit Mode 

แลวเลือกจุดที่เราตองการหรือเลือกหลายๆ จุดโดยใชแปน <B> แลวลากเมาส เราจะทดลองกดแปน <Delete> ที่

คียบอรด แลวเลือก Select 

 
สามารถใชวิธีการปรับแตงไดเหมือนวัตถ ุNURBS ทั่วไป 
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บทที่ 7 
สรางวัตถุแบบอื่นๆ 

 
สําหรับบทนี้เราจะกลาวถึงการสรางวัตถุแบบอื่นๆ ที่นอกเหนือจากโครงสราง Mesh และ Curve ซึ่งในโปรแกรม 

Blender นั้นจะมีอีกสองวัตถุนั้นคือ วัตถุ Meta และวัตถุ Text สําหรับสรางตัวอักษร 

 
การสรางโมเดลจากวัตถุ Meta 

  ในหัวขอนี้เราจะทําความรูจักกับวัตถุพื้นฐานชนิด Meta ซึ่งวัตถุชนิดนี้มีความแตกตางจากวัตถุชนิด

อื่นคอนขางมาก กลาวคือ วัตถุชนิด Meta นี้มีคุณสมบัติการหลอมรวมของวัตถุ เสมือนเปนกึ่งของเหลวนั่นเอง ดังนั้นวัตถุ 

Meta ทั้งหมดก็จะสามารถหลอมรวมกันไดในลักษณะดังภาพ 

 
วิธีการสรางวัตถุ Meta 

การสรางวัตถุ Meta สามารถสรางโดยเลือกเมนู Add เชนเดียวกับวัตถุชนิดอื่นๆ โดยการกดคีย <Spacebar> 

เลือกเมนู Add>Meta จะพบวัตถุใหเลือก 5 แบบดวยกัน ดังนี้ 

 
คลิกเลือกคําสั่ง Add>Meta>แลวเลือกวัตถุที่ตองการ 
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สําหรับตัวอยาง เราจะเลือก Mata Ball สรางรูปทรงกลม 1 ชิ้นซึ่งลักษณะภายนอกเหมือนกับทรงกลมทั่วๆ ไป 

แตเมื่อเลือกสรางวัตถุ Meta ขึ้นมาอีกชิ้น คราวนี้จะเลือก Meta Tube และลองทําการเลื่อนวัตถุดู ก็จะพบวาวัตถุชนิด 

Meta นี้มีคุณสมบัติการหลอมรวมของวัตถุดังที่กลาวไป 

 
ทดลองสรางวตัถ ุMeta ชิ้นแรก 

 
 

คุณสมบัติของวัตถุ Meta 
วัตถุ Meta จะไมสามารถปรับแตงโครงสรางไดเหมือนวัตถุประเภทอื่นๆ แตสามารถใชเครื่องมือเคลื่อนยาย 

หมุน เปล่ียนขนาด หรือทําการสําเนาวัตถุไดตามปกติ 

สรางวตัถ ุMata อื่นขึ้นมา เม่ือลองลากวัตถใุหมไปมา 
จะสังเกตวามีการหลอมรวมกันระหวางวตัถ ุ

Page 166



 
 

ตัวอยางการสรางโมเดลจากวตัถุ Meta 
สําหรับการสรางโมเลดวยวัตถุ Mata นี้ เราควรเลือกสรางโมเดลที่

สามารถนําจุดเดนของคุณสมบัติวัตถุ Mata มาใชได ดังเชนตัวอยางนี ้เรา

จะสรางตัวการตูนจากวัตถุ Mata ซึ่งถาสังเกตจากภาพจะพบวาเราเลือกใช

วัตถุ Mata Ball มาขึ้นรูปโดยสรางสวนหัว ลําตัว แขนและขาจากวัตถุ 

Mata Ball ทั้งหมด ดังภาพ 
 
 

ขอดีที่เลือกใชวัตถุ Mata Ball ก็คือ เราจะไดโมเดลตัวการตูนที่มี

สัดสวนเหมือนคน ซึ่งการเลือกใชวัตถุนี้จะชวยใหงายตอการขึ้นโมเดลนั้นเอง โดยขั้นตอนการสรางโมเดลดวยวัตถุ Mata 

Ball มีดังนี้ 

1. สรางตัวคนโดยเลือกคําส่ัง Add>Meta>Cube จากนั้นกดคีย <S> ขยายวัตถุในแนวตั้ง  

 
 

สรางตวัคนดวย Mata Cube แลวขยายวัตถใุนแนวตั้ง 
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2. สรางสวนแขนโดยเลือกคําส่ัง Add>Meta>Tube จากนั้นคัดลอกวัตถุใหเปนแขน 2 ทอนดวยการกดคีย 
<Shift+D> 

 

 
2.1 สรางแขนดวย Mata Tube     2.2 คัดลอก Mata Tube ใหเปนแขนทอนท่ี 2 
 

 
2.3 คัดลอกแขนทัง้ 2 ทอนดานซายมายังดานขวา 

 

3. สรางสวนขาโดยเลือกคําส่ัง Add>Meta>Meta Tube เชนกัน จากนั้นกดคีย <S> ขยายวัตถุในแนวยาว 

แลวลากมาเชื่อมกับลําตัว สุดทายคัดลอกขาอีกขางหนึ่งดวยการกดคีย <Shift+D> แลวหมุนสวนขากลับมามาเปนขาอีก

ขางหนึ่ง 

 
3.1 สรางขาดวยวัตถ ุMeta Tube   3.2 ขยายขาใหยาวขึ้น แลวกด <G> เลื่อนขามาติดกับลําตัว 
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4. สรางสวนหัวโดยเลือกคําส่ัง Add>Meta>Meta Ball มาวางที่ลําตัว แลวสรางเทาจากวัตถุ Mata Tube 

จากนั้นจัดใหเขาทีตามสัดสวนของหุน ดังภาพ 

 
 

     
 
 
 
 
 
 
 
 
 

3.3 คัดลอกขาอีกขางออกมาโดยกดคีย <Shift+D> 3.4 หมุนขาขางใหม แลวนํามาเชื่อมกับลําตัว 

4.1 สรางสวนหวัดวย Meta Ball 

4.2 สรางสวนเทาดวย Mate Tube 4.3 จัดทุกสวนของรายกายใหไดเปนหุน
ตามตองการ 
5. ถาตองการแกไขวัตถุแบบ Mesh ก็ใหกดคีย 
<Alt+C> เพื่อเปลีย่นเปนวัตถ ุMesh 
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การสรางตัวอักษร 
สําหรับรูปแบบการสรางโมเดลตอมา เราจะเรียนรูถึงการสรางตัวอักษร และการใชคําส่ังตางๆในการจัดการกับ

ตัวอักษร โดยเราสามารถเปลี่ยนตัวอักษรที่สรางขึ้นใหกลายเปนวัตถุประเภท Mesh และทําการปรับแตงรูปทรงของวัตถุ

ได  
 

วิธีการการสรางตัวอักษร 
เราจะเริ่มตนดวยการสรางตัวอักษรใน Front View จากนั้นใหคลิกที่เมนู Add>Text จะปรากฏตัวอักษรพรอม

กับเสนสีดํา  

 
เม่ือกดคีย <Spacebar> แลว ใหเลือกคําสั่ง Add>Text 

 

  จะปรากฏตัวอักษรคําวา “Text” ขึ้นมา 
 

เมื่อขยายมุมมองใหใกลขึ้น จะปรากฏวาเสนสีดําคือเคอรเซอรที่ใชแกไขขอความเหมือนกับโปรแกรมพิมพงาน

นั่นเอง ซึ่งเราสามารถแกไขขอความไดดวยการกด Arrow Key ที่คียบอรดในทิศทางซายและขวา เพื่อเล่ือนตําแหนงที่จะ

แก และพิมพขอความที่ตองการได  
 

การแกไขตัวอักษร 
เมื่อเราสรางตัวอักษรและแกไขใหไดคําที่ตองการแลว เรา

ยังสามารถปรับแตงตัวอักษร เพิ่มเติมไดที่แท็ป Fonts โดยคลิกที่ปุม  

Editing ดังนี้ 
 
 
 
 
 

 

แท็ป Font สําหรบัปรับแตงฟอนต 
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เปล่ียนรูปแบบตัวอักษร 
หากตองการเปล่ืยนรูปแบบตัวอักษร ใหเราเลือกแถบ Font ในสวนของ Editing โดยคลิกเลือกปุม Load จะ

ปรากฏหนาตางเพื่อใหเราคนหาฟอนตที่มีอยูในเครื่องของเรา โดยคลิกเลือกปุมแสดงที่อยู และเลือกไดรว 

C:>Windows>Fonts เราจะพบรูปแบบอักษรมากมาย (สําหรับรูปแบบฟอนตที่ใชกับ Blender ไดจะมีส่ีเหลี่ยมสีน้ําเงิน

เปนสัญลักษณ) 

 
คลิกปุม  เพื่อเขาไปเลือกรูปแบบฟอนตใน  C:>Windows>Fonts 
 

ลองคลิกเมาสกลางเลือกฟอนตที่ตองการ แลวเลือกตัวอักษรจะเปลี่ยนรูปแบบไป 

 คลิกเมาสกลางเลือกฟอนตไดหลากรูปแบบ 
 
เปล่ียนขนาดตัวอักษร 

สวนของขนาดฟอนตปรับไดที่ชอง size โดยการคลิกซายคางแลวลาก หรือคลิกที่ลูกศรปรับคา หรือพิมพคา

ตัวเลขลงไปในชองไดเลย 
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Size: ปรับขนาดตัวอักษร 
 
  นอกจากนั้น ยังมีคาอื่นๆ ที่ใชปรับแตงตัวอักษรไดดวยวีธีเดียวกันกับการปรับขนาดไดแก 

 
 

  Spacing คือระยะการเวนระหวางตัวอักษรในขอความ 

  Shear คือคาความเอียงของตัวอักษร 

  Offset ในแนว X และ Y คือคาตําแหนงที่หางออกจากจุดเริ่มตนในแกน X และ Y 

  Word spacing เปนระยะหางระหวางคําในขอความ หรือการเวนวรรค 
 

ปรับแตงรูปรางของตัวอักษร 
ในสวนของ Curve and Surface จะเปนการปรับแตงลักษณะของตัวอักษรในเชิงวัตถุ ใหเราเปลี่ยนโหมดเปน 

Object mode ดวยการกดคีย <Tab> เพื่อใหเห็นผลลัพธที่ชัดเจน จากนั้นเปลี่ยนมุมมองเปน Perspective 

   
ปรับแตงรูปรางของตัวอักษร Curve and Surface 
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การเปลี่ยนตัวอักษรใหเปนวัตถุ Mesh 

  เมื่อเรารูจักการสรางและการปรับแตงหลักๆ ของตัวอักษรไปแลว ตอมาเราจะเปลี่ยนตัวอักษรใหเปน

วัตถุเพื่อปรับแตงรูปทรงในแบบของวัตถ ุโดยใหเรากดคีย <Alt+C> แลวคลิกเลือก Curve ตัวอักษรของเราจะกลายเปน 

Curve จากนั้นกด <Alt+C> อีกครั้ง คราวนี้เลือกที่ Mesh เพื่อใหไดวัตถ ุMesh มาใชงาน 

 
 
 

 
ในการปรับแตงรูปทรงนั้น ใหเราปรับแตงใน Edit Mode เหมือนกับการปรับแตงวัตถุ Mesh ทุกประการ ซึ่ง

สามารถสามารถปรับแตงรูปทรงดวยการเลือกจุด พื้นผิว หรือเสนขอบตามตองการ 

 เราสามารถปรับแตงวตัถ ุMesh ไดตามตองการ 

 

ทดลองปรับคา Extrude และ Bevel Depth ใน Curve 
and Surface เพื่อสรางความหนาใหกับตัวอักษร 

กดคีย <Alt+C> เลือก Curve เพื่อเปลี่ยน 
Text เปน Curve กอน 

กดคีย <Alt+C> เลือก Mesh เพื่อเปลี่ยน Curve 
เปน Mesh 
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บทที่ 8 
ใสพื้นผิว 

 
หลังจากสรางโมเดลแลว จะไดวตัถุที่มีสีพื้นเปนสีเดียว ตอมาเราจะใสพื้นผิวใหกับวัตถุ เพื่อใหโมเดลนั้นส่ือ

ความหมายชัดเจนขึ้นวา วัตถุนั้นคือวัตถุประเภทใดและมีองคประกอบที่ทําจากวัสดุชนิดใด ทําใหเหมือนจริงและเพิ่มสีสัน 

สรางความสมบูรณแบบใหกับโมเดล โดยใชเครื่องมือใน Material Editor ทําการใสพื้นผิวใหกับวัตถุ 
 

ทํางานกับพืน้ผิววัตถ ุ
ในการสรางโมเดล 3 มิตินั้น การกําหนดคุณสมบัติพื้นผิว

วัตถุเปนเรื่องหนึ่งที่มีความสําคัญเปนอยางมาก เนื่องจากคุณสมบัติ

พื้นผิววัตถุจะเปนตัวกําหนดลักษณะของวัตถุที่จะปรากฏออกไปสู

สายตาคนดู ไมวาจะเปนเรื่องของสีของวัตถุ ความละเอียดของ

พื้นผิว ความมันวาว ความโปรงใส การสะทอนแสง การกระจายตัว

ของแสง เงาสะทอน ซึ่งวัตถุแตละชนิดก็จะมีคุณสมบัติที่แตกตางกัน

ไป เชน โลหะ พลาสติก ไม ผา พื้นดิน ผิวมนุษย เปนตน ในขั้นตน 

เราจะมาทําความเขาใจกับพื้นฐานของคุณสมบัติพื้นผิววัตถุใน

โปรแกรม Blender กันกอน  

 

ความเขาใจเกีย่วกับพ้ืนผิวของวัตถุใน Blender 
โดยปกติแลว เราจะสามารถเห็นพื้นผิววัตถุไดก็ตอเมื่อมีแสงสองมาตกกระทบยังพื้นผิววัตถุเทานั้น หากไมมีแสง

สองถึง เราก็จะเห็นวัตถุเปนรูปทรงที่ดํามืด เมื่อมีแสงสองมากระทบตัววัตถุ วัตถุนั้นจะมีการสะทอนแสงที่กระทบกลับเขาสู

สายตาของเรา ทําใหเราสามารถเห็นวัตถุได  

ในโปรแกรม Blender นั้น แหลงของแสงจะถูกเรียกวา “Lamp” หรือหลอดไฟ ซึ่งมีหลายประเภท สวนพื้นผิว

วัตถุจะถูกเรียกวา “Surface” สําหรับ Surface ที่ถูกแสงสองกระทบนั้น จะสะทอนแสงกลับในลักษณะการกระจาย ซึ่งมี

ความเขมขนของแสงในแตละตําแหนงตางกันไป 

จุดที่มีความเขมขนของแสงมากสุดในพื้นผิววัตถุจะเรียกวา 

“Specular” สวนจุดอื่นๆ ที่มีแสงสองถึงและสามารถเห็นผิววัตถุไดจะ

เรียกวา “Diffuse”   

ซึ่งทั้ง Specular และ Diffuse นี้ จะเปนปจจัยหลักๆ ที่จะบงบอก

วาวัตถุนั้นเปนวัตถุประเภทใด เพราะทั้ง 2 คานี้จะเปนตัวกําหนดความมัน

วาว การสะทอนแสงของวัตถุได  
การกําหนดพื้นผิวใหกับวัตถุ 

ในหัวขอนี้เราจะมากําหนดพื้นผิวใหกับวัตถุ ซึ่งการกําหนดผิวนั้นก็จะเปนการกําหนดสีใหกับวัตถ ุลักษณะของผิว 

ความขรุขระ ความมันวาว โดยการทํางานเหลานี้สามารถทําไดในโหมด Shading  

Page 174



โดยเริ่มตนเราจะนําวัตถุที่สรางเสร็จแลวมาทดลองใสพื้นผิว โดยในตัวอยางเปนเกาอี้ จากนั้นใหเราคลิกขวาเลือก

เกาอี ้และคลิกเมาสซายที่ปุม  Shading หรือกดคีย <F5> จะมีสวนของการปรับแตงขึ้นมาคือ Material 

 
การกําหนดพื้นผิวใหกับวัตถุ 

ในหัวขอนี้เราจะมากําหนดพื้นผิวใหกับวัตถุ ซึ่งการกําหนดผิวนั้นก็จะเปนการกําหนดสีใหกับวัตถ ุลักษณะของผิว 

ความขรุขระ ความมันวาว โดยการทํางานเหลานี้สามารถทําไดในโหมด Shading  

โดยเริ่มตนเราจะนําวัตถุที่สรางเสร็จแลวมาทดลองใสพื้นผิว โดยในตัวอยางเปนเกาอี้ จากนั้นใหเราคลิกขวาเลือก

เกาอี ้และคลิกเมาสซายที่ปุม   Shading หรือกดคีย <F5> จะมีสวนของการปรับแตงขึ้นมาคือ Material 

 
 
สรางวตัถุทีต่องการใสพื้นผวิขึ้นมา 
 

  
กอนใสพื้นผิว  หลังใสพื้นผิว 
 

Page 175



เมื่อเขาสูโหมด Shading ก็จะเปนการกําหนดคุณสมบัติพื้นผิววัตถุ โดยขณะปรับรายละเอียดวัตถุก็จะถูกเปลี่ยน

พื้นผิวตามไปดวย ซึ่งมีรายละเอียดใหเราไดกําหนดมากมาย ดังนี้ 

 
 

ปุม   (Col)  

ใชเลือกสีของวัตถุ โดยคลิกซายแลวจะมีหนาตางสีขึ้นมา เมื่อคลิกซายเลือกสีแลว 

วัตถุก็จะเปลี่ยนสีตามที่เราเลือก หรือจะใชคาแมสีผสมกันจนไดสีที่ตองการดวยการเลื่อน 

Slide Bar หรือพิมพคาลงไปได 
 
 

 
หนาตาง Preview  

มีไวสําหรับดูผลการปรับแตงพื้นผิวที่เรากําลังทํางาน ซึ่งสามารถเลือกไดวาจะให 

Preview เปนรูปทรงอะไร เชน ทรงกลม ส่ีเหลี่ยม ซึ่งการ Preview นี้ไมสงผลเปลี่ยนแปลง

ใดๆ กับวัตถุจริง 
 
ตั้งช่ือใหกับพ้ืนผิว  
เราสามารถตั้งชื่อใหกับพื้นผิวที่เราเพิ่งสรางมานี้ได โดยการพิมพในชองเปลี่ยนชื่อนี้

ได  
 
 
 
แท็ป Shaders  
  การกําหนด Shaders ของวัตถุจะกําหนดได 2 สวนคือ Diffuse 

Shader และ Specular Shader  

Diffuse Shader เมื่อคลิกตัวเลือกดู จะพบวามีชนิดของ Shader ตางๆ ใหเลือก 

ซึ่งแตละแบบมีคุณสมบัติการสะทอนและกระจายแสงแตกตางกันไป ดังนี้ 

• Mannaert เหมาะสําหรับใชกับวัตถุที่ตองการใหมีเงามืดเกิดขึ้นบน

วัตถุ เชน ไม พลาสติก เหล็ก หนังสัตว เปนตน 

• Fresnel จะเปน Shader ที่มีคาการสะทอนแสงสูง ทําใหวัตถุสามารถ

แสดงสีจริงออกมาไดชัดเจน แตแสงเงาจะไมชัดเจนเหมือน Shader อื่นๆ 

• Oren‐nayar เหมาะกับวัตถุที่มีพื้นผิวหยาบเชน ผา  พื้นผิวของผนังปูน 

พื้นดิน ผิวคน เปนตน 

• Toon เหมาะกับการแสดงผลการเรนเดอร ในลักษณะลายเสนการตูน 
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• Lambert จะเปน Shader พื้นฐานที่มีการตกกระทบของแสงพอดีไมมากหรือนอยไป เหมาะกับพื้นผิว

วัตถุ ทั่วๆไป เชน  โลหะ, แกว, ไม, เซรามิค เปนตน 
 
เมื่อเลือกชนิดของ Diffuse แลว เชน เลือก Lambert แลว เราสามารถปรับคาของ Diffuse ชนิดนั้นๆ เชน คา

การสะทอน (Reflection) และคาความมืดของพื้นผิว (Darkness) ได 
 

 
 

ปรับคาเพิ่มเติมใหกับพื้นผิว 
 

Specular Shader จะเปนการกําหนดคุณสมบัติของแสงสะทอน ซึ่ง 

Specular ตางชนิดกันก็มีคุณสมบัติตางกันไปเชนกัน ดังเชน Toon: สําหรับแสดง

แสงสะทอนแบบการตูน Blinn: แสดงแสงสะทอนแบบเนื้อผา, Phong: แสดงแสง

สะทอนแบบวัตถุแกว เปนตน  
 

 
 

กําหนดพื้นผิวใหกับวัตถุอ่ืน 
 ตอมาเราจะกําหนดพื้นผิวใหกับวัตถุช้ินอื่นๆ โดยใชพ้ืนผิวของเกาอี้ที่ผานมา ซึง่สังเกตเห็นวาในสวนของพื้นผิว
ของโตะในตัวอยางนั้นจะไมมีรายละเอียดใดๆ เพราะยังไมไดกําหนดนั่นเอง  
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 ตองการใสพืน้ผวิของเกาอี้ใหกับโตะ ใหคลิกเมาสขวาเลือกโตะ 

เราสามารถนําพื้นผิวที่เราเพิ่งสรางไปมากําหนดเปนพื้นผิวของวัตถุชิ้นใหมได โดยการคลิกซายที่ปุม  

 (Add New) แลวเลือกที่ปุม     และคลิกเลือกชื่อที่เราเพิ่งตั้งไป วัตถุชิ้นใหมก็จะมี

พื้นผิวเหมือนวัตถุชิ้นแรกที่เราไดทําไปทันท ี

      
 
หากเราตองการสรางเปลี่ยนพื้นผิวนี้ใหเปนพื้นผิวใหม ก็เพียงตั้งชื่อใหกับพื้นผิวนั้น เมื่อตั้งชื่อแลวใหเราลอง

เปล่ียนแปลงคาบางอยาง เชน สี เพื่อใหเห็นความแตกตาง  
 
 

ใสลวดลลายใหกับพืน้ผิววัตถุ 
หลังจากที่เราไดรูจักกับวิธีการกําหนดพื้นผิวใหกับวัตถุ รวมทั้งคุณสมบัติตางๆ ที่สรางความมันวาว ความโปรงใส 

และคุณสมบัติอื่นๆ มาแลว ในหัวขอนี้ เราจะมาเรียนรูจักวิธีการใสพื้นผิวที่เปนลวดลายใหกับวัตถุบาง ซึ่งลวดลายเหลานี้

จะชวยสรางความโดดเดนของพื้นผิวไดดี และชวยชี้ใหเห็นชัดขึ้นมาวัตถุเหลานี้เปนวัตถุประเภทใด  

เชน ถาเกาอี้ถูกใสลวดลายไมเขาไป ก็จะชวยบอกวาวัตถุนี้ทํามาจากไม แตถาใสพื้นผิวมันวาวก็อาจบอกไดวา

เปนโลหะ หรือถาใสพื้นผิวลายการตูนก็จะบอกไดวานี่เปนเกาอี้สําหรับเด็ก นั่นเอง 

 
 

เลือกพื้นผิวของเกาอี้ 

เราจะไดพื้นผิวของโตะ
และเกาอี้สีเดียวกัน 
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สําหรับการเขาสูการสรางลวดลายใหกับวัตถุนั้น ใหเราคลิกที่ปุม   (Shading) หรือกดแปน <F5> แลวกด

ปุม   (Texture Buttons) จากนั้นในแท็บ Texture ใหเราคลิกที่ปุม   ในสวนของ Text Type จะมี

ลวดลายที่โปรแกรมเตรียมไวให  

 
 
 
 

 
ใสลวดลายจากรูปแบบที่โปรแกรมกําหนด 

เราสามารถที่จะใชลวดลายที่โปรแกรมเตรียมไวใหได โดยคลิกเลือกที่ Texture Type แลวเลือกลวดลายที่

ตองการ ดังตัวอยาง เลือกลาย Marble 

 
 
ทดลองเรนเดอรดูโดยกดแปน <F12> ที่คียบอรดเพื่อดูผลลัพธ  พื้นผิวใหมก็จะ

แสดงแทน  
   
 
 
 
 
 
 
นอกจากการใชพื้นผิวสําเร็จรูปที่โปรแกรมเตรียมใหแลวนั้น เรายังสามารถปรับรายละเอียดของพื้นผิวเพิ่มเติมได

อีก โดยปรับที่ลวดลายโดยคลิกปุม Texture ในแท็ปเฉพาะของลวดลายนั้น  

1. คลิกท่ีปุม Shading แลวกด
ปุม Texture Buttons 

2. คลิกท่ีปุม Add New 
3. เลือกลวดลายไดจาก Texture Type 
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ในตัวอยางเราใชลวดลายของ Marble จึงปรับรายละเอียดเพิ่มเติมใน

แท็ป Marble โดยในปุมแถวบนจะเปนการเลือกลวดลายใหกับพื้นผิว หรือสามารถ

เพิ่มคา Noise และ Turbulance โดยคลิกเมาสซายคางไว แลวเลื่อนเพื่อหรือลด

คาใหไดลวดลายตามตองการ (สามารถดูลวดลายประกอบไดจากแท็ป Preview)  
 

 
ปรับคาลวดลาย Marble เชน เลือกใหเปน Shaper ทําใหลวดลายคมชัด, เลือกคา Noise ใหลดลงเพือ่ใหลวดลายหางขึ้นเกิด
พื้นที่มากขึ้น 
 

 ผลลัพธหลังการปรับเพิ่มเติม 

จากนั้นเราก็สามารถปรับพื้นผิวเพิ่มเติมไดอีก โดยคลิกกลับมาท่ีปุม   Material Button ก็จะพบกับการ

ปรับแตงพื้นผิว ดังนี้ 

 
 

แท็ป Map to 
เราสามารถเปลี่ยนสีของลวดลายไดโดย คลิกในพื้นที่สี แลวคลิกเมาสปุม

ซายเลือกสีใหม เชน เลือกสีเหลือง หรือเราอาจเลือกสีไดจากการผสมสีทั้ง 3 นั่นคือ 

แดง เขียว น้ําเงิน โดยคลิกเมาสซายคางไว แลวเลื่อนสไลดสี  

 
 

 

ใชเปลี่ยนสีใหวัตถุ 
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ปุม Col เปนปุมที่ส่ังใหแสดงลวดลายขณะปรับแตงพื้นผิวในแท็ป 

Preview ซึ่งถาไมคลิก ก็จะไมมีการแสดงลวดลายใดๆ 

  
    คลิกปุม Col             ไมคลิกปุม Col 
 

ปุม Nor หรือปุม Normal จะเปนการนําลวดลายมาแปลงใหเปนเฉดสี ขาว เทา และดํา ทําใหพื้นผิวมีมิติ

ความลึกและนูน โดยสีออนจะมีลักษณะนูนขึ้น สีเขมจะลึกลงไป ซึ่งวิธีนี้จะชวยประหยัดทรัพยากรเคลื่อนชวยใหไมตองใช

ทรัพยากรหนักมากในการเรนเดอร เนื่องจากวิธีการนี้เปนเพียงจากหลอกตา โดยการจัดแสงเขามาชวย เหมาะกับการสราง

เกมที่จะชวยประหยัดทรัพยากรขณะเลนเกมไดดี  

 
       เลือกปรับปุม Nor และคา Nor   กอนปรับคา Nor           หลังปรับคา Nor 

 
พื้นผิวหลงัการปรบัใหมีมิต ิ

 

แตถาเราตองการสรางใหพื้นผิวมีมิติและมีความนูนลึกจริงๆ ก็ใหเราคลิกที่ปุม Display  

 
 
และวิธีการคลิกของปุม Normal และ Display นั้นจะมีจังหวะการคลิกอยู 3 จังหวะ คือ  

  จังหวะที ่1 เปนการเลือกใชคุณสมบัติ   

  จังหวะที ่2 เปนการสลับระหวางโทนสีออนและเขม เพื่อสลับใหการคํานวณจากสวนนูนเปนสวนลึก 

และสวนลึกเปนสวนนูน  

เลือกปรับปุม Col และคา Col 

คลิกปุม Display เพื่อแสดงคา
พื้นผิวใหมีมิติจรงิๆ 
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  จังหวะที ่3 เปนการยกเลิกการใชงานคุณสมบัตินั้น  

สวนปุมอื่นๆ จะเปนการปรับลวดลายของพื้นผิวเชนกัน ซึ่งเราสามารถเลือกคลิกเพื่อดูความเปลี่ยนแปลง และ

เลือกปรับไดตามตองการ เชน ปุม Reflective จะใชควบคุมการการสะทอนแสงของวัตถุ และปุม Specularity ใชควบคุม

แสงที่ตกกระทบบนพื้นผิวของวัตถ ุ
 

แท็ป Map Input  
ใชสําหรับปรับลักษณะการวางตัวและขนาดของลวดลาย โดยใหคลิกเมาสปุมซายคางไวที่ปุมดังกลาว แลวเลือก

ปรับคาตางๆ ก็จะพบวาลวดลายของพื้นผิวก็จะเปลี่ยนไปดวย เชน  

  คา Offset จะเปนการเปลี่ยนตําแหนงการวางตัวของลวดลาย  

  คา Size  จะใชกําหนดขนาดของลวดลาย   
 

     
 
 

  
  นอกจากนั้น เรายังสามารถเลือกแปะหรือหอหุมลวดลายใหกับวัตถุตามลักษณะของวัตถุที่ใชได เชน   

  Flat ทําการแปะพื้นผิวใหกับวัตถุที่มีลักษณะแบน  

  Cube ทําการแปะพื้นผิวที่มีลักษณะเปนรูปทรงลูกบาศก  

  Tube ทําการแปะพื้นผิวใหกับวัตถุที่มีลักษณะเปนหลอดยาวหรือทรงกระบอกก็ได 

  Sphere ทําการแปะพื้นผิวใหกับวัตถุที่มีลักษณะทรงกลม 

 
 

ใสลวดลายจากไฟลภาพ 
นอกจากลวดลายที่โปรแกรมกําหนดมาใหเรา เรายังสามารถเลือกใชไฟลภาพมาสรางเปนลวดลายใหกับพื้นผิว

ไดเชนกัน โดยเริ่มตนใหเราคลิกเลือกลวดลายจาก Texture Type จากนั้นเลือก Image ดังภาพ 

คา Offset 

คา Size หลังปรับคา 
Offset และ Size 

กอนปรับคา 
Offset และ Size 
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ในสวนของการทํางานกับ Texture Buttons ใหเลือก Image ท่ี Texture Type 
 

วิธีการนําไฟลรูปภาพใหมาเปนลวดลายนั้น ทําไดโดยใหคลิกปุม   จะแสดงหนาตางของไฟล

บราวเซอรขึ้นมา โดยใหเราคลิกเลือกปโฟเดอรที่เก็บไฟลภาพนั้นไว แลวเลือกไฟลภาพที่เราตองการ จากนั้นคลิกที่ปุม 

Select Image ไฟลภาพนั้นและโฟลเดอรที่เก็บไฟลก็จะปรากฏอยูในชองนี้ และแสดงภาพตัวอยางในแท็ป Preview 
 

2. เลือกไฟลภาพที่ตองการ แลวคลิกปุม Select Image 

 
1. คลิกปุม Load Image 
 

 
3. ไฟลภาพนัน้จะแสดงในหนาตาง Preview 
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 หลังจากทดลองเรนเดอรจะเห็นพื้นผิวที่เปนไฟลภาพปรากฏอยูบนวัตถ ุ
 

สรางพ้ืนผิวที่มากวา 1 ลวดลายขึ้นไป 
ในโปรแกรม Blender เราสามารถเพิ่มลวดลายใหมากกวา 1 ลวดลายได โดยคลิกที่แท็ป Texture คลิกเลือก

ปุมวาง แลวคลิกที่ปุม  จากนั้นจะเปนการกําหนดพื้นผิวและลวดลายใหมเหมือนกับการกําหนดพื้นผิวและลวดลายที่ผาน

มา ดังตัวอยางตอไปนี้ เราจะสรางพื้นผิวใหมตอจากพื้นผิวเดิม (ซึ่งเปนไมที่สรางจากไฟลภาพ)  

 
 

 
 
 

 
 

1. หลังจากที่เราสรางลวดลาย
แรกไวแลว ใหคลกิที่ปุมวาง 

2. คลิกที่ปุม Add New เพิ่ม
ลวดลายใหมเขาไป 
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 หลังจากทดลองเรนเดอรจะเห็นพื้นผิว 2 พื้นผิวผสมกัน 
 

จากวิธีการดังกลาว เราสามารถเพิ่มลวดลายใหมากขึ้นไดอีก โดยคลิกที่ปุมวาง และคลิกเลือก Add New ดัง

ขั้นตอนที่ผานมา และจากการทํางานลักษณะนี้จะทําใหเรามีลวดลายเพิ่มเขามาซอนกับลวดลายเดิม ซึ่งเราสามารถ

เลือกใชลวดลายทั้งสอง หรือเลือกอยางใดอยางหนึ่งก็ได โดยคลิกเลือกใชพื้นผิวที่หนาชื่อของพื้นผิวนั้น 
 

 
คลิกทําเครื่องหมายหนาลวดลายทีต่องการใชงาน 
 

3. เลือกลวดลายตามที่ตองการ ในตัวอยางเลือก 
Voronoi และสามารถปรับแตงลวดลายเพิ่มเติม โดย
ดูความเปลี่ยนแปลงไดจากหนาตาง Preview 4. คลิกกลับมาที่ปุม Matterial Buttons แลวเลือก

ปรับสีสัน คาตางๆ ไดเหมือนกับการปรับพื้นผิวปกติ 
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บทที่ 9 
ทํางานกับแสง 

 
แสงเปนสวนประกอบสําคัญในการจัดฉาก โดยเราจะตองเรียนรูและฝกฝนในการปรับแตงแสง โดยเลือก

แหลงกําเนิดแสงแบบตางๆ ใหเขากับช้ินงานของเรา เพื่อเปนประโยชนในการจัดฉากใหไดอารมณที่เราตองการ 

นอกจากนั้นยังตองทําความเขาใจเกี่ยวกับหลักความจริงในเรื่องของแสงรวมดวย เพื่อจะนําหลักการเหลานั้นมาชวยในการ

ตกแตงฉากใหสวยงามมากขึ้น ในสวนนี้เราจะกลาวถึงการกําหนดแสงในรูปแบบตางๆ ของ Blender 
 

ความรูเบ้ืองตนเรื่องการใสแสงใหชิ้นงาน 
ในหัวขอนี้ เราจะมาทําความรูจักกับแสงในการสรางงาน 3 มิติดวยโปรแกรม Blender ซึ่งแสงดังกลาวมี

ความสําคัญอยางมากตอการมองเห็นวัตถุ การปรับใหมีความสวางในฉาก พรอมทั้งชวยใหเกิดมิติที่เหมือนจริงมากขึ้น 

 
และสําหรับแสงในโปรแกรม Blender นั้น จะมีบทบาทสําคัญคือ จะชวยใหเรามองเห็นรายละเอียดของวัตถุ เชน 

พื้นผิว สีสัน ความมันวาว ความเรียบหรือขรุขระ และในทางกลับกัน ถาเราไมใสแสงลงไปวิวพอรต ผลที่เกิดขึ้นจะทําให

วัตถุที่วางอยูในฉากกลายเปนวัตถุสีดํา มองไมเห็นรายละเอียดใดๆ   

 
ดังในตัวอยางนี้ เปนผลจากการเรนเดอรวัตถุทรงกลมที่มีการใสแสงลงไปในฉากและไมไดใสแสง เราจะพบวา

ภาพทางซายเปนภาพที่มีการใสแสงลงไปในฉาก ทําใหเราสามารถมองเห็นรายละเอียดของวัตถุไดชัดเจน และภาพ

ทางขวาเปนภาพที่ไมมีการใสแสงลงไป สังเกตวาวัตถุนั้นจะดํามืดจนกระทั่งมองไมเห็นรายละเอียดใดๆ 
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การสรางแสงในโปรแกรม Blender  
เมื่อเราเปดโปรแกรม Blender เขามา เราจะพบแสง 1 ดวงที่ปรากฏอยูบนวิวพอรต มีลักษณะเปนวงกลมและมี

จุดสีดําตรงกลาง วางอยูใกลๆ กับวัตถุเสมอ เราเรียกวัตถุแสงในโปรแกรม Blender นี้วา “Lamp” 

  

Lamp ในววิพอรตที่โปรแกรมกําหนดมาให 
 

แตถาเราตองการสราง Lamp ดวงใหมขึ้นมา ก็ใหคลิกที่เมนู Add>Lamp จากนั้นจะปรากฏชนิดของแสง

ทั้งหมด 5 ชนิด ไดแก Lamp, Sun, Spot, Hemi และ Area ซึ่งแสงไฟแตละชนิดจะใหแสงสวางที่ตางกัน เชน แสงสอง

เฉพาะที ่หรือแสงที่ใหความสวางโดยรวม โดยรายละเอียดของ Lamp แตละชนิดเราจะกลาวถึงในหัวขอตอไป  

ในที่นี่เราจะทดลองสรางแสงขึ้นมาเพิ่มในวิวพอรต โดยเลือกสราง Lamp แบบ Spot กอนสรางใหเรากําหนด 

Cross Hair Cursor ในตําแหนงที่ตองการวางแสงกอน 
 
1. คลิกซายกําหนด Cross Hair เพือ่จะวางแสง 

 
2. เลือกเมน ูAdd>Lamp>Spot 
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แสงแบบ Spot จะปรากฏ หลังจากนั้นเราสามารถปรับแตงแสงไดตามตองการ 
 

ทันทีที่คลิกเลือก Lamp ก็จะปรากฏขึ้นมาบนวิวพอรต จากนั้น เราจะทดลองเรนเดอร เพื่อดูผลลัพธของการใส

แสง โดยคลิกที่เมน ูRender>Render Current Frame หรือกดแปน <F12> ที่คียบอรด  

 หลังการเรนเดอร 
 
ผลจากแสงและการตกกระทบของแสง 

จากการเรนเดอร Lamp ที่เราสรางจะชวยใหวัตถุมีความสวางที่เหมือนกับแสงธรรมชาติ กลาวคือสวนที่ใกลแสง

มากที่สุดจะมีความสวางและสะทอนแสงมากที่สุด เราเรียกสวนนี้วา “Specular” และสวนที่ถูกแสงตกกระทบและมีความ

สวางที่กระจายทําใหมองเห็นสีสันและลักษณะของพื้นผิวไดชัดเจนเราเรียกวา “Diffuse” และถาในการสรางแสงนั้น ถูก

กําหนดใหแสดงเงามืดหลังจากเรนเดอร เราจะเรียกเงามืดนั้นวา “Shadow” 
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แสงในโปรแกรม Blender นั้น นอกจากจะทําใหเราเห็นรายละเอียดของวัตถุโดยรวมแลว ยังชวยใหเรามองวัตถุ

ไดอยางเขาใจมากขึ้นวา วัตถุนั้นถูกสรางใหมีพื้นผิวเปนอยางไร ถาเปนวัตถุที่มีพื้นผิวเปนไม ก็จะสะทอนแสงนอยและมี

ลวดลายของไม วัตถุที่เปนแกวจะสะทอนแสงมากกวา เปนตน  

ซึ่งลูกทรงกลมทั้งหมดนี้เราไดกําหนดพื้นผิวใหแตกแตงกัน เพื่อใหมองเห็นคุณสมบัติการกระทบแสงที่ตางกัน 

อยางไรก็ตามเราสามารถเพิ่มเติมคุณสมบัติของแสงไดอีก โดยสามารถจัดแสงใหมีความสวางมากนอย มีเงาหรือไมมีเงา 

มีการกระจายแสงที่ตางกันได ขึน้อยูกับคุณสมบัติและชนิดของแสงเปนหลัก 

 
 

เม่ือมีแสงตกกระทบ จะทําใหเราสามารถมองเห็นวัตถ ุและพื้นผิวของวัตถไุดชดัเจนในฉาก 
 

ชนิดของแสงในโปรแกรม Blender 
ตอมาเราจะมารูจักกับชนิดของแสงในโปรแกรม Blender ทั้ง 5 ชนิด โดยจะกลาวถึงลักษณะเดนของแสง ความ

เหมาะสมในการเลือกใชแสงกับงานตางๆ รวมถึงวิธีการปรับคุณสมบัติยอยของแสงเพื่อสรางความหลากหลายในการ

ทํางานมากขึ้น  

แตกอนเราจะกลาวถึงนั้น ใหลบ Lamp ที่อยูในวิวพอรตเดิมเสียกอน เพื่อใหแสงแตละแบบที่เราจะสราง ไดแสดง

คุณลักษณะจริงๆ โดยไมมีผลของแสงอื่นใดมาแสดงซอน ดวยการคลิกเมาสปุมขวาที่ Lamp เพื่อเลือกแสดง จากนั้นกด

คีย <Delete> แลวคลิกเมาสซายเลือก Erase selected object  
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กดคีย <Delete> แลวเลือก Erase selected object ลบแสงที่เลือกอยูนั้นออกไป 
 

จะเห็นวา Lamp นั้นถูกลบไปแลว และตอไปนี้ เราจะทดลองสราง Lamp แตละชนิดเพื่อศึกษาคุณลักษณะและ

จุดเดนของ Lamp ทั้ง 5 ชนิด ดังนี้ 
 

แสงแบบ Lamp 
Lamp ชนิดที่ 1 แสงแบบ Lamp เปนแหลงกําเนิดแสงแบบจุด ที่มีการกระจายแสงจากจุดกําเนิดแสงไปรอบ

ทิศทางดวยรัศมีความเขมแสงที่เทากัน  

ตัวอยางวัตถุแสงในลักษณะของ Lamp คือ หลอดไฟ เทียนไข หรือตะเกียง เปนตน ซึ่งความสวางของแสงจะ

ขึ้นอยูกับความเขมแสงที่จุดกําเนิด  

 http://mackmoon.com/images/3d 
 

เราสามารถสรางแสงชนิดนี้ไดโดยใชคําส่ัง Add>Lamp>Lamp ดังตัวอยาง 

  1. กดคีย <Space Bar> แลวเลือกคําส่ัง Add>Lamp>Lamp 

  2. เมื่อ Lamp ปรากฏบนวิวพอรต เราจะเลื่อน Lamp ออกมาวางในตําแหนงอื่นที่ไมซอนทับอยูบน

วัตถุ เชน เล่ือนขึ้นมาดานบนและลาก Lamp ใหเล่ือนไปทางขวาของวัตถุเล็กนอยดวยเครื่องมือ Transformation 

  3. จากนั้นทดลองเรนเดอรโดยกดคีย <F12> หรือเลือกคําส่ัง Render>Render Current Frame 
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1. เลือกคําสั่ง Add>Lamp>Lamp สรางแสงในวิวพอรต 
 

 
 

2. เม่ือ Lamp ปรากฏ ใหเลื่อน Lamp ออกมาวางในตําแหนงอื่นที่ไมซอนทับอยูบนวัตถ ุ
 

 3. เรนเดอรดูผลลัพธโดยกดคีย <F12> 
 

จะพบวาแสงแบบ Lamp ที่เราสรางจะสองสวางใหกับวัตถุ ซึ่งถาวัตถุนั้นอยูใกลจุดกําเนิดแสง วัตถุก็จะมีความ

สวางมาก แตถาอยูไกลออกไป ความสวางของแสงก็จะนอยลง   
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ดังภาพตัวอยางนี้เปนการเปรียบเทียบความสวางของแสงเมื่อเทียบกับระยะหางระหวางจุดกําเนิดแสงกับวัตถุ 

จะเห็นไดชัดวา ยิ่งวัตถุอยูใกลจุดกําเนิดแสงมากเทาไหร ก็จะยิ่งสวางมากเทานั้น แตวัตถุที่อยูไกลออกไปความสวางของก็

จะลดนอยลงเปนลําดับ และวัตถุที่อยูไกลเกินรัศมีของแสงก็จะยิ่งมืดจนมองไมเห็นรายละเอียดของวัตถ ุโดยเราสามารถ

ปรับความเขมแสงใหกับ Lamp ชนิดนี้ได 
 

 
 
ใกลแหลงกําเนิดแสง ไกลแหลงกําเนิดแสง 
 

แสงแบบ Sun 
Lamp ชนิดที่ 2 แสงแบบ Sun ลักษณะแสงแบบ Sun จะมีทิศทางการสองแสงแบบแสงขนานคลายกับดวง

อาทิตย กลาวคือมีลักษณะการสองแสงเปนลําแสงที่สองทอดลงมายังวัตถุดวยความเขมแสงที่เทากัน และเงาที่ไดจะมี

ลักษณะขนานกัน 

 
www.wisarts.com/digital 

 

เราสามารถสรางแสงชนิดนี้ไดโดยใชคําส่ัง Add>Lamp>Sun ดังตัวอยาง 

1. กดคีย <Space Bar> แลวเลือกคําส่ัง Add>Lamp>Sun 

2. เมื่อ Sun ปรากฏบนวิวพอรต เราจะเลื่อน Sun ออกมาวางในตําแหนงอื่นที่ไมซอนทับอยูบนวัตถุ  

3. จากนั้นกําหนดทิศทางของการสองแสงไดโดยใชอุปกรณ Rotate ปรับตําแหนงรัศมีของการสองแสงดวยการ

หมุนเสนประยาวสีชมพู 

4. จากนั้นทดลองเรนเดอรโดยกดแปน <F12> ที่คียบอรดหรือเลือกคําส่ัง Render>Render Current Frame 
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1. เลือกคําสั่ง Add>Lamp>Sun สรางแสงในวิวพอรต 
 

 
 

2. เม่ือแสง Sun ปรากฏ ใหเลื่อนออกมาวางในตําแหนงอืน่ที่ไมซอนทับอยูบนวัตถ ุ
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3. กําหนดทศิทางการสองแสง โดยการหมุนเสนประยาวสีชมพู 
 

  3. เรนเดอรดูผลลัพธโดยกดคีย <F12> 
 

ในดังตัวอยางนี้ เราจะเปรียบที่เทียบเรื่องของทิศทางของแสงใหเห็นชัดขึ้น โดยจะทดลองเรนเดอรดูลักษณะของ

แสงในทิศทางเดิมที่เราสรางกอน โดยกดแปน <F12> ที่คียบอรด 

 กอนมีการปรับทิศทางของแสง 

แตเมื่อเราทดลองเปลี่ยนทิศทางการสองแสงดวยการใช อุปกรณ Rotate หมุนเปลี่ยนทิศทางของเสนปะใหม จะ

พบวาลักษณะการสองแสงจะเปลี่ยนไปตามทิศทางของเสนปะที่เลือก เมื่อเรนเดอรดูผลลัพธจะเปนดังนี้ 
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 หลังการปรับทิศทางของแสง 
 
จุดเดนอีกอยางหนึ่งของแสงแบบ Sun นี้ จะมีลักษณะการสองแสงที่ไมเปล่ียนไปจากเดิม แมวาจะมีการเปลี่ยน

ตําแหนงของแหลงกําเนิดแสงก็ตาม เชน เราจะทดลองเลื่อนตําแหนง Lamp ชนิดนี้ใหม 

 
กอนปรับทิศทางแสง 
 

 
หลังการตําแหนงของแหลงกําเนิดแสง 
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เมื่อทดลองเรนเดอรดูผลลัพธโดยการกดแปน <F12> ที่คียบอรด จะพบวาความสวางของแสงจะคงที่เสมอ ไมวา

วัตถุจะอยูใกลหรือไกลจากแหลงกําเนิดแสง หรือผิดไปจากตําแหนงเดิม และการทอดเงาของวัตถุจะไมมีการเปลี่ยนแปลง 

 

 
แสงแบบ Spot 

Lamp ชนิดที่ 3 แสงแบบ Spot ลักษณะแสงแบบ Spot จะมีจุดกําเนิดแสงที่แคบ และเมื่อสองไกลออกไปจะมี

ลําแสงที่กวางขึ้นเรื่อยๆ คลายรูปกรวย ตัวอยางวัตถุแสงในลักษณะของ Spot ไดแก สปอตไลท ไฟฉาย หรือไฟหนารถยนต 

เปนตน  

 
 
  เราสามารถสรางแสงชนิดนี้ไดโดยใชคําส่ัง Add>Lamp>Spot  

 

 
เลือกคําสั่ง Add>Lamp>Spot  สรางแสงในววิพอรต 
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แสง Spot จะแสดงบนววิพอรต 
 

หลังจากสรางแสงแลว เราสามารถปรับมุมของการสองแสงใหกวางหรือแคบลงได และปรับทิศทางการสองแสง

ดวยอุปกรณ Rotate ไดเชนกัน 

 
ใชอุปกรณ Rotate มาปรับทิศทางของแสง 
 

แสงแบบ Area 
Lamp ชนิดที่ 4 แสงแบบ Area ลักษณะแสงแบบ Area จะมีจุดกําเนิดเปนรูปส่ีเหลี่ยม ทําใหลักษณะของการ

สองแสงจะเปนลําแสงสี่เหลี่ยมดวย เหมาะสําหรับสรางเปนแสงที่สองลงมาและมีขอบเขตหรือพื้นที่ๆ ตายตัว เชน แสงไฟที่

สองบนโตะสนุกเกอร แสงที่สองลอดหนาตางเขามากระทบพื้น ลักษณะของแสงจะเปนรูปส่ีเหลี่ยมอยูบนพื้นที่แสงตก

กระทบ เปนตน 
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 ผลงานจาก www.thai3dviz.com (nd_rut@yahoo.com) 
 

เราสามารถสรางแสงชนิดนี้ไดโดยใชคําส่ัง Add>Lamp>Area 

 

 
เลือกคําสั่ง Add>Lamp>Area  สรางแสงในววิพอรต 
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แสง Area จะแสดงบนวิวพอรต 
 

นอกจากนั้น เราสามารถปรับทิศทางของแสงดวยอุปกรณ Rotate ใหมีมุมในการสองแสงได 

 
 
ใชอุปกรณ Rotate มาปรับทิศทางของแสง 
 

แสงแบบ Hemi 
Lamp ชนิดที่ 5 แสงแบบ Hemi ลักษณะแสงแบบ Hemi จะมีทิศทางการสองแสงแบบแสงขนานคลายกับแสง

แบบ Sun แตส่ิงที่แสงแบบ Hemi ตางไปจากแสงแบบ Sun ก็คือแสงแบบ Hemi ไมสามารถกําหนดใหมีเงาไดนั่นเอง จึง

นิยมนําแสงแบบ Hemi นี้ไปใชในการสรางแสงของบรรยากาศโดยรวม เพื่อสรางความสวางในฉากใหเหมือนกับแสงรอบๆ 

วัตถุในความเปนจริง 
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เราสามารถสรางแสงชนิดนี้ไดโดยใชคําส่ัง Add>Lamp>Hemi 

 
เลือกคําสั่ง Add>Lamp>Hemi  สรางแสงในวิวพอรต 
 

 
แสง Spot จะแสดงบนววิพอรต 
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เราสามารถกําหนดทิศทางของการสองแสงไดดวยใชอุปกรณ Rotate เพื่อเปล่ียนทิศทางการสองแสงใหม  แต

จะไมมีการเปลี่ยนแปลงความเขมแสงเมื่อมีการเปลี่ยนตําแหนงของแหลงกําเนิดแสงแตอยางใด  

 
ใชอุปกรณ Rotate มาปรับทิศทางของแสง 
 

 
กอนปรับ       หลังปรับ 
 

ปรับแตงรายละเอียดของแสง 
เราสามารถปรับแตง เปล่ียนแปลงแสดงชนิดตางๆ ใหเหมาะสมกับงานของเรามากขึ้นได โดยการเขาสูการ

ปรับแตงแสงนั้น ใหเราลิกเมาสปุมซายที่ปุม   Shading หรือกดแปน <F5> ที่คียบอรด จากนั้นอุปกรณและคําส่ังตางๆ 

ในการปรับแตงแสงจะปรากฏขึ้นที่หนาตาง Buttons Window 

 
เขาสูการปรับแตงแสง โดยเลือกที่ปุม Shading 

 

Page 201



เปล่ียนชนิดของแสง 
นอกจากการกําหนดแสงดวยวิธีการสราง Lamp ดังกลาวแลว เรายังสามารถเปลี่ยนชนิดของแสงใหมไดตาม

ตองการ โดยขณะที่ทํางานกับโหมด Shading ใหคลิกเปลี่ยนชนิดของแสงที่หัวขอ Preview ใน Buttons Window ซึ่ง

จะมีชนิดของแสงทั้ง 5 ใหเลือก ในที่นี้จะทดลองเปลี่ยนจากแสงแบบ Hemi เปน Sun โดยคลิกเมาสปุมซายเลือก Sun 

สังเกตวา Lamp ในวิวพอรตจะเปลี่ยนเปนแสงแบบ Sun ทันที 

 

 
แสงในวิวพอรตเดิมเปน Hemi 
 

 

 
เม่ือเราคลิกปุม  รูปแบบแสงจะเปลี่ยนเปน Sun ทนัท ี
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ปรับสี ความสวาง เงาใหกับแสง 
เราสามารถปรับคุณสมบัติของแสงแตละชนิดเพิ่มเติมไดที่โหมด Shading ในหนาตาง Buttons Window เชน 

ปรับคาของความสวาง สีของแสง สรางเงาที่เกิดจากการตกกระทบของแสงบนวัตถุ กําหนด Texture หรือลวดลายใหกับ

แสง และคุณสมบัติอื่นๆ ที่เปนคุณสมบัติเฉพาะของแสงชนิดนั้นๆ ดังนี้ 

 
 

ปรับรายละเอียดของแสงในหัวขอ Lamp 
  Lamp จะใชปรับคาหลักเกี่ยวกับแสง เชน  ความเขมแสง ระยะการสองแสง 

สีของแสง เปนตน  
 

   
ในที่นี้เราจะทดลองปรับคาแสงแบบ Lamp โดยเลือกสวนของ Lamp แลว

คลิกเมาสปุมซายที่ชอง   จะเปนการเปลี่ยนชื่อของแสงที่เราสราง จากนั้นพิมพชื่อของแสงที่ตองการลง

ไป ดังตัวอยางเราพิมพชื่อวา LampTest แลวกดแปน <Enter> 
 

 
 

• ถาคลิกปุม Distant   จะเปนการกําหนดคาของระยะการสองสวางของแสง วาตองการ

ใหแสงสองในระยะไกลที่สุดไดเทาไหร 

• ถาปรับคาที่ปุม Energy   จะเปนการกําหนดคาความเขมแสง ถามีคามากแสงก็

จะสวางมาก ถามีคานอยแสงก็จะสวางนอย  

• สวนชองของสี จะเปนการกําหนดสีของแสง โดยเมื่อเราคลิกเมาสซายเลือก

ชองสี เราก็จะสามารถเลือกใหแสงเปนสีตางๆ ได หรือสามารถเลือกเปลี่ยนสี

ไดในชอง R G B เพื่อผสมแสงสีใหมไดเชนกัน  
 

สรางและปรับเงาในหัวขอ Shadow and Spot  
Shadow and Spot จะใชสรางเงาของแสง ปรับความเขาและทิศทางของ

เงา  
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• ถาเราคลิกเมาสซายที่ปุม Ray Shadow  จะเปนการสรางเงาที่เกิดจากการสองแสงไปยังวัตถุ คลิกอีก

ครั้งจะเปนการยกเลิกการสรางเงาแบบ Raytrace 

 
เลือกใชเงาแบบ Ray Shadow     ยกเลิกการใชเงาแบบ Ray Shadow 
 

• ถาเราคลิกเมาสซายที่ปุม Only Shadow  จะเปนการกําหนดใหวัตถุมีเงามืด 

 
เลือกใชเงาแบบ Only Shadow    ยกเลิกการใชเงาแบบ Only Shadow 
 

สรางลวดลายในหัวขอ Texture and Input  
Texture and Input ใชสรางลวดลายใหกับแสง  
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ในตัวอยางเราจะสรางลวดลายใหกับแสงที่สองมายังวัตถุ ดังภาพ 

 
 

  1. เมื่อเลือกสวนของ Texture and Input ใหคลิกเมาสปุมซายเลือกสราง Texture ใหม  แลวคลิกเลือกปุม 

Add new   จะเปนการนําลวดลายมาเปน Texture ของแสง  

  2. เลือกลวดลายไดที่ปุม Texture Button   ที่ Header ของ Buttons Windows 

  3. จากนั้นคลิกเลือก Texture Type แลวเลือกลวดลายของแสงไดตามตองการ 

  4. จากนั้น กลับไปที่แท็ปสวนของ Texture and Input อีกครั้ง โดยคลิกปุม Lamp Button    

  5. เลือกแท็ป Map to จะเปนการเลือกสีใหกับลวดลายของแสง 

  6. คลิกเลือกที่ Blending Mode ให โปรแกรมผสมแสงสีระหวางสีของ Texture และสีของแสงเดิม โดยมี

รูปแบบการผสมสีใหเลือกตามความตองการ 

 
 

1. คลิกเมาสปุมซายเลือกสราง Texture โดยคลิกทีปุ่ม Add New 
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3. เลือกสรางลวดลายไดที่ปุม Texture Button 
 

 
 
4. เลือก Texture Type แลวเลือกลวดลาย (ในตัวอยางเลือก Wood) 
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5. กลับไปท่ีแท็ป Texture and Input โดยคลิกปุม Lamp Button  

       6. เลือกสีใหกับลวดลายของแสงทีแ่ท็ป Map to 
 

 
 

6. คลิกเลือกท่ี Blending Mode ในตัวอยางเลอืก Difference  
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เมื่อมีการเรนเดอรจะเห็นวาวัตถุที่อยูภายใตแสงจะมีลวดลายที่เปนไปตามที่เราเลือกไว 

 
 

ลวดลายของแสงที่มีผลตอวัตถ ุ
 

การกาํหนดความสวางโดยรวมของฉาก 
โดยปกติแลวโปรแกรม Blender จะคํานวนการสองแสงไปยังวัตถุในระดับเบื้องตนเมื่อเราสรางแหลงกําเนิดแสง

ขึ้นมาในฉาก กลาวคือ โปรแกรมจะกําหนดตายตัววาวัตถุสวนใดที่ถูกแสงก็จะสวางและเห็นพื้นผิวไดชัด สวนที่ลําแสงสอง

ไมถึงก็จะเปนเงามืดสนิทนั่นเอง ซึ่งการกําหนดแสงแบบนี้จะเปนขั้นพื้นฐาน และไมสมจริงเหมือนธรรมชาติมากนัก 

 
 

การเรนเดอรแบบปกติจากโปรแกรม Blender 
 
แตถาหากเราตองการฉากที่มีการสองสวางดูสมจริงเหมือนธรรมชาติมากขึ้น เราจะตองกําหนดการสองสวางรวม

ของฉาก หรือ Global Illumination ใหกับฉากที่เราทํางานอยูดวย และเมื่อมีการเรนเดอรโดยกําหนด Global 

Illumination ใหกับฉาก โปรแกรมจะคํานวนการสองแสงที่จําลองมาจากสภาพจริงตามธรรมชาต ิโดยใชหลักการคํานวน

ของโปรแกรม เชน การสะทอนแสงของพื้นผิววัตถุหนึ่งไปยังวัตถุอื่นๆ ซึ่งทําใหวัตถุในฉากนั้นไดรับแสงจากทั้งทางตรงคือ 

แหลงกําเนิดแสงจําพวกหลอดไฟชนิดตางๆ และขณะเดียวกันก็ไดรับแสงจากแหลงกําเนิดแสงทางออม (Indirect 

Illumination) ซึ่งไดมาจากการสะทอนของวัตถุอื่นๆ ทําใหสวนที่ไมโดนแสงโดยตรงนั้นไมมืดสนิท แตมีการรับแสง

สะทอนและดูดกลืนแสงตามสูตรการคํานวนของโปรแกรม 
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 การเรนเดอรดวยวธิี Global Illumination 
 

สําหรับการการกําหนด Global Illumination ในโปรแกรม blender นั้น วิธีที่นิยมใชกันก็คือการใชเครื่องมือ

เรนเดอรที่มีชื่อวา Yafray (Yet Another Free Raytracer) หมายถึงโปรแกรมคํานวนแสงที่สามารถนํามาใชไดฟรี

นั่นเอง 

ในการใชงาน Yafray นั้น ผูใช ตองดาวนโหลดโปรแกรม Yafray มาติดตั้งเพิ่มเติมเสียกอน สามารถดาวนโหลด

ไดจากเว็บไซต www.yafray.org และเมื่อดาวนโหลดแลวใหทําการติดตั้งไฟลที่ไดมา แนะนําวาใหติดตั้งโดยใชคาตางๆที่

โปรแกรมตั้งให 

 
ดาวนโหลดโปรแกรมไดที ่www.yafray.org 
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เมื่อติดตั้งเสร็จเรียบรอยแลว Yafray จะเขาไปอยูในโปรแกรม Blender และเรียกใชผาน Blender ไดทันที 

ดังที่กลาวไปแลววาการกําหนด Global Illumination ใหกับฉากนั้น เปนการเรนเดอรที่คํานวณจากแสงในฉาก 

ซึ่งในจํานวนแสงไฟทั้ง 6 ชนิดของ Blender นั้น Yafray จะทํางานไดดีกับไฟ 4 ประเภทเทานั้น คือ Lamp, area, spot 

และ sun สวน Hemi และ Photon นั้น Yafray จะไมรองรับการทํางาน ดั้งนั้นควรหาชนิดไฟที่ใกลเคียงใชแทน 
 

เขาสูการกําหนด Global Illumination ดวย Yafray 

เราจะมาดูหนาตางการใชงานของ Yafray ซึ่งอยูในสวนของเรนเดอรโดยใหกดปุม   หรือกดคีย <F10> เรียก

หนาตางเรนเดอรขึ้นมา 

  โดยคาตั้งตนของโปรแกรม Blender จะใชเครื่องมือเราเรนเดอรภายในที่เรียกวา “Blender 

Internal” ซึ่งเราจะลองกดปุมเราเดอรเพื่อดูผล 

 
 

 
 
 
จากภาพจะเห็นไดวาแสงสวางในภาพจะมีสวนมืดและสวางที่ตัดกันชัดเจน ดังที่กลาวไวขางตนวาโปรแกรม 3 

มิติทั่วไปจะคํานวนแสงเพียงครั้งเดียว ซึ่งคราวนี้ เราจะกําหนด Global Illumination ดวยการเลือก Yafray ในชอง

เดียวกับที่เราเลือก  Blender Internal จากนั้นจะมีแถบเพิ่มขึ้นมาอีก 2 แถบคือ Yafray และ Yafray GI 

กําหนดการเรนเดอรแบบปกติจาก
การเลือกคา Blender Internal 
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รายละเอียดของการทํา Global Illumination ดวย Yafray   

เมื่อเราเลือกการเรนเดอรเปน Yafray แลว จะมีแท็ปสําหรับปรับแตงรายละเอียดของการทํา Global 

Illumination ขึ้นมา ดังนี้ 

แท็ป Yafray   

ในสวนของแท็ป Yafray จะเปนการกําหนดคาตัวเลือกในการใช Yafray 

เชนความลึกของแสง คาความสวาง ซึ่งแนะนําวาคาตั้งตนเปนคาที่เหมาะสมกับงาน

ทั่วไปอยูแลว  
 
 
สวนตัวเลือก XML นั้นคาตั้งตนจะเปนการเลือกใชความสามารถของไฟลชนิด XML โดยเวลาเรนเดอรนั้น

โปรแกรมจะสงคาไฟลไปคํานวนจนเสร็จแลวจึงแสดงผลในหนาตางเรนเดอรทีเดียว ซึ่งถาหากไมเลือกใชคานี้ เวลา

เรนเดอรจะเห็นขั้นตอนการเรนเดอรคอยๆ ปรากฎภาพเหมือนกับการเรนเดอรตั้งตนของโปรแกรม ซึ่งการไมเลือกใช XML 

จะชวยใหเราทราบวาเรนเดอรไปถึงเฟรมที่เทาไหร และถามีการใชทรัพยาการเครื่องมากๆ ก็จะชวยใหทราบวาขณะนั้น

เครื่องแฮงคอยูหรือไม 
 
 
 
 
 
 
 

เม่ือเลือก Yafray จะมีแท็ป Yafray 
และ Yafray GI ปรากฏเพิ่มขึ้นมา 
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แท็ป Yafray GI 
ตอไปเราจะมาดูในแถบของ Yafray GI ซึ่งจะเปนแถบที่ใชในการกําหนด

วิธีการกําหนด Global Illumination ของ Yafray คาตัวเลือกหลักที่เราตองกําหนดคือ   

  Method จะเปนการเลือกวิธีการทํา Global IIlumination ซึ่งไดแก Skydome และ Full  

  Quality คือความละเอียดในการคํานวน ซึ่งจะสงผลตอคุณภาพของผลลัพธ 
 

การปรับแตงรายละเอียดของการทํา Global Illumination ดวย Yafray  
การปรับแตง Global Illumination นี้ จะเปนการใชตัวเลือกจากแท็ปการทํางานของ Yafray GI เขามาชวยใน

การเรนเดอร ซึ่งม ี2 แบบที่นาสนใจ ดังนี้  
ทํา Global Illumination โดยใช Skydome 

  เราจะลองเลือกวิธ ีSkydome กันกอน ซึ่งเปนวิธีการสราง Global Illumination อยางงายๆ โดย

โปรแกรมจะจําลองสภาพบรรยากาศแสงที่สองมาจากทองฟา วิธนีี้อาจจะไมใชการกําหนด Global Illumination อยาง

สมบูรณแบบ แตนับวาเปนวิธีที่สรางผลลัพธไดอยางนาพอใจในเวลาอันรวดเร็ว เหมาะกับงานที่ตองการสภาพแสงสมจริง 

(โดยเฉพาะฉากกลางแจง) แตตองการประหยัดเวลา 

 
 
จากภาพใหเราทดลองคลิกเลือกคุณภาพระดับ Low สวนปุม Cache นั้นสามารถกดเลือกใชเพื่อกําหนดคุณภาพ

ในสวนยอย เชน แสง เงา ลวดลายพื้นผิว เพื่อจํากัดการใชหนวยความจํา ซึ่งจะใหการเรนเดอรเร็วขึ้น แลวกดคีย <F12> 

เพื่อดูผลลัพธ จะเห็นไดวาแสงและเงาเริ่มมีรายละเอียดที่ดีมากขึ้นจากเดิม 
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 หลังการเรนเดอรดวยวิธีเลือก Skydome 
 

ทํา Global Illumination โดยใช Skydome 
ตอไปจะมากําหนด Method แบบ Full ซึ่งจะเปนการกําหนด Global Illumination อยางสมบูรณ ซึ่งจะได

ผลลัพธที่ดีกวาแบบ Skydome เมื่อเลือกแบบ Full แลว จะมีตัวเลือกใหกําหนดเพิ่มขึ้น ดังนี้ 

 
Depth จะเปนจํานวนการสะทอนของลําแสงตอการฉายแสงครั้งหนึ่ง ซึ่งถากําหนดคามากการคํานวนตอครั้งก็

ละเอียดมากขึ้น คาที่เหมาะสมกับงานทั่วไปไดแก 3 

Cdepth คือคา Caustics Depth ซึ่งเปนความละเอียดการคํานวนการสะทอนที่มีตอวัตถุโปรงแสงเชนแกว 

อัญมน ีหรือของเหลว คาที่ใชไดทั่วไปอยูในชวง 3‐5 

Photon เปนอนุภาคที่ชวยในการกําหนด Global Illumination นุมนวลขึ้น ซึ่งไมมีความเกี่ยวของกับแสงชนิด 

Photon ของ Blender แตอยางใด หากเลือก Photon แลวจะมีตัวเลือกเพิ่มขึ้นมาไดแก 

  Count ไดแกจํานวนอนุภาค photon ที่จะใชในฉาก 

  Radius ไดแกรัศมีของการคนหา photon เพื่อใชในการกําหนดความฟุงเบลอ หรือความนุมนวลของ

แสง  

  Mixcount ไดแกจํานวน Photon ที่ตองการใชในระยะรัศมีนั่นเอง  

ซึ่งเมื่อเรากําหนด Radius และ Mixcount จะเปนการสราง Photon‐map หรือพื้นที่ๆ Yafray จะคํานวนการ

ใช Photon โดย Photon ภายใตพื้นที่จะถูกใช และ Photon นอกพื้นที่ก็จะไมนํามาคํานวนเพื่อเปนการประหยัด

หนวยความจํานั่นเอง  

และเมื่อกดคีย <F12> ดูผลลัพธ ก็จะเห็นวาแสงใน

ฉากมีความนุมนวลขึ้นอีกระดับ ซึ่งงานที่มีองคประกอบมากก็

จะยิ่งเห็นผลลัพธไดชัดเจนมากขึ้น  
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การจัดแสงเบื้องตนจากไฟ 3 ดวง 
สําหรับหัวขอนี้ เราจะมารูจักกับการกําหนดตําแหนงของแสงพื้นฐานที่นิยมใชกันในการจัดแสงใหกับวัตถุทั่วไป 

ซึ่งจะเรียกวา "Three Point Lights" หรือ "การกําหนดตําแหนงของไฟสามดวงใหกับช้ินงาน" โดยมีแสงที่จําเปนสําหรับ

การจัดแสงลักษณะนี้อยู 3 แบบ คือ  Key Light, Fill Light และ Back Light โดยจะกลาวถึงแสงแบบแรกกอน นั่นคือ 
Key Light 

 
   Fill Light  Key Light 

 

 
 

   Camera                   Back  Light 
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Key Light 
เปนแสงหลักที่ใชสองวัตถุ โดยเปนแสงที่มีความเขมมากที่สุด และตองกําหนดเงาที่เกิดจากแสง Key Light 

ใหกับวัตถุดวย ในตัวอยางเปนการจัดวางแสง Key Light ซึ่งเราจะอางอิงการจัดแสงจากตําแหนงของกลองที่วางอยู

ดานหนาวัตถุ โดยจะตองวาง Key Light ใหอยูเยื้องไปทางดานขางซายหรือขวาของแนวนอน และทางดานบนหรือ

ดานลางของแนวตั้ง ทํามุมกับกลอง 15‐45 องศา   

 
แสง Key Light วางทํามุมกับกลองเยื้องไปทางดานบนซาย Key Light วางทาํมุมกับกลอง ทํามุมประมาณ 15-45 องศา 
 

ในภาพดานซาย จะแสดงการจัดแสงในมุมมองแบบ Perspective จะเห็นวาแสง Key Light วางทํามุมกับกลอง

เยื้องไปทางดานบนซาย และในภาพดานขวา จะแสดงการจัดแสงในมุมมอง Top View จะเห็นวาแสง Key Light วางทํา

มุมกับกลองเยื้องไปทางซายทํามุมประมาณ 15‐45 องศา  

โดยการจัดแสง Key Light นั้น เราจะสามารถจัดใหอยูทางซายหรือขวาของกลองหรือวัตถุก็ได แตจะตองเยื้อง

มาทางดานหนาของวัตถุดังภาพดานซายในมุมมอง Top View  
 

Fill Light 
ทําหนาที่เติมแสงใหกับวัตถุเพื่อลบเงามืดที่เกิดจากการสองแสงของ Key Light ใหหายไป โดยเราจะกําหนดเงา

ใหกับ Fill Light หรือไมก็ได แตตองกําหนดใหความเขมของเงานั้นนอยกวาความเขมเงาของ Key Light เสมอ และความ

เขมแสงของ Fill Light จะตองนอยกวาความเขมแสงของ Key Light ดวยเชนกัน  

โดยการกําหนดตําแหนงของ Fill Light นั้น เราจะตองวางไวดานหนาของวัตถุเสมอ และตองอยูในฝงตรงขางกับ 

Key Light ดวย ทั้งนี้เพื่อเติมแสงในสวนที่เปนเงามืดของวัตถุใหสวางขึ้น ซึ่งเปนการลบเงามืดใหหายไปดังที่กลาวมาแลว  

 
Fill Light จะวางตรงกันขามกับ Key Light ในดานหนาของวัตถ ุ
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Back Light 
ซึ่งเราสามารถเรียกไดอีกอยางวา "Rim Light" สําหรับ Back Light นั้น จะทําหนาที่สองสวางจากทางดานหลัง

ของวัตถุ เพื่อจะแยกวัตถุออกจากฉากหลัง ทําใหวัตถุดูเดนขึ้น ทั้งนี้เนื่องมาจากแสง Back Light จะเขามาชวยสรางใหมี

การเรืองแสงบริเวณขอบของวัตถ ุทําใหเกิดการตัดกันของแสง ชวยแยกใหวัตถุเดนชัดขึ้น 

โดยการกําหนดตําแหนงของ Back Light จะตองวางอยูตรงดานหลังของวัตถุ และใหความสูงของระดับแสง

เหมาะสมกับการแสดงวัตถุ โดยดูจากบริเวณขอบของวัตถุวา ปรากฏเดนชัดขึ้นและแยกออกจากฉากหลังหรือไม  

นอกจากนั้น เราจะตองกําหนดใหความสวางของแสง Back Light นอยกวาแสง Key Light และ Fill Light 

เสมอ และจําเปนตองกําหนดเงาใหกับ Back Light ดวย 
 

Back Light จะวางดานหลังวตัถ ุ

 
 

ดังนั้นจุดสําคัญของการจัดแสงแบบ Three Point Lights จะตองกําหนดให Key Light เปนแสงหลักที่มีความ

สวางมากที่สุด ในขณะที ่Fill Light จะมีความสวางรองลง เพื่อเติมแสงใหกับวัตถุในทิศทางตรงกันขามกับ Key Light 

และสุดทาย Back Light จะทําหนาที่เปนแสงสวางที่สองมาจากดานหลังของวัตถุ เพื่อตัดขอบของวัตถุกับฉากหลัง และ

กําหนดใหเปนแสงที่มีความสวางนอยที่สุด    
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บทที่ 10 
ทํางานกับกลอง 

 
ในหัวขอนี้ เราจะมาทําความรูจักกับกลองหรือ Camera องคประกอบสําคัญอีกองคประกอบหนึ่งในการสราง

งาน 3 มิติดวยโปรแกรม Blender ซึ่งกลองจะทําหนาที่ถายทอดภาพในมุมมองที่เราตองการ เหมือนกับการมองภาพผาน

เลนสของกลองปกติทั่วไป 
 

รูจักกับกลองในโปรแกรม Blender 
เมื่อเราเปดโปรแกรม Blender เขามา เราจะพบกับกลอง 1 ตัว ปรากฏอยูบนวิวพอรต ซึ่งใชกําหนดมุมมอง

สําหรับการเรนเดอร เนื่องจากโปรแกรม Blender นั้น จะไมสามารถแสดงผลการเรนเดอรในมุมมองอื่นๆ ไดนอกจาก

มุมมองของกลองเทานั้น กลาวคือ ในชิ้นงานที่เรากําลังทํางานอยู ไมวาจะทํางานอยูกับมุมมองใดก็ตาม ทุกครั้งที่มีการ

เรนเดอร โปรแกรมจะเรนเดอรจากมุมมองของกลองเสมอ  

   
มุมมอง Perspective        มุมมองจากกลอง 
 
สรางกลองสําหรับแสดงผลงาน 

ในตัวอยางตอไปนี ้เราจะมาเรียนรูจักวิธีการกําหนดมุมมองของกลอง ซึ่งเราจะเลือกเปดไฟลตัวอยางขึ้นมา โดย

คลิกเลือกเมนู File>Open แลวคลิกเมาสกลางเลือกไฟลตัวอยาง  

 เปดไฟลทีต่องการสรางกลองขึ้นมา 
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จากนั้นจะปรากฏวัตถุขึ้นมาบนวิวพอรต ซึ่งมุมมองที่

เรากําลังทํางานอยูนี้เปนมุมมองแบบ Top View ใหเราทดลอง

เรนเดอรโดยการกดแปน <F12> ที่คียบอรด 

หลังจากเรนเดอรจะปรากฏวา โปรแกรมจะแสดง

มุมมองอื่นที่ไมเหมือนกับมุมมอง Top ซึ่งมุมมองนี้คือมุมมอง

ของกลองนั่นเอง 
 
 
 
 

ปรับมุมมองของกลองใหสัมพันธกับวิวพอรต 
ถาเราตองการมองวัตถุในมุมมองของกลองจากวิวพอรตบาง ใหเรากดคียเลข <0> ที่ Num Pad หรือคลิกเมาส

ปุมซายเลือก View>Camera มุมมองในวิวพอรตเดิมก็จะเปลี่ยนเปนมุมมองของกลองทันที และใหสังเกตวาจะมีกรอบ

ส่ีเหลี่ยมปรากฏขึ้นมาบนวิวพอรตดวย นั่นคือขอบเขตในการมองเห็นผานมุมมองของกลอง 

 มุมมองจากกลอง (Camera) 
 

ในขณะที่เราทํางานกับมุมมองอื่นๆ อยู (ที่ไมใชมุมมองของกลอง) แตตองการใชมุมมองนั้นเปนมุมมองของกลอง

แทน เชน ทํางานอยูในมุมมอง Perspective และตองการใหมุมมองนั้นเปนมุมมองของกลองเพื่อใชสําหรับการเรนเดอร

แทน เราสามารถทําไดโดยใหกดคีย <Ctrl+Alt+เลข 0 ที่ Num Pad> 

 
มุมมองที่ตองการสรางใหเปนมุมมองของกลอง  หลังจากกดคีย <Ctrl+Alt+เลข 0 ที่ Num Pad> 
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และเมื่อเราทดลองเรนเดอร ก็จะพบวามุมมอง Perspective 

เดิม ไดกลายเปนมุมมองของกลองไปเรียบรอย   
 
 
 
 
 
 

การควบคุมกลอง 
นอกจากมุมมองของกลองปกติแลว เรายังสามารถปรับหรือควบคุมกลองใหแสดงมุมมองอื่นๆ ได โดยใชกลุม

อุปกรณ Transform ควบคุมกลอง  

ในตัวอยาง เราจะทดลองปรับกลองพรอมกับแสดงมุมมองของกลองไปพรอมกัน โดยจะแบงวิวพอรตออกเปน 2 

หนาจอกอน โดยใชคําส่ัง Split Area แลวตั้งคาใหหนาตางดานซายเปนมุมมอง Perspective และใหหนาจอดานขวา

เปนมุมมองจากกลอง เพื่อใหเราสามารถมองเห็นความเปลี่ยนแปลงไดชัดเจน เมื่อมีการเปลี่ยนมุมมอง ดังนี้ 

 
แบงจอภาพออกเปน 2 จอภาพยอยกอน จากนั้นปรับใหจอภาพดานซายเปน Perspective  
และปรบใหจอภาพดายขวาเปน Camera 
 

ปรับมุมมองของกลองจากเครื่องมือ Transformation 
ในสวนนี้เราจะใชกลุมเครื่องมือ Transformation เขามาปรับตัวกลอง ดังตัวอยางเราจะทดลองเปลี่ยนตําแหนง

กลองดวยอุปกรณ Translate และหมุนมุมกลองดวยอุปกรณ Rotate ใหสังเกตวาหนาจอทางขวาจะมีการเปลี่ยนแปลง

ตามหนากลองที่เราปรับ 
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เม่ือทดลองยายกลองในมุมมอง Perspective เราจะเห็นมุมมองที่เปลี่ยนไปในมุมมอง Camera 
 

 
เม่ือทดลองหมุนกลองในมุมมอง Perspective เราจะเห็นมุมมองที่เปลี่ยนไปในมุมมอง Camera 

 

ปรับมุมมองของกลองจากเครื่องมือ Transformation 
ที่ผานมาเปนการควบคุมตัวกลองใหจับภาพวัตถุที่หยุดนิ่งกับที่ แตในทางกลับกัน ถาเราเล่ือนตําแหนงวัตถุหรือ

กระทําการใดๆ กับวัตถุใหมีการเคลื่อนที่ กลองนั้นจะไมสามารถหันไปจับภาพตามวัตถุไดตลอด ดังตัวอยาง ถาเราคลิก

เมาสปุมขวาเลือกวัตถุ แลวกดแปน <G> ที่คียบอรด จากนั้นเลื่อนตําแหนงวัตถุไปมา สังเกตวามุมกลองในหนาจอขวาจะ

ไมเล่ือนจับภาพตามวัตถุ 
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แมวามีการเลือกวัตถ ุแตกลองจะไมจับภาพตาม สังเกตจากมุมมองกลองดานซาย 

 

ซึ่งถาเราตองการใหกลองจับภาพวัตถุนั้นตลอดเวลา ไมวาวัตถุนั้นจะเคลื่อนที่ไปยังตําแหนงใด เราสามารถทําได

โดยกําหนดใหมุมมองของกลองติดตามการเคลื่อนที่ของวัตถุ โดยสามารถทําไดดังนี้ 

1. ใหคลิกเมาสขวาเลือกกลองกอน แลวกดคีย <Shift> คางไว คลิกเมาสขวาเลือกที่วัตถุ  

2. เลือกคําส่ัง Object>Track>Make Track (หรือกดคีย <Ctrl+T>) แลวคลิกเลือก Track to Constraint ก็

จะเปนการสรางใหกลองติดตามการเคลื่อนที่ของวัตถุไปตลอด  

สังเกตวาจะมีเสนปะเชื่อมระหวางกลองและวัตถุ เราจะทดลองโดยคลิกเลือกวัตถุ แลวกดแปน <G> ที่คียบอรด 

จากนั้นลองเล่ือนวัตถุไปมา สังเกตวามุมกลองในหนาจอทางขวาจะเปลี่ยนตามการเคลื่อนที่ของวัตถุ 
 

 
1. เลือกกลองกอน แลวกดคีย <Shift> คางไว คลิกเมาสขวาเลือกที่วัตถ ุ
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2. เลือกคําสั่ง Object>Track>Make Track… 

 

 
3. เลือก Track to Constraint 
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ทดลองปรับตําแหนงวัตถ ุจะเห็นวากลองจับภาพตามวัตถุแลว 

 
สรางกลองหลายตัวเพ่ือใชควบคุมมองมองไดมากขึ้น 

ในการทํางานบางครั้งเราอาจจําเปนตองใชมุมมองกลองหลายมุมมอง ดังนั้น โปรแกรมจึงกําหนดใหเราสามารถ

สรางกลองขึ้นมาไดหลายตัว โดยคลิกเลือกคําส่ัง Add>Camera ก็จะไดกลองตัวใหมเขามาในวิวพอรต จากนั้น ก็ใหใช

กลุมอุปกรณ  Transformation ยายตําแหนงและหมุนมุมมองกลองตัวใหมใหเปนไปตามตองการได 
 

 
 
เพิ่มกลองเปน 2 ตัว ดวยคําสั่ง Add>Camera 
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ปรับกลองตัวใหมไดไดตําแหนงทีต่องการ 
 

สําหรับการเลือกใชกลองที่อยูในซีนการทํางานนี้ ถาเรามีกลองหลายตัวเราสามารถเลือกใชมุมมองของกลอง

มุมมองใดก็ได ซึ่งในตัวอยางเรามีกลองอยู 2 ตัว เราจะทดลองเลือกมุมมองกลองระหวางกลองตัวที่ 1 กับกลองตัวที ่2 

ดังนี้  

1. คลิกเมาสขวาเลือกกลองตัวที ่2 คือกลองที่เราเพิ่งสรางขึ้นมา 

2. กดแปน <Ctrl+เลข 0> ที่ Num Pad ก็จะเปนการเลือกใชมุมกลองจากกลองที่เราเลือก  

3. ทดลองกดแปน <G> ที่คียบอรดเพื่อปรับมุมกลองเขาหาวัตถุ  

และเมื่อเราไดมุมมองที่ตองการแลว ก็สามารถเรนเดอรจากมุมมองของกลองตัวที่เราเลือกนั้นไดทันที 

 
 
1. คลิกเมาสขวาเลือกกลองตัวที ่2 
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2. กดแปน <Ctrl+เลข 0> จะเปนการเลือกใชมุมกลอง 
 

 
3. ทดลองกดแปน <G> เพื่อปรับมุมกลองตัวใหม 

 
ปรับรายละเอียดใหกับกลอง 

ในการทํางานบางครั้งเราอาจจําเปนตองใชมุมมองกลองหลายมุมมอง ดังนั้น โปรแกรมจึงกําหนดใหเราสามารถ

สรางกลองขึ้นมาไดหลายตัว โดยคลิกเลือกคําส่ัง Add>Camera ก็จะไดกลองตัวใหมเขามาในวิวพอรต จากนั้น ก็ใหใช

กลุมอุปกรณ  Transformation ยายตําแหนงและหมุนมุมมองกลองตัวใหมใหเปนไปตามตองการได 

เมื่อเราสรางมุมมองกลองไดตามตองการแลว เราสามารถปรับคุณสมบัติกลองเพิ่มเติมได โดยคลิกเลือกกลองที่

ตองการกอนแลวคลิกเลือกปุม Editing   ที่ Header   ของ Buttons Window จากนั้นใหมากําหนดในแท็ปของ 

Camera ดวยตัวแปรดังนี้  
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 คาของเลนส จะเปนการกําหนดคาของทางยาวโฟกัส เพื่อกําหนดใหมุมมองของกลองเปน 

มิลลิเมตร กลาวคือปรับใหกลองนั้นมีลักษณะเปนเหมือนกลองถายวิดีโอหรือถายภาพทั่วไป ซึ่งปกติโปรแกรม Blender 

จะใชคาเลนสที่ 35 mm ซึ่งเปนคาเลนสที่นิยมใชกับกลองทั่วไป สําหรับเลนสของกลองที่ใชงานจะถูกจัดเปน 3 กลุมตาม

คาทางยาวโฟกัส ดังนี้ 

  กลุมที่ 1 คือ เลนสมาตรฐาน หรือ Standard Lens มีคาทางยาวโฟกัสที่  

50‐55 mm จะใหภาพที่ใกลเคียงกับสายตามนุษยมากที่สุด เหมาะกับมุมมองที่ตองการเนนวัตถุ งาน Modeling และ

งาน Animation 

  กลุมที่ 2 คือ เลนสมุมกวาง หรือ Wide angle lens มีคาทางยาวโฟกัสต่ํากวา 50 mm เชน 35 mm, 

20mm, 18mm เลนสมุมกวางเปนเลนสที่กําหนดใหเห็นบริเวณแวดลอมรอบวัตถุดวย เชน ในฉากมีวัตถุหลัก และจับ

ภาพใหมีวัตถุรองอื่นๆ อยูบริเวณรอบๆ  

  กลุมที่ 3 คือ เลนสถายไกล หรือ Telephoto lens มีทางยาวโฟกันมากวา 55 mm เชน 85mm, 

100mm, 135mm เลนสถายไกลเปนเลนสที่เหมาะสําหรับถายภาพระยะไกล แตตองการเนนวัตถุนั้นๆ โดยไมสนใจ

ส่ิงแวดลอมอื่น 
 
Clipping จะเปนการกําหนดระยะความสามารถในการมองเห็นวัตถุของกลอง โดยคา 

Start จะเปนคาปกติจะเริ่มที่ 0 นั่นคือมองเห็นไดตั้งแตหนากลอง ไปยังคา End หรือระยะไกล

ที่สุดที่กลองสามารถมองเห็นได ซึ่งถาวัตถุนั้นอยูไกลเกินคาปกติของโปรแกรม ก็ใหเราปรับเพิ่มคาจนกระทั่งสามารถ

มองเห็นวัตถุได โดยคาที่มากที่สุดของ End คือ 5000  
 

 
ระยะการมองเห็นของกลองครอบคลุมวัตถุ   ระยะการมองเห็นของกลองที่ไมครอบคลุมวัตถุ 
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Show จะเปนการแสดงรายละเอียดที่เราเลือกตัวอยางเชน  

 ถาคลิกปุม Name จะปรากฏชื่อของกลองในวิวพอรต  

 ถาคลิก Title Safe จะปรากฏกรอบสี่เหลี่ยนลอมรอบ โดยการจัดวางวัตถุควร

จะใหอยูในกรอบ Title Safe ทั้งนี้เพื่อเปนการปองกันไมใหภาพบางสวนขาด

หายไป เมื่อนําชิ้นงานหลังการเรนเดอรไปตัดตอ  

 Passpartout เปนการไฮไลทบริเวณกรอบนอกวัตถุ โดยคาความเขม 

มาตรฐานของไฮไลทจะอยูที ่0.2 
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บทที่ 11 
สรางงานแอนิเมชั่นเบื้องตน 

 
งานแอนิเมชั่นคือขั้นตอนอีกขั้นตอนหนึ่งสําหรับการสรางความสมบูรณแบบใหกับภาพยนตรหรือการตูน

เคล่ือนไหว เนื่องจากเปนการสรางใหโมเดลที่เราเตรียมไวมีการเคลื่อนที่ ขยับได รวมถึงการสรางความตอเนื่องใหกับ

ชิ้นงาน ซึ่งในบทนี้เราจะไดเรียนรูถึงวิธีการสรางการเคลื่อนไหวใหกับโมเดลเบื้องตน เพื่อสรางความเขาใจในการทํางานกับ

เครื่องมือและหนาตาง Timeline 

 
ลักษณะของงานแอนิเมชัน่ 

การสรางแอนิเมชั่น เปนการทําใหวัตถุเคลื่อนไหวตามที่เรากําหนด โดยหลักการทํางานของโปรแกรม 3D ทั่วไป

นั้น จะเปนการนําภาพนิ่งของวัตถุที่เคลื่อนไหวมาแสดงเรียงตอกันในเวลาที่รวดเร็วเพื่อใหเกิดภาพตอเนื่องที่เคลื่อนไหว

เหมือนกับการตูนหรือภาพยนตรที่เราคุนเคย โดยภาพเหลานี้จะมาจากการเรนเดอรชิ้นงานในซีนนั้นๆ 

เชน ถาเราสรางการเคลื่อนที่ของลูกบอลใหวิ่งจากทางซายของจอภาพไปยังทางขวา จะตองเริ่มจากภาพแรกให

เปนภาพลูกบอลที่เริ่มหมุนจากตําแหนงซายของหนาจอ ภาพที ่2 แสดงลูกบอลกําลังหมุนและเคลื่อนที่ไปขางหนาเล็กนอย 

และแสดงภาพอื่นๆ ตอกันจนกระทั่งถึงภาพสุดทายที่ลูกบอลหมุนไปอยูที่จุดส้ินสุดทางขวาของหนาจอ   
 

 
 

ตัวอยางการเคลื่อนไหวของลูกบอล 
 

สังเกตวาแตละภาพของลูกบอลมีการเปลี่ยนแปลงบางจุด แตจะตอเนื่องกัน เชน เปล่ียนตําแหนงลูกบอก เปล่ียน

การวางตัวและการทําองศากับพื้น เปนตน และถาเรานําการภาพเคลื่อนไหวเหลานี้มาแสดงเรียงตอเนื่องกัน เราก็จะไดงาน

แอนิเมชั่นชิ้นใหมขึ้นมาผานการเรนเดอร ซึ่งเปนไฟลวิดีโอสําหรับนําไปเผยแพร 

ภาพแตละภาพที่แสดงอยางตอเนื่องเพื่อใหเปนงานแอนิเมชั่นนั้น จะตองเคลื่อนที่ดวยความเร็วระดับหนึ่ง เพื่อให

การเคลื่อนไหวแสดงไดอยางราบร่ืน โดยอัตราเร็วในการแสดงวัดจากจํานวนภาพที่แสดงใน 1 วินาท ีหรือจํานวนเฟรมตอ 

1 วินาท ีซึ่งแตละภาพมาจากการเรนเดอรแอนิเมชั่นของวัตถุในแตละ 1 เฟรม  

นอกจากนั้น ความเร็วในการแสดงแอนิเมชั่นจะขึ้นอยูกับระบบของสื่อในการเผยแพร  เชน โทรทัศน คอมพิวเตอร 

หรือระบบเครือขายอินเทอรเน็ต เนื่องจากการเผยแพรชิ้นงานจําเปนตองใชส่ือจําพวกนี้ ดังนั้น การทํางานแอนิเมชั่นจึง

นิยมใชระบบโทรทัศนภายในประเทศเปนคาหลัก ซึ่งประเทศไทยจะใชความเร็วในการแสดงภาพเทากับ 25 เฟรมตอวินาที 

เปนระบบ PAL และคาความเร็วนี้ก็สามารถแสดงบนคอมพิวเตอรไดเชนกัน  
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วิวพอรตสําหรับสรางงานแอนิเมชั่น 
ในโปรแกรม Blender จะมีหนาตางหรือวิวพอรตที่ใชในการควบคุมการสรางแอนิเมชั่นที่เรียกวา “หนาตาง 

Timeline” ซึ่งเปนหนาตางหลักที่ใชในการสรางงานแอนิเมชั่น โดยตรง หนาตางนี้จะชวยใหเราเห็นจํานวนเฟรมทั้งหมด 

รวมทั้งเฟรมที่กําลังทํางาน และขอบเขตของการแสดงแอนิเมชั่นไดชัดเจน  

 
 
ตัวอยางหนาตาง Timeline 
 

วิธีการเรียกหนาตางนี้ขึ้นมาใช สามารถทําไดดังตอไปนี้ 

1. ทําการแบงวิวพอรตใหมีหนาจอใหมขึ้นมากอน โดยเราจะแบงวิวพอรตในแนวนอนดวยการคลิกเมาสขวาที่

ดานซายของวิวพอรตหลัก แลวเลือก Split Area  

2. จากนั้นเลื่อนเสนที่ไดลงมาดานลางเล็กนอยแลวใหคลิกเมาสซาย เพื่อกําหนดใหเปนหนาตาง Timeline  

3. เลือกที่ปุม   (Display Current Windows Type) แลวเลือก Timeline หนาตาง Timeline ก็จะ

ปรากฏ 
 

 
 
1. คลิกเมาสขวาที่ดานซายของวิวพอรตหลัก แลวเลือก Split Area 
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2. เลื่อนเสนที่ไดลงมาดานลางเลก็นอยแลวใหคลกิเมาสซาย 
 

 
 

3. ลือกที่ปุม  แลวเลือก Timeline 
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หนาตาง Timeline จะปรากฏ 
 

การสรางแอนิเมชั่นในโปรแกรม Blender 
เริ่มตนเราตองเขาใจกอนวาโปรแกรมสรางงาน 3D เหลานี้ มีจุดเดนอยูที่การสรางแอนิเมชั่นแบบคียเฟรม ซึ่งเปน

การสรางแอนิเมชั่นที่ใชการกําหนดความเปลี่ยนแปลงขององคประกอบและตําแหนงของวัตถุใหกับบางเฟรม เพื่อสรางให

วัตถุนั้นเคล่ือนไหวได และเฟรมดังกลาวจะจําความเปลี่ยนแปลงนั้นไว จากนั้นโปรแกรมจะใชการคํานวณทางคณิตศาสตร 

เพื่อใหแสดงการเคลื่อนไหวจากเฟรมหนึ่งไปยังอีกเฟรมหนึ่ง เราเรียกเฟรมที่จดจําการเปลี่ยนแปลงขอมูลของวัตถุนั้นวา 

"คียเฟรม" 

สําหรับตัวอยางนี้ เราจะสรางใหวัตถุกลองส่ีเหลี่ยมนี้มีการเคลื่อนที่จากซายไปขวา และคอยๆ ขยายใหญขึ้น โดย

อาศัยหลักการทําแอนิเมชั่นแบบคียเฟรม เพื่อใหเราเขาใจหลักการและวิธีการสรางแอนิเมชั่นดวยโปรแกรม Blender มาก

ขึ้น ดังนี้ 
วัตถุเคลื่อนที่จากซายไปขวา 

 
 
 
 
 
 

วัตถุกําลังหมุน 
 
 

วัตถุกําลังขยาย 
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จากตัวอยางภาพ เราจะแบงขั้นตอนการสรางงานแอนิเมชั่นชิ้นนี้ออกเปน 3 ชวง ขั้นตอน ดังนี้ 

   ขั้นตอนที ่1 กําหนดคาการแสดงแอนิเมชั่น 

   ขั้นตอนที ่2 สรางการเคลื่อนที่ของวัตถุ 

   ขั้นตอนที ่3 หมุนและขยายขนาดวัตถุ 
 

ขั้นตอนที่ 1 กําหนดคาการแสดงแอนิเมชั่น 
สําหรับขั้นตอนนี้ถือเปนขั้นตอนที่สําคัญมาก เนื่องจากเปนขั้นตอนที่เราตองวางแผนลวงหนากอนที่จะลงมือ

สรางชิ้นงาน วาเราตองการใหระยะเวลาการแสดงของเรามีความยาวเทาใด มีอัตราเร็วในการแสดงเทาใด และตองการ

นําไปใชงานกับส่ือใด เพื่อจะตั้งคางานของเราใหตรงกับส่ือสําหรับเผยแพรที่เราจะใช  

ในตัวอยางนี้ เราตองการงานแอนิเมชั่นที่สามารถนําไปเลนไดกับโทรทัศนระบบ PAL และมีความยาวการแสดง 

200 เฟรม ซึ่งสามารถตั้งคาชิ้นงานได ดังนี้ 

1. เริ่มตนจากการเขาสูการสรางแอนิเมชั่น โดยใหคลิกเมาสซายที่ปุม   (Scene)   หรือกดแปน <F10> ที่

คียบอรด  

2. จากนั้นใหเราปรับคาพารามิเตอรตางๆ เพื่อกําหนดขอบเขตการแสดงแอนิเมชั่นครั้งนี้ โดยเขาสูการกําหนด

เอาทพุตของการเคลื่อนไหว ใหคลิกที่ปุม    (Render Buttons) 

3. ปรับคาอัตราเร็วในการแสดง โดยปรับคาที่ปุมเฟรมตอวินาที   ในแท็ป Format ใหเราคลิกรูป

สามเหลี่ยมดานซายของปุมเพื่อลดจํานวนเฟรมหรือคลิกรูปสามเหลี่ยมดานขวาเพื่อเพิ่มจํานวนเฟรม (หรือคลิกเมาสปุม

ซายบริเวณตรงกลางปุมแลวพิมพจํานวนเฟรมที่ตองการเขาไป) แตจากโจทยที่กําหนด เราตองการงานที่นําไปใชไดกับ

ระบบ PAL ดังนั้นจึงเลือกตั้งคาสําเร็จรูปใหเปนระบบ PAL โดยคลิกที่ปุม   คาทุกอยางก็จะถูกเปลี่ยนใหอัตโนมัติ

ตามมาตรฐานของระบบ PAL 

4. กําหนดความยาวหรือขอบเขตในการแสดงแอนิเมชั่นครั้งนี้ สําหรับตัวอยางเราตองการใหมีการแสดงการ

เคล่ือนไหวทั้งหมด 200 เฟรม จึงกําหนดคาที่ Start และ End ในแท็ป Anim โดยใหคา Start เทากับ 1 นั่นคือใหเริ่ม

แสดงตั้งแตเฟรมแรกของซีน และกําหนดคา End เทากับ 200 เพื่อใหความยาวของการแสดงเทากับ 200 และจบที่เฟรมที่ 
200   

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Page 232



1. คลิกซาย    2. คลิกซาย 
 

 
3. พิมพคาอัตราเร็วในการแสดง (ในตวัอยางใหคาอัตราเร็วตามระบบ PAL 
 

 
 

4. กําหนดขอบเขตของการแสดงแอนิเมชั่น (ในตวัอยางเริ่มตนที ่1 และสิ้นสุดที่เฟรม 200) 
 

ขั้นตอนที่ 2 สรางการเคลื่อนที่ของวัตถุ 
ในขั้นตอนนี ้เราตองกําหนดคียเฟรมแรกใหกับการแอนิเมชั่นของเรา เพื่อระบุเฟรมตั้งตนกอนการเคลื่อนที่ 

จากนั้นกําหนดคียเฟรมถัดมาเพื่อสรางใหวัตถุเคลื่อนที่จากทางซายไปขวาของววิพอรต โดยกําหนดใหการเคล่ือนที่นี้แสดง

ทั้งหมด 100 เฟรม 

1. เริ่มตนเราตองกําหนดใหเฟรมที ่1 เปนเฟรมแรกที่จะเริ่มใหมีการเคลื่อนที่กอน ใหพิมพเลข 1 ในชองกําหนด

เฟรม  (Display Current Frame) เพื่อเขาสูการทํางานกับเฟรมที่ 1 (ในที่นี้เปนเลข 1 อยูแลว)  

(Display Current Frame) สําหรับชองนี้เราสามารถเลือกใหแสดงเฟรมใดเฟรมหนึ่งเพื่อดูลักษณะการ

เคล่ือนไหว เพียงพิมพคาเฟรมที่เราตองการ เชน ตองการใหแสดงเฟรม 20 ก็ใหพิมพคา 20 ลงไป หรือกดปุมสามเหลี่ยม

เพื่อเลือกเฟรม หรือคลิกเมาสปุมซายคางไว แลวลากไปมาเพื่อเลือกเฟรมแบบรวดเร็วก็ได นอกจากนั้นยังสามารถคลิก

เมาสปุมซายแลวกดคีย <Shift+Alt> คางไวแลวเลื่อนไปมา ก็จะเปนการเลือกเฟรมทีละเฟรมตามการเลื่อนเมาสได 
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2. ตอมาจะกําหนดใหเฟรมที่ 1 เปนคียเฟรมแรก โดยคลิกเมาสปุมขวาเลือกวัตถุกอน จากนั้นกดคีย <I> เพื่อ

สรางคียเฟรม (หรือเรียกวาการ Insert Keyframe) จากนั้นจะมีปอบอัพแสดงรายการใหเราเลือกวา เราจะสรางการ

เคล่ือนไหวใดใหกับวัตถุ ดังนี้ 

  Loc (Location) เปนการกําหนดแอนิเมชั่นดวยการยายตําแหนง 

  Rot (Rotation) เปนการกําหนดแอนิเมชั่นดวยการหมุนวัตถุ 

  Size เปนการกําหนดแอนิเมชั่นดวยการยอหรือขยายวัตถ 

  LocRot เปนการกําหนดแอนิเมชั่นดวยการยายตําแหนงและหมุนวัตถุดวย  

  LocRotSize เปนการกําหนดแอนิเมชั่นดวยการยายตําแหนง หมุน และยอ/ขยายวัตถุไดตามตองการ 

สําหรับตัวอยางนี้เราจะเลือก LocRotSize เพื่อสรางการเคลื่อนที่ดวยการยายตําแหนง หมุนและยอ/ขยายวัตถุ

ไดตลอดการเคลื่อนที่ (ตามโจทย) โดยคลิกเมาสปุมซายเลือก LocRotSize จะทําใหเฟรม 1 กลายเปนคียเฟรมแรกทันที 

ซึ่งโปรแกรมจะทําการบันทึกตําแหนง การวางตัวและขนาดของวัตถุในเฟรมแรกไว  
 
2. กดคีย <I> เลือก LocRotSize สรางคียเฟรมแรก 

 
 

1. กําหนดเฟรมแรกเปนเฟรมที่ 1 

3. จากนั้นเราจะสรางคียเฟรมตอไป สําหรับคียเฟรมนี้ เราจะระบุคาใหวัตถุเคลื่อนที่จากทางซายของวิวพอรตไป

ทางขวา โดยกําหนดใหมีการเคลื่อนที่ทั้งหมด 100 เฟรม ใหเราพิมพเลข 100 ลงไปในชองกําหนดเฟรม สังเกตวาจะเกิด

เสนสีเขียวที่เฟรม 100 จากนั้นเราจะระบุใหเฟรม 100 เปนคียเฟรม 

4. เล่ือนวัตถุไปยังตําแหนงที่ตองการ แลวกดแปน <I> แลวเลือกลักษณะการสรางคียเฟรม (ในตัวอยางเลือก 
Loc) 
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4. กดคีย <I> แลวเลือก Loc สรางคียเฟรมที่ 2 

 
  

3. กําหนดเฟรมสดุทาย 
 

(จากขอ 3 และ 4) เราสามารถส่ังใหโปรแกรมสรางคียเฟรมใหเราแบบอัติโนมัติได โดยทุกครั้งที่เรากําหนดเฟรม

ใดใหเปนคียเฟรม และทําการเปลี่ยนแปลงตําแหนง หมุน หรือเปล่ียนขนาดวัตถุ โปรแกรมจะบันทึกคานั้นๆ ลงในคียเฟรม

ที่เราเลือกใหทันที ซึ่งจะสะดวกกวาวิธีแรกที่ตองกําหนดคาผานการ Insert Keyframe โดยคลิกที่ปุม    

(Automatically Insert Keyframe) ที่ Header ของหนาตาง Timeline จากนั้นสรางการเคลื่อนไหวปกต ิ
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C. เม่ือมีการปรับตําแหนงวัตถ ุโปรแกรมจะบันทึกลงในคียเฟรมทันที 

 
 
A. คลิกเลือก 

B. กําหนดคียเฟรม 
 

ขั้นตอนที ่3 หมุนและขยายขนาดวัตถุ 
ตอมาเราจะสรางคียเฟรมที่ 3 ใหบันทึกการหมุนและขยายขนาดขยายขนาดวัตถุ ซึ่งเราจะกําหนดใหมีการ

เคล่ือนไหวในลักษณะนี้ทั้งหมด 100 เฟรมตอจากการเคลื่อนไหวในขั้นตอนที ่2 ดังนั้น คียเฟรมที่ 3 เราจึงจะเซ็ตหรือตั้งให

อยูในเฟรมที่ 200 ดังภาพ 

1. ขณะที่เราทํางานกับโหมดการตั้งคาคียเฟรมอัติโนมัติ ใหเราสรางคียเฟรมที่ 3 ในเฟรมที่ 200 โดยพิมพเลข 

200 ลงไปในชองกําหนดเฟรม   

2. ใชเครื่องมือ   ในกลุมเคร่ืองมือ Transformation หมุนวัตถุ  

3. ใชเครื่องมือ   ในกลุมเคร่ืองมือ Transformation ขยายขนาดวัตถุ 
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2. หมุนวัตถ ุ
 

 
 

1. ใสเลข 200 
3. ขยายวัตถ ุ

 

 
 

 
เมื่อเราสรางเสร็จแลว ใหทดลองดูแอนิเมชั่นนี้ โดยเลื่อนเฟรมมายังเฟรมแรก   หรือพิมพ 1 ลงในชองกําหนด

เฟรม แลวคลิกเมาสปุมซายที่ปุม  (Play) บริเวณ Header ของ Timeline 
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เลื่อนเฟรมมาที่เฟรมแรก แลวลิกเมาสปุมซายที่ปุม  
 

 
 
 
 
 
 
 
 
 
 

วัตถุจะมีการเปลี่ยนแปลง 
 

จะเห็นวาวัตถุมีการเปลี่ยนแปลงตามการกําหนดคียเฟรมที่เราไดสรางไว ซึ่งเมื่อเราเลือกสรางคียเฟรมแบบ 

LocRotSize ทําใหเราสามารถเปลี่ยนแปลงวัตถุไดทั้งตําแหนง การหมุน และขนาด โดยคียเฟรมที่ 1 ไมมีการเปลี่ยนแปลง

ใดๆ เพราะเราไมไดสรางการเปลี่ยนแปลง จากนั้นวัตถุจะคอยๆ เล่ือนมาทางขวาตามคียเฟรมที่ 2 ในเฟรม 100 ที่เรา

กําหนดการเปลี่ยนแปลงไว แลวสุดทายเมื่อผานเฟรม 100 วัตถุก็จะเลื่อนมาทางขวาสุดของวิวพอรต พรอมกับหมุนตัวเอง

และขยายใหญขึ้นจนหยุดในเฟรม 200 ซึ่งเปนคียเฟรมที่ 3 ที่เรากําหนดไว 

  เราสามารถควบคุมการแสดงแอนิเมชั่นดวยปุม   ทั้งหมดนี้     

  ปุม     เปนการกําหนดใหการแสดงกลับมาเริ่มตนที่เฟรมแรกกอน   

  ปุม     เปนการสั่งใหกลับไปยังคียเฟรมกอนหนา  

  ปุม     เปนการเลนแอนิเมชั่น  

  ปุม   เปนการสั่งใหไปยังคียเฟรมถัดไป  

  ปุม     เปนการสั่งใหไปยังเฟรมสุดทายที่เราสรางไว 
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บทที่ 12 
สรางงานแอนิเมชั่นดวย IPO  Curve และ Path Animation 

 
ในบทนี้เราจะไดเรียนรูถึงวิธีการสรางการเคลื่อนไหวเชิงประยุกตใหกับโมเดลดวยการควบคุมโมเดลอยางมือ

อาชีพดวย IPO Curve Editor และวิธีการสรางการเคลื่อนไหวจากเสน Path ดวยวิธี Path Animation ที่นิยมใชกันใน

การสรางเสนทางการเคลื่อนไหวใหโมเดล 
 

การใชงาน IPO Curve 
ความสามารถในการสรางแอนิเมชั่นของโปรแกรม Blender ที่นาสนใจก็คือ การใชหนาตาง IPO CURVE มา

ชวยในการปรับแตงรายละเอียดของการสรางแอนิเมชั่นใหกับวัตถ ุโดยหนาตางทํางานของ IPO CURVE จะมีลักษณะเปน

เสนกราฟหลายสี เสนกราฟเหลานี้เรียกวา “กราฟ IPO (Interpolation)” เปนกราฟที่แสดงผลของการแอนิเมชั่นที่เรา

สรางไว 

 
IPO Curve กราฟแสดงการสรางแอนิเมชั่น 
 

เรียกใชงาน IPO Curve 
หนาตาง IPO Curve เปนหนึ่งในหนาตางของกลุมหนาตางใน Window Type ดังนั้นเราจะแบงหนาตางเพิ่มอีก

หนึ่งหนาตางกอน โดยคลิกเมาสปุมขวาที่สวนบนของวิวพอรต เลือก Split Area แลวคลิกเมาสปุมซายกลางหนาจอ เรา

จะไดหนาตางใหมขึ้นมา 
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แบงวิวพอรตโดย Split Area เพื่อจะกําหนดหนาตางใหมใหเปนหนาตาง IPO Curve Editor 
 

จากนั้นคลิกเมาสที่ปุม   (Display Current Windows Type) แลวเลือก IPO Curve Editor จะปรากฏ

หนาตาง IPO Curve Editor ขึ้นมา เราจะเห็นวามีเสนกราฟอยูในหนาตาง  

 
 
1. คลิกเมาสที่ปุม  แลวเลือก IPO Curve Editor 2. จะปรากฏหนาตาง IPO Curve Editor ขึ้นมา 
 

เราสามารถควบคุมมุมมองของกราฟไดเหมือนกับวิวพอรตที่แสดงชิ้นงาน เชน การยอ/ขยายหนาตางทําไดโดย

กดคีย <Ctrl+Atl> พรอมกับคลิกเมาสกลางเล่ือนขึ้นเลื่อนลง หรือตองการเลื่อนเพื่อดูสวนอื่นๆ ในกราฟ ก็ใหคลิกเมาส

กลางคางไวแลวเลื่อนหนาจอก็ไดเชนกัน   

 

เขาใจการทํางานกับ IPO Curve Editor   
กราฟในหนาตาง IPO Curve Editor นั้น จะมีสัญลักษณะและสีสันหลากหลาย ซึ่งแตละสัญลักษณและแตละสี

นั้นมีความหมายเล็งถึงวัตถุและช้ินงานที่เราสรางการแอนิเมชั่นไวทั้งส้ิน ดังนี้ 
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จุดคียเฟรม  
เปนจุดสีดําบนเสน Curve แตละเสน และจุดเหลานี้จะอยูในตําแหนงที่ตรงกัน ดังตัวอยางภาพนี ้เราไดสรางแอนิ

เมชั่นไวกอนหนานี ้3 คียเฟรมเราจึงเห็นจุดบนเสน Curve แตละเสนเปน 3 จุด  
เสน Curve 
เสน Curve เหลานี้จะใชสรางความราบรื่นใหกับการทําแอนิเมชั่น ซึ่งโปรแกรมจะบอกใหทราบวาเสน Curve 

เสนนี้คือ Curve ของการแอนิเมชั่นอะไรโดยดูจากสีของเสน Curve และคําอธิบายดานขาง และถาเราตองการปรับการ

เคล่ือนไหวของเสน Curve ก็สามารถเลือกเสน Curve นั้นแลวทําการแกไขได โดยวิธีดังนี้ 

1. คลิกเมาสปุมขวาเลือกเสน Curve นั้น สังเกตวาจุดสีดําบนเสน Curve จะกลายเปนจุดสีขาวเมื่อถูกเลือก  

2. จากนั้นใหเรากดคีย <Tab>  เพื่อเขาสูการปรับแตงเสน Curve สังเกตวาจะมีแขนเกิดขึ้นที่จุดบนเสน Curve 

ซึ่งเราสามารถปรับแตงตําแหนงของจุดคียเฟรมได ดังนี้ 

  ‐ ถาเราตองการปรับแตงที่จุดใด ใหคลิกเมาสปุมขวาเลือกที่จุดนั้น แลวคลิกเมาสปุมขวาคางไวเพื่อดึง

แขนปรับจุด  

  ‐ ถาตองการปรับตําแหนงจุด กดคีย <G> แลวเลื่อนตําแหนงจุดตามตองการ คลิกเมาสปุมซายเพื่อวาง

จุดนั้น  

  ‐ ถาตองการปรับเสน Curve อื่น ก็ใหกดแปน <Tab> อีกครั้งเพื่อออกจากการทํางานกับจุดเขาสูการ

ทํางานกับเสน Curve แทน 

ดังตัวอยางตอไปนี ้เราจะมาทดลองปรับแตงเสน Curve เพื่อสังเกตความเปลี่ยนแปลงของการเคลื่อนที่เมื่อมีการ

ปรับแตง โดยคลิกเมาสปุมขวาเลือกเสนกราฟสีแดง Loc X (ดูจากคําอธิบายดานขาง) เพื่อปรับตําแหนงในแกน x จากนั้น

กดคีย <Tab> เขาสูการปรับแตงคียเฟรมหรือจุดบนเสน Curve 
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เลือกกราฟสีแดง แลวกดคีย<Tab> เขาสูการปรับแตงคียเฟรม 
 

ใหเราลองทดสอบดูการเคล่ือนที่กอนปรับแตงเสนกราฟจากหนาตางวิวพอรตกอน จากนั้นคลิกเมาสขวาเลือกจุด

ลําดับที่ 2 แลวกดคีย <G> เล่ือนจุดขึ้นบน และคลิกเมาสปุมซายเพื่อวางจุด 

 
 

ขยับจุดบนเสนกราฟขึ้น 
 

เมื่อทดลองแสดงการเคลื่อนไหวอีกครั้ง จะสังเกตความเปลี่ยนแปลงไดวา การเคล่ือนที่เดิมจะเปลี่ยนไป นั่นคือ

วัตถุจะเคลื่อนที่เลยพื้นไป และมีการวนกลับมาที่ตําแหนงเดิมเล็กนอยเมื่อผานชวงของจุดที่เราเปล่ียนแปลง 

 
 
 
   
 
จากนั้นลองกดคีย <G> เล่ือนจุดลงมาดานลางบาง จะสังเกตวา การเคลื่อนที่ของวัตถุจะยอนกับไปทางซายกอน 

และเมื่อผานคียเฟรมที่เราเปล่ียนแปลง วัตถุจะกลับมาแสดงการเคลื่อนที่ตามเดิม 

กอนการเปลี่ยนตําแหนงคียเฟรมที ่2 ใน IPO Curve หลังการเปลี่ยนตาํแหนงคียเฟรมที ่2 ใน IPO Curve จะ
เห็นวาตําแหนงของวัตถุก็จะเปลี่ยนไปดวย 
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ขยับจุดบนเสนกราฟลง 

 

 
 
 
 
 

การปรับแตง IPO Curve ดวย Interpolation Mode 
นอกจากนั้น เรายังสามารถปรับเสนกราฟเพิ่มเติมโดยกําหนดรูปแบบวางตัวของเสนกราฟ สามารถทําไดโดย

ขณะที่เรากําลังเลือกจุดคียเฟรม ใหคลิกเมาสซายเลือกเมนู Point แลวเลือก Interpolation Mode จะพบตัวเลือก 3 

แบบ คือ Constant, Linear และ Bezier  

 
 

ในตวัอยางนี้เราเลือกคียเฟรมที่ 2 ของเสนกราฟสแีดง Loc X 
 

Constant เปนการจัดใหมีการเคลื่อนที่แบบไมตอเนื่อง จะแสดงเฉพาะการเปลี่ยนแปลงที่คียเฟรมที่กําหนดไว

เทานั้น 

กอนการเปลี่ยนตําแหนงคียเฟรมที ่2 ใน IPO Curve หลังการเปลี่ยนตาํแหนงคียเฟรมที ่2 ใน IPO Curve จะ
เห็นวาตําแหนงของวัตถุก็จะเปลี่ยนไปดวย 
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เสนกราฟจะเปลี่ยนไปหลังการเลอืก Constant 
 

ผลของการเคลื่อนที่ระหวางคียเฟรมที่ 1 และคียเฟรมที่ 2 จะเปลี่ยนไป สังเกตวา เราจะไมเห็นวัตถุคอยเคลื่อนที่

จากจุดเริ่มตนไปยังคียเฟรมที่ 2  แตจะกลายเปนแสดงเฉพาะคียเฟรมแรกและคียเฟรมที่ 2 แทน 
 
Linear เปนการจัดใหมีการเคลื่อนที่ตามการเคลื่อนที่เดิม แตจะไมคอยนุมนวลราบรื่นมากนัก 

 
 

เสนกราฟจะเปลี่ยนไปหลังการเลอืก Linear 
 

Bezier เปนการจัดใหมีการเคลื่อนที่ตามการเคลื่อนที่เดิม ซึ่งจะมีความราบรื่นในการเคลื่อนที่มากที่สุด โดย

โปรแกรมจะตั้งใหการเคลื่อนที่เปนแบบ Bezier เปนหลัก 
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เสนกราฟจะเปลี่ยนไปหลังการเลอืก Bezier เปนกราฟปกติ 
 

เทคนิคการใช IPO Curve ควบคุมการเคลื่อนไหว 
สําหรับหัวขอนี้ เราจะมาศึกษาวิธีการใช IPO Curve เพื่อควบคุมวัตถุในการทําแอนิเมชั่น  โดยจะสรางลูกบอล

ใหวางอยูดานซายของวิวพอรต และจะใช IPO Curve เขามาควบคุมการเคลื่อนไหวในรูปแบบตางๆ ใหลูกบอลกระเดง 1 

รอบ ดังภาพ 
 

 
 

สําหรับการสรางการเคลื่อนที่นี้ เราจะตั้งใหมีการแสดงทั้งหมด 150 เฟรม โดยกําหนดคา End Frame เปน 150 

และอัตราการแสดงภาพเปน 25 เฟรมตอวินาที 
 

 
 
ปรับคาตางๆ โดยแสดงทั้งหมด 150 เฟรม โดยกําหนดคา End Frame เปน 150 และใหมีจํานวนเฟรมตอวินาทีเปน 25 
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จากภาพ ในตอนเริ่มตนนั้นวัตถุจะยังไมมีการแอนิเมชั่น สังเกตไดจากหนาตาง IPO Curve Editor ยังไมปรากฏ

เสนกราฟดๆ จากนั้นเราจะสรางคียเฟรมแรกใหกับลูกทรงกลม โดยใหตําแหนงแรกวัตถุหยุดอยูนิ่งที่ตําแหนงเดิมกอน และ

ตอไปนี้เราจะสรางแอนิเมชั่น โดยการสรางคียเฟรมจากการเปลี่ยนตําแหนงของลูกบอล ดังนี้ 

    คียเฟรมที่ 1 (เฟรม 1) กําหนดใหลูกบอลเร่ิมกระเดง  

    คียเฟรมที่ 2 (เฟรม 20) กําหนดใหลูกบอลกระเดงที่จุดสูงสุด 

    คียเฟรมที่ 3 (เฟรม 40) กําหนดใหลูกบอลกระทบพื้น 
 

 
คียเฟรมที่ 1 (เฟรม 1)   คียเฟรมท่ี 2 (เฟรม 20)  คียเฟรมท่ี 2 (เฟรม 40) 
 
คียเฟรมที่ 1 (เฟรม 1) กําหนดใหลูกบอลเริ่มกระเดง 

โดยเราจะกําหนดใหลูกบอลหยุดนิ่งบนพื้นที่มุมดานซายของจอภาพกอน จากนั้นกําหนดใหเฟรม 1 เปนคียเฟรม

ที่จะเริ่มมีการเคลื่อนที่ ดังนี้ 

1. ขณะอยูที่เฟรมแรก (เฟรมที่ 1) ใหคลิกเมาสขวาเลือกลูกบอล แลวกดคีย <I> เพื่อสรางคียเฟรมแรก โดยคลิก

เลือก Loc (Location) เพื่อสรางแอนิเมชั่นดวยการเปลี่ยนตําแหนง สังเกตที่หนาตาง IPO CURVE EDITOR จะมีเสน 

Curve ปรากฏขึ้นมา และมีจุดคียเฟรมจุดแรกอยูบนเสน Curve 

2. กดคีย <N> เพื่อแสดง Transform Properties ซึ่งเปนสวนที่แสดงตําแหนงของวัตถุ โดยที่เราจะใช

ประโยชนจากสวนนี้ในการกําหนดการเคลื่อนที่ของลูกบอลที่มีคาแนนอนและชัดเจน 

  
 

1. คลิกเมาสขวาเลือกลูกบอล แลวกดคีย <I> เลือก Loc (Location) 
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หนาตาง IPO CURVE EDITOR จะมีเสน Curve ปรากฏขึ้นมา และมีจดุคียเฟรมจุดแรกอยูบนเสน 
 

 
2. กดคีย <N> เพื่อแสดง Transform Properties 

 
 
คียเฟรมที่ 2 (เฟรม 20) กําหนดใหลูกบอลกระเดงที่จุดสูงสุด 

โดยเราจะกําหนดใหลูกบอลกระเดงขึ้น ในจุดที่สูงสุดของการเคลื่อนที่ในเฟรม 20 และใหมีการเลื่อนตําแหนงขึ้น 

2.5 หนวยในแกน Z และไปขางหนา 2 หนวยในแกน Y ดังวิธีการตอไปนี ้

1. สรางคียเฟรมที่ 2 ที่เฟรม 20 โดยไมใชวิธีการสรางเฟรมอัติโนมัติ แตเลือกกําหนดสรางคียเฟรมเอง ใหพิมพ

คา 20 ลงไปในชองกําหนดเฟรม  

2. ยายลูกบอลขึ้น 2.5 หนวย (ยายตําแหนงแกน Z) โดยพิมพคา 3.5 ใน Loc Z ที่ Transform Properties (คา

นี้ใหเราบวกเพิ่มจากคา Z ตั้งตน ซึ่งขึ้นอยูกับการวางตําแหนงลูกบอลของเรา ในตัวอยางนี้เราวางลูกบอลไวในตําแหนง Z 

= 1.0 ดังนั้นเมื่อเล่ือนตําแหนง 2.5 หนวยจึงพิมพคา 3.5 ลงไปในชอง LocZ) 
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3. ยายลูกบอลไปขางหนา 2 หนวย (ยายตําแหนงแกน X) โดยพิมพคา 2 ใน Loc X ที่ Transform Properties 

(คานี้ใหเราบวกเพิ่มจากคา X ตั้งตน ซึ่งขึ้นอยูกับการวางตําแหนงลูกบอลของเรา ในตัวอยางนี้เราวางลูกบอลไวใน

ตําแหนง X = 0.0 ดังนั้นเมื่อเล่ือนตําแหนง 2 หนวยจึงพิมพคา 2 ลงไปในชอง LocX) 

4. กดคีย <I> แลวเลือกเลือก Loc (Location) ใหคียเฟรมที่ 2 จดจําตําแหนงที่เปล่ียนไป 

ในขณะนี้ถาเรามาดูที่ IPO CURVE สังเกตวากราฟเสนสีแดงและเหลืองจะมีคาสูงขึ้น แสดงวาแกน X และ Z มี

การเปลี่ยนแปลงคา  
 

2. พิมพคา LocZ เทากับ 3.5  3. พิมพคา LocX เทากับ 2 
 

 
 

1. สรางเฟรมที ่2 ในเฟรมที ่20 
 
4. กดคีย <I> เลือก Loc เพื่อสรางคยีเฟรมท่ี 2 ใหมีการจําคาตําแหนงท่ีเราเพิ่งเคลื่อนยายไป 
 

 
 

กราฟเสนสีแดงและเหลืองจะมีคาสูงขึน้ แสดงวาแกน X และ Z มีการเปลี่ยนแปลงคา 
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คียเฟรมที่ 3 (เฟรม 40) กําหนดใหลูกบอลกระทบพื้น 
สําหรับคียเฟรมสุดทาย (เฟรม 40) เราจะปรับใหมีการเคล่ือนที่ของลูกบอล ในลักษณะที่กระทบพื้น โดยปรับให

มีการเลื่อนตําแหนงลงมาเทากับคาเริ่มตนนั่นคือ 1 หนวย (คาที่ลูกบอลวางบนพื้น ซึ่งคานี้ขึ้นอยูกับเราวาในครั้งแรกเราจัด

ตําแหนงแกน Z เทาไหรใหตั้งคาตามคานั้น) และเคลื่อนที่ไปขางหนา 2 หนวยในแกน Y ดังนั้นจากคา Y เดิมคือ 2 หนวย

ตองเคลื่อนที่เพิ่มอีก 2 หนวย รวมเปน 4 หนวยจากจุดเริ่มตน จึงกําหนดใหคา Y เปน 4 ดังวิธีการตอไปนี้ 

1. สรางคียเฟรมที่ 3 ขึ้นมาเพื่อลองควบคุมวัตถุดวย IPO Curve อีกครั้ง โดยคราวนี้ใหพิมพ 40 ในชองกําหนด

เฟรม แลวกดคีย <Enter>  

2. ตองการเลือกใหลูกบอลตกลงมา เราจะตองระบุใหตําแหนงใหมของลูกบอลนี้มีตําแหนงแกน Z เทากับคา

เริ่มตนขณะที่ลูกบอกอยูบนพื้น (ในตัวอยางคือ 1) โดยคลิกเมาสในชอง LocZ แลวพิมพ 1  

3. ใหลูกบอลเดงไปขางหนาอีก 2 หนวย โดยพิมพคา 4 ในชอง LocX จากนั้นกดคีย <Enter>  

4. จากนั้นใหสรางเฟรม 40 นี้ใหกลายเปนคียเฟรม โดยกดคีย <I> แลวเลือก Loc ในตอนนี้กราฟในหนาตาง 

IPO Curve จะมีการเปลี่ยนแปลง นั่นคือ คา Curve ในแกน Z เทากับ 1 และคา Curve ในแกน X เทากับ 4 
 

2. พิมพคา LocZ เทากับ 1  3. พิมพคา LocX เทากับ 4 
 

 
 

1. สรางเฟรมที ่3 ในเฟรมที่ 40 
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4. กดคีย <I> เลือก Loc เพื่อสรางคยีเฟรมท่ี 3 

 
กราฟเสนแดงและเหลืองมีการเปลี่ยนแปลงคา 
 

ถาเราคลิกเมาสปุมซายในบริเวณหนาตาง IPO CURVE EDITOR แลวเลื่อนเสนสีเขียวไปมา จะพบวาวัตถุมีการ

เคล่ือนที่ตามลักษณะของเสน Curve หรือมีการเคลื่อนที่ในแกน X และ Z ตามเสน Curve ใน LocX และ LocZ นั่นเอง 
 

 
 
เม่ือมีการขยับเสนสีเขียวจะมีการเคลื่อนไหวของลูกบอล 

 
และนี่คือหลักการในการควบคุมวัตถุใหเคลื่อนไหวดวยการใชเสน IPO Curve ตอไปเราจะรูจักวิธีการควบคุม

วัตถุอีกรูปแบบหนึ่งดวยการใช Extent Mode ใน IPO Curve ซึ่งเปนการควบคุมวัตถุที่นํารูปแบบสําเร็จรูปมาชวยสราง

การเคลื่อนที่เพิ่มเติมใหกับแอนิเมชั่นที่เราสรางไว 
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สรางการเคลื่อนไหวสําเร็จรูปดวย Extent Mode ของ IPO Curve 
Extent Mode เปนโหมดการทํางานที่ใชควบคุมวัตถุดวยเสน IPO แบบสําเร็จรูป ซึ่งจะชวยใหเราประหยัดเวลา

ในการสรางการเคลื่อนไหว ไมจําเปนตองสรางคียเฟรมที่ละคียเฟรม แตเลือกใช Extent Mode สรางคียเฟรมตามรูปแบบ

ของการเคลื่อนไหวของชิ้นงานตนแบบไดทันที โดยวิธีการทํางานดวย Extent Mode มีดังนี้ 

1. เลือกทํางานกับเสน Curve ทั้งสามเสน โดยกดคีย <Shift> แลวคลิกเมาสขวาเลือกเสน Curve หรือกดคีย 

<A> เพื่อเลือกเสน Curve ทั้งหมดก็ได (สังเกตจากจุดคียเฟรมจะตองเปนสีขาว) 

2. จากนั้นเลือกเมน ูCurve>Extent Mode จะพบตัวเลือกใหเรา 4 ตัวเลือกซึ่งมีการเคล่ือนที่แบบตางๆ ไดแก 

Constant, Extrapolation, Cyclic และ Cyclic Extrapolation 
 

 
 

 
 
 
โดยลักษณะของการเคลื่อนที่ของแตละรูปแบบมีดังนี้   

Constant เมื่อเลือก Constant แลวทดลองแสดงแอนิเมชั่นดูจะพบวามจะเปนการเคลื่อนที่ตามลักษณะการ

เคล่ือนที่เดิม นั่นคือบอลมีการกระเดงเพียงครั้งเดียว และเมื่อเลยคียเฟรมที่ 3 ไป บอลก็จะหยุดนิ่งอยูบนพื้น 

 
เม่ือเลือก Constant การเคลื่อนที่จะเปนตามเดิม 

1. เลือกทํางานกับเสน Curve ทั้งสาม 
2. เลือกเมน ูCurve>Extent Mode จะ
ปรากฏตัวเลอืก 4 
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Extrapolation เมื่อเลือก Extrapolation แลวทดลองแสดงแอนิเมชั่นดู จะพบวามีการเคล่ือนที่เพิ่มขึ้นจาก

เสน Curve เดิมที่เราสรางไว โดยจะมีเสน Curve ที่ลากตอจากคียเฟรมสุดทายในทิศทางเดียวกัน นั่นคือเมื่อบอลมีการ

กระเดงหลังจากกระทบพื้นแลว จะจมหายลงไป 

 
 

เม่ือเลือก Extrapolation จะมีการเคลื่อนที่เพิ่มขึ้นจากเสน Curve เดิม 
 

 
 

Cyclic เมื่อเลือก Cyclic แลวทดลองแสดงแอนิเมชั่นดู จะพบวามีการแสดงซ้ําตามแอนิเมชั่นเดิม โดยจะเคลื่อนที่

แบบวนลูป 
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เม่ือเลือก Cyclic จะเคลื่อนที่แบบวนลูป 
 

 
 

Cyclic Extrapolation จะเปนการเคลื่อนที่วนลูปเฉพาะการเคลื่อนที่ในแกน Z แตสําหรับแกน X จะมีการ

เคล่ือนที่ไปขางหนา เหมือนกับลูกบอลกระเดงไปเรื่อยๆ 
 

 
เม่ือเลือก Cyclic Extrapolation จะทําใหมีการเคลื่อนที่ตอเนื่องไปเรื่อยๆ 

 

 
การทํางานดวย IPO Curve จะมีประโยชนมากสําหรับการทําแอนิเมชั่น ซึ่งถาเราลองศึกษาหรือฝกเพื่อเติมใน

แกนอื่น และการเคลื่อนที่แบบอื่นก็จะพบวาการใช IPO CURVE มาชวยปรับแตงแอนิเมชั่น จะชวยใหเราไมตองเสียเวลา

ในการสรางคียเฟรมทีละจุด อีกทั้งยังงายในการควบคุมใหเปนไปตามตองการอีกดวย 
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สรางการเคลือ่นไหวตามเสนทางทดวยวิธ ีPath Animation 
สําหรับหัวขอนี้ เราจะมาศึกษาการสรางแอนิเมชั่นอีกรูปแบบหนึ่งที่นําเสน Path มาใชในการสรางเสนทางในการ

เคล่ือนที่ เรียกวา “Path Animation” โดยในตัวอยางนี ้เราจะสรางใหเครื่องบินใหบินตามเสน Path ที่เราไดสรางไว 

พรอมทั้งเอนตัวตามทิศทางของเสน Path นั้นดวย นอกจากนั้น เราจะใช IPO CURVE เขามาชวยในการปรับแตง

รายละเอียดใหราบรื่นขึ้นดวย ดังนี้ 
 

 
 

เครื่องบินเคลื่อนที่ตามเสน 
 

จากภาพ เราจะเห็นวา เครื่องบินนั้นไดบินไปตามเสน Path ที่เรากําหนด โดยแบงขั้นตอนการสรางชิ้นงานนี้

ออกเปน 3 ขั้นตอน ดังนี้ 

  ขั้นตอนที ่1 สรางเสน Path  

  ขั้นตอนที ่2 สรางเครื่องบินใหบินตามเสน Path 

  ขั้นตอนที ่3 ปรับแตงการเครื่องที่ของเครื่องบินใหเปนตามกฏธรรมชาติ 
 

ขั้นตอนที ่1 สรางเสน Path 
เริ่มตนใหเราเปดไฟลเครื่องบินขึ้นมาหรือวัตถุใดก็ไดที่เราตองการสราง โปรแกรมก็จะแสดงวัตถุเครื่องบินขึ้นมา

บนวิวพอรต ในที่นี้เราจะเลือกทํางานกับมุมมอง TOP เพื่อสะดวกในการสรางเสนทางการเคลื่อนที่ของเครื่องบิน จากเรา

จะสรางเสน Path ใหเปนเสนทางสําหรับการเคลื่อนที่ของเครื่องบิน ดังภาพ 
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สรางเสนทางสําหรับการเคลื่อนที่ของเครื่องบิน 
 

ในที่นี้เราจะปรับใหเสนมีลักษณะคลายกราฟรูป Sine Curve ดังนั้นเราจึงตองปรับแตงจุดทั้ง 5 ใหมีตําแหนงที่

เหมาะสม ดังนี้ 

1. เลือกเมนู Add>Curve>Path โปรแกรมก็จะแสดงเสน Path ขึ้นมา  

2. เมื่อเราไดเสน Path แลวใหขยายเสน Path ใหยาวขึ้นจนเต็มวิวพอรต โดยใชอุปกรณ Scale หรือกดคีย <S> 

ที่คียบอรด แลวลากเมาสขยายเสน Path ใหยาวขึ้น 

3. เมื่อไดความยามตามตองการใหคลิกเมาสปุมซายเพื่อออกจากการขยายเสน  สังเกตวาในเสน Path จะมีจุด

สําหรับใชปรับแตงรูปรางของเสน โดยมีทั้งหมด 5 จุด 

 
 

1. เลือกเมน ูAdd>Curve>Path 
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2. กดคีย <S> ขยายเสน Path 

 

 
3. จะไดจุดควบคุมเสน Path 5 จุด 

 
 

4. ขณะที่เราทํางานใน Edit Mode อยูนั้น ใหคลิกเมาสขวาเลือกจุดแรกของเสน Path แลวเลือกอุปกรณ 

Translate หรือกดคีย <G> แลวลากเมาสเล่ือนจุดนั้นมาวางในตําแหนงใหม จากนั้นคลิกเมาสซายเพื่อวางจุด  

5. สําหรับจุดที่ 2 เมื่อคลิกเมาสขวาเลือกจุดที่ 2 แลวใหเรากดคีย <G> แลวดึงจุดที่ 2 ลงมาดานลาง เพื่อดึงเสน 

Path ใหโคงต่ําลงมา คลิกเมาสซายเพื่อวางจุด 

6. ตอมาเราจะเลือกจุดที่ 4 แลวกดคีย <G> ดึงจุดที่ 4 ขึ้นไปใหเสน Path ใหโคงขึ้น คลิกเมาสซายเพื่อวางจุด 

(สวนจุดที่ 3 วางไวตําแหนงเดิม เพราะเปนจุดกึ่งกลางของเสนอยูแลว)  

7. เลือกจุดสุดทายจุดที่ 5 กดคีย <G> ดึงจุดที่ 5 ลงมา แลวคลิกเมาสซายเพื่อวางจุด 
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1. เลื่อนจุดแรกขึน้ 
 

 
2. เลื่อนจุดที ่2 ลงมา 

Page 257



 
3. เลื่อนจุดที ่4 ขึ้น 

 
  อยางไรก็ตาม วิธีการเลือกวาจะปรับแตงเสนจากจุดใดนั้น ขึ้นอยูกับรูปแบบลักษณะของเสนที่เรา

ตองการ จึงไมมีสูตรตายตัววาจะตองปรับอยางไรเปนอันดับแรก 
 
 

ขั้นตอนที ่2 สรางเครื่องบินใหบินตามเสน Path 
เมื่อสรางเสน Path เรียบรอยแลว ใหเรากดคีย <Tab> ออกจาก Edit Mode เพื่อเลือกปรับแตงเสน Path ทั้ง

เสน ซึ่งตอไปเราจะสรางใหเสน Path นั้นมีระยะทางตามจํานวนเฟรมในการแสดง และรายละเอียดของแอนิเมชั่นที่เรา

ตองการ โดยทํางานที่หัวขอ Curve and Surface ภายใต Object Mode และทําตามขั้นตอนแตละสวนดังนี้ 

  สวนที่ 1 กําหนดความยาวในการแสดงแอนิเมชั่น 

  สวนที่ 2 กําหนดใหเครื่องบินมีการเคลื่อนที่ไปตามเสน Path 

  สวนที่ 3 กําหนดใหเครื่องบินเคล่ือนที่บนเสน Path 

  สวนที่ 4 กําหนดใหเครื่องบินเคล่ือนที่จนครบทั้งเสนทาง (ครบทุกเฟรมที่เรากําหนด) 
 
สวนที่ 1 กําหนดความยาวในการแสดงแอนิเมชั่น 
ใหเรากําหนดความยาวในการแสดงแอนิเมชั่นที่ปุม   (Path Length) โดยจะกําหนดเปน 150 

เฟรม (ใหคลิกเมาสซายที่ปุมนี้ แลวพิมพจํานวนเฟรมที่ตองการลงไป) 
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คลิกแลวพิมพจํานวนเฟรม 
 

สวนที่ 2 กําหนดใหเครื่องบินมีการเคลื่อนที่ไปตามเสน Path 
จากนั้นเราจะกําหนดใหเครื่องบินมีการเคล่ือนที่ไปตามเสน Path โดยวิธีการดังนี ้

1. คลิกเมาสปุมขวาเลือกเครื่องบิน แลวกดคีย <Shift> คางไว จากนั้นคลิกเมาสปุมขวาเลือกที่เสน Path  

2. ใชคําส่ังจากเมนู Object>Parent>Make Parent หรือกดคีย <Ctrl+P> เพื่อเรียกใชคําส่ังนี้ก็ได แลวเลือกที่ 

Normal Parent ในปอบอัพ สังเกตวาจะมีเสนประเกิดโยงเชื่อมระหวางเครื่องบินกับเสน Path 
 

 
1. คลิกเลือกเครื่องบินแลวเลือกเสน Path 
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2.1 คลิกเลือก Object>Parent>Make Parent 
 

 
 

2.2 คลิกเลือก Normal Parent 
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จะเกิดเสนประเกิดโยงเชื่อมระหวางเครื่องบินกับเสน Path 
 

ถาเราทดลองคลิกปุม Play ก็จะเห็นวาเครื่องบินนั้นไดเคลื่อนที่ไปตามเสน Path แลว แตวาตําแหนงของ

เครื่องบินยังวางผิดที่อยู 
 

 
เลือก Play ดูการเคลื่อนที่ของเครือ่งบิน 

 
สวนที่ 3 กําหนดใหเครื่องบินเคล่ือนที่บนเสน Path 

เราจะทําใหเครื่องบินมาวางที่ตําแหนงใหมใหอยูบนเสน Path เพื่อใหเห็นการเคลื่อนที่ไดชัดเจน และเปนไปตาม

เสนทางที่เราสรางไว โดยคลิกเมาสปุมขวาเลือกเครื่องบน แลวคลิกเมนู Object>Clear/Apply>Clear Origin เสนประ

นั้นจะหายไป และทําใหเครื่องบินมาวางบนเสน Path นั้นทันที  
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คลิกเมน ูObject>Clear/Apply>Clear Origin 
 

 
เครื่องบินยายมาวางบนเสน Path 

 

ใหทดลองคลิกปุม Play ก็จะเห็นวาเครื่องบินนั้นไดเคลื่อนที่ไปตามเสน Path ในตําแหนงที่ถูกตองแลว 
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คลิกปุม Play 
 

 
เครื่องบินเคลื่อนที่ไปตามเสน Path ในตําแหนงทีถ่กูตอง 
 

เมื่อเราสังเกตจากหนาตาง Timeline ก็จะพบวา การเคล่ือนที่ของเครื่องบินนั้นจะเคลื่อนที่เพียงแค 100 เฟรม 

โดยจุดสุดทายที่เครื่องบินหยุดนั้น คือเฟรม 100 แมวาเราจะสรางใหเสน Path มีความยาว 150 เฟรมก็ตาม แตคา

มาตรฐานของวัตถุกอนตั้งคาความยาวในการแสดงนั้นเปน 100 โปรแกรมจึงตั้งคาใหเครื่องบินแสดงเพียง 100 เฟรม

เทานั้น 

ทางแกไขใหเครื่องบินแสดงครบ 150 เฟรมตามความยาวของเสน Path ทําไดโดย กําหนดคาเพิ่มเติมใน IPO 
Curve Editor 
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เปด IPO Curve Editor แลวเลือก Path 
 

ตอมาใหคลิกเมาสขวาเลือกเสน Path จากนั้นเขาสูหนาตาง  IPO Curve Editor  แลวเลือกชนิดเปน Path 

โปรแกรมจะแสดงเสน Curve ขึ้นมา และมีจุดคียเฟรมในเฟรม 100 วิธีการปรับใหการแสดงแอนิเมชั่นของเครื่องบินขยาย

เปน 150 เฟรม ซึ่งสามารถทําได 2 วิธ ีดังนี้ 

ทดลองกดปุม Play เพื่อดูแอนิเมชั่น จะเห็นวาเครื่องบินลํานั้นเคลื่อนที่ตามความยาวของเสน Path จํานวน 150 

เฟรมแลว 

วิธีที่ 1 ปรับจุดคียเฟรมโดยตรง ทําไดดังนี้ 

1. กดคีย <Tab> เขาสูการปรับแตงที่จุดคียเฟรม แลวคลิกเมาสขวาเลือกจุดคียเฟรมที่ตําแหนงเฟรม 100  

2. กดคีย <G> เล่ือนคียเฟรมนั้นออกมาวางที่เฟรม 150 จากนั้นคลิกเมาสปุมซายออกจากการทํางาน  
 

 
 

เลือกจุดเฟรมที่ 100 
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วิธีที่ 2 ใชวิธีการลบเสน Path เดิมทิ้งไปเสีย เพื่อเล่ียงการจํากัดการเคลื่อนที่ ดังนี้ 

1. ในขณะที่คลิกเลือกเสน Path เดิมอยูนั้น ใหเราคลิกเมาสกลางเลื่อนแถบเครื่องมือมาทางซาย เพื่อใหปุม

แสดงชื่อของเสน Curve ปรากฏแลว Add New ก็จะเปนการสรางหนาตาง IPO Curve  

2. จากนั้นตั้งชื่อสําหรับเสน Path ใหม คลิกที่ชองชื่อของเสน Path แลวพิมพชื่อใหมเขาไป (ในที่นี้เราพิมพ 
PlanePath) 

3. กดคีย <Delete> เลือก Erase Selected เพื่อลบเสน IPO สําหรับ Path เดิมทิ้งไป  

เลือกจุดเฟรมที่ 150 

คียเฟรมจะเลื่อนมาที่เฟรม 150 
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4. แลวปรับคา Path Length ใหมเปน 150 ที่ปุม  ในแท็ป Curve and Surface 

 
1. แสดงชื่อของเสน Curve 

 
2. ตั้งชื่อ Path ใหม 
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3. ลบ Path เดิม  

 
4. ปรับคา Path Length เปน 150 

 
และเมื่อเราทดลองคลิกปุม Play ก็จะเห็นวาเครื่องบินลํานั้น สามารถบินไดตามเสนทางจนครบ 150 เฟรมแลว 
 

ขั้นตอนที่ 3 ปรับแตงการเครือ่งที่ของเครื่องบินใหเปนตามกฏธรรมชาติ 
ถาเราสังเกตการเคลื่อนที่ของเครื่องบินในขั้นตอนที่ผานมา ก็จะพบวาลักษณะการหันหัวของเครื่องบินนั้นยังไม

ถูกตอง หัวเครื่องบินยังไมหันไปตามเสนโคง  

 
เครื่องบินหันหวัผดิทาง 
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โดยวิธีการปรับใหเปนไปตามธรรมชาติของการเคลื่อนที่ของวัตถุนั้น สามารถไดโดยคลิกเมาสซายเลือกปุม  

Curve Follow ที่แท็ป Curve and Surface ก็จะสังเกตวาเครื่องบินนั้นเคลื่อนที่ตามความโคงของเสน Path 

 
 

คลิกเมาสซายเลือกปุม Curve Follow 
 

อยางไรก็ตาม เครื่องบินก็ยังหันหัวไมถูกตอง เราจึงตองเขาไปปรับแกไขตอ โดยคลิกเลือกที่ปุม     (Object) 

เลือกคา Track ในแท็ป Animation Setting เปนแกนใดก็ได ซึ่งม ี3 แกนที่ควบคุมวัตถุหรือเครื่องบินนั้นอยู ใหเลือกแกน

ที่ทําใหเครื่องบินวางตัวไดถูกตอง  

ในตัวอยางคลิกเลือกแกน X แลวทดลองกดปุม Play หรือคลิกเมาสซายคางไวที่เสนการเคลื่อนที่ในหนาตาง 

Timeline แลวเลื่อนดู ก็จะพบวาการเคลื่อนที่ของเครื่องบินนั้นถูกตองแลว 
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1. คลิกเลือกที่ปุม  

 
2. ในชอง Track ใหเลือกแกนที่ทําใหเครื่องบินวางตัวไดถูกตอง 

 
แกไขและปรับการเคลื่อนที่ใหสมบูรณแบบ 

นอกจากนั้น เรายังสามารถปรับแตงการเคลื่อนที่ของเครื่องบินใหสมบูรณแบบมากขึ้น โดยทําใหมีการเอียงตัวไป

ตามเสนโคง ใหเหมือนกับการเคลื่อนที่ของเครื่องบินจริงๆ โดยในที่นี้เราจะปรับหนาตางการทํางานใหม ดวยการปรับวิว

พอรตใหแสดงในมุมมอง Perspective จากนั้นทําตามขั้นตอนดังนี ้
 

 
 
เครื่องบินเองตัวไปตามเสนโคง 
 

1.  คลิกเมาสปุมขวาเลือกเสน Path แลวกดคีย <Tab> เขาสูกาทํางานใน Edit Mode จากนั้นคลิกเมาส

ปุมขวาเลือกจุดที่อยูตรงกับสวนโคงของเสน Path (ในตัวอยางคือจุดที ่2) 
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2.  เล่ือนเสนแสดงตําแหนงเฟรมมาใหตรงกับจุดที่เราเลือก แลวใหเราใชคําส่ัง Curve>Control 

Point>Tilt หรือกดคีย <T> จะเปนการปรับใหเครื่องบินเอียงในองศาที่เราตองการได คลิกเมาสปุมซายเมื่อไดองศาที่

พอใจ  

3.  จากนั้นคลิกเมาสปุมขวาที่จุดที่ 4 แลวกดแปน <T> ที่คียบอรด ปรับใหเครื่องบินเอียงในองศาที่เรา

ตองการ แลวคลิกเมาสปุมซาย  
 

1. เลือกจุดที่ 2 ของ Path 
 

 
 

2. เลือก Curve>Control Point>Tilt 
 

 
3. เลือกจุดที่ 4 แลวกดคีย <T> ปรับเครื่องบินใหเอียง 
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สุดทายใหเราทดสอบการเคลื่อนที่ทั้งหมด โดยคลิกไปยังตําแหนงเฟรมเริ่มตน คลิกปุม Play เราก็จะไดการ

เคล่ือนที่ที่สมบูรณแบบ โดยการใชเสน Path มาเปนตัวนําเสนทางใหกับวัตถุ   
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บทที่ 13 
การเรนเดอร 

 
การเรนเดอร เปนการประมวลผลงานที่เราสรางไวใหออกมาเปนชิ้นงานที่สามารถนําไปเผยแพรได โดยในการ

ทํางาน 3D การเรนเดอรจะมีทั้งเรนเดอรเปนภาพนิ่ง และเปนภาพเคลื่อนไหว ทั้งนี้ขึ้นอยูกับช้ินงานที่เราตองการ โดยในบท

นี้ เราจะมาเรียนรูจักกับทั้ง 2 รูปแบบกัน 
 

รูจักกับการเรนเดอร 
เราไดกลาวไปแลวในหัวขอที่ผานมาวา การเรนเดอรในโปรแกรม Blender จะแสดง มุมมองตามมุมมองของ

กลองเสมอ ดังนั้นเราจําเปนตองจัดเตรียมมุมมองที่เราตองการไวและกําหนดใหเปนมุมมองจากกลองกอน จึงจะสามารถ

เรนเดอรออกมาได ซึ่งในตัวอยางเราไดกําหนดมุมมองวัตถุนี้ไวใหเปนมุมมองของกลอง 

 
 

วัตถุในมุมมองกลอง 
 

วิธีการเรนเดอรสําหรับดูผลเปนภาพนิ่ง 
สําหรับการเรนเดอรผลงานนั้นมีหลายวิธี ขึ้นอยูกับช้ินงานนั้นๆ เปนอยางไร บางชิ้นงานเปนภาพนิ่ง บางชิ้นงาน

เปนภาพเคลื่อนไหว และบางชิ้นงานตองอาศัยการเรนเดอรเทานั้นจึงจะแสดงผลงานจริงออกมาได 

ซึ่งในหัวขอนี ้เราจะกลาวถึงการเรนเดอรเปนภาพนิ่งกอน เพื่อใชทดสอบชิ้นงานขณะสรางงาน โดยเลือกคําส่ัง 

Render>Render Current Frame หรือกดคีย <F12> โปรแกรมจะทําการเรนเดอรโดยใชคาคุณสมบัติของเอาทพุต เชน 

ขนาดภาพ คุณภาพของภาพ ตามที่โปรแกรมกําหนดไว 
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เลือก Render>Render Current Frame หรือ กดคีย <F12>   ภาพที่ไดจากการเรนเดอร 
 
การกําหนดคณุสมบัติสําหรับการเรนเดอร 

โปรแกรม Blender ไดออกแบบใหเราสามารถเรนเดอรชิ้นงานไดอยางหลากหลาย ทั้งเรนเดอรเปนภาพนิ่งและ

วิดีโอ โดยใหเราสามารถกําหนดคุณสมบัติของการเรนเดอรเพิ่มเติมได เพื่อใหไดชิ้นงานตามเปาหมาย เริ่มจากกําหนดคา

คุณสมบัติของการเรนเดอร ใหคลิกเมาสซายที่ปุม   (Scene) จากนั้นคลิกปุม   (Render Buttons) เพื่อเขาสูการ

ตั้งคาตางๆ ในแท็ป Format ดังนี้ 

 
 

                     1. คลิกเมาส    2. คลิกเมาส   3. ตั้งคาการเรนเดอรในแท็ป Format 
 
 
การกําหนดขนาดเฟรม 
การกําหนดขนาดเฟรม กําหนดไดที่คา Size X ซึ่งเปนความยาวของเฟรม 

และคา Size Y ซึ่งเปนความสูงของเฟรม โดยโปรแกรมกําหนดคามาตรฐานไวที่ 

800x600 หรือจะกําหนดขนาดเฟรมตามคาเอาทพุตของรูปแบบวิดีโอตางๆ ในปุม

กําหนดคาสําเร็จรูปดานขวาของแถบคําส่ัง ซึ่งปุมเหลานี้จะนิยมใชกับช้ินงานที่เปน

แอนิเมชั่น เพื่อใหไดผลงานออกมาเปนไฟลวิดีโอที่สามารถนําไปเผยแพรแบบตางๆ 

ได เชน 
 
 
 

• PAL โปรแกรมก็จะกําหนดคุณสมบัติของเอาทพุตตามคุณสมบัติของไฟลวิดีโอในระบบ PAL ซึ่งเปนระบบที่ใชใน

ประเทศไทย และทวีปเอเชียบางประเทศ กลาวคือ จะมีคาขนาดเฟรมเทากับ 720x576 (ความยาวในแกน X 

เทากับ 720 และความสูงในแกน Y เทากับ 576) และมีคาอัตราสวนของพิกเซลในภาพ (Aspect Ratio) เทากับ 

54 ในแกน x และ 51 ในแกน Y คาอัตราสวนในการแสดงภาพเคลื่อนไหวเทากับ 25 เฟรมตอวินาที  

ความยาวและความสูงของเฟรม 

กําหนดคุณสมบัติของไฟลวดิีโอ
แบบสําเร็จรูป 
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• NTSC โปรแกรมก็จะกําหนดคุณสมบัติของเอาทพุตตามคุณสมบัติของไฟลวิดีโอในระบบ NTSC ซึ่งเปนระบบที่

ใชในสหรัฐอเมริกา ญี่ปุนและโซนยุโรปบางประเทศ กลาวคือ จะมีคาขนาดเฟรมเทากับ 720x480 และมีคา 

Aspect Ratio เทากับ 10:11 รวมทั้งคาอัตราสวนในการแสดงภาพเคลื่อนไหวเทากับ 30 เฟรมตอวินาที 

• Default จะเปนเลือกใหการเรนเดอรมีคุณสมบัติคลายระบบ PAL 

• Preview จะเปนการเรนเดอรเพื่อทดสอบผลงานซึ่งใชขนาด 640x512 

• PC จะเปนเรนเดอรใหไดไฟลวิดีโอสําหรับแสดงในคอมพิวเตอร โดยใชขนาด 640x480 และมีคา Aspect Ratio 

เทากับ 100:100 หรือมีพิกเซลเปนส่ีเหล่ียมจตุรัส ซึ่งในศัพททั่วไปของงานวิดีโอเรียนกวา “Progessive” 

• PAL 16:9 เปนการเรนเดอรสําหรับไฟลวิดีที่ใชระบบ PAL ขนาดเฟรม  720x576 แตมีคา Aspect Ratio 

เทากับ 64:45 ซึ่งรองรับการแสดงผลแบบ Wide Screen 

• Pano เปนการเรนเดอรสําหรับไฟลที่จะใชสรางเปนรูปแบบ Panorama ที่สามารถมองเห็นไดรอบทิศทาง 360 

องศา 

• Full เปนการเรนเดอรที่ไดภาพขนาดใหญที่สุดคือ 1280x1024 และมีคา Aspect Ratio เทากับ 1:1 

• คุณสมบัติของการเรนเดอรที่กลาวถึงนี้ แมจะเหมาะสําหรับใชกับงานวิดีโอหรือใชเรนเดอรชิ้นงานที่เปนแอนิเมชั่น

มากกวา แตก็สามารถใชกําหนดขนาดเฟรมแบบรวดเร็วใหกับการเรนเดอรแบบภาพนิ่งได เชนกัน 
 
 
ฟอรแมตไฟลภาพ  
เราสามารถระบุฟอรแมตไฟลภาพที่ตองการใหเปนเอาทพุตได โดยคลิกที่

ปุม   ในชอง Save image as ซึ่งจะปรากฏฟอรแมตไฟลรูปแบบตางๆ ใหเลือก 

ตัวอยางเชน  

• ถาเราตองการไฟลภาพสําหรับใชงานทั่วไปก็ใหเลือกไฟล Jpeg  

• ถาตองการคุณภาพไฟลสูงใหเลือก TIFF 

• ถาตองการสรางใหไฟลภาพนั้นมีอัลฟา ซึ่งเราสามารถนําไฟลภาพนั้นไป

ซอนกับภาพอื่นไดเนื่องจากจะมีพื้นที่บางสวนในภาพโปรงใสก็ใหเลือก 
Targa  

• ถาตองการไฟลสําหรับทําเว็บไซตใหเลือก Png  
 
 
 
คุณภาพของไฟลภาพ 
  นอกจากรูปแบบของไฟลที่เหมาะสมกับงานแตละรูปแบบแลว 

เรายังสามารถกําหนดคุณภาพของชิ้นงานไดที่ Quality ไดซึ่งโปรแกรมตั้งคา

มาตรฐานไวที่ 90 หรือถาเราตองการใหไดคุณภาพสูงสุด ก็ใหคลิก ที่ปุม Quality 

แลวพิมพ 100 กดคีย <Enter> ก็ได 
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คุณสมบัติเกี่ยวกับการแสดงสี 
เรายังสามารถกําหนดใหภาพที่ตองการเรนเดอรมีการแสดงสีในแบบตางๆ ได เชน 

• คลิกปุม   กําหนดใหเปนภาพขาวดํา  

• คลิกปุม   กําหนดใหเปนภาพสีแบบ RGB  

• คลิกปุม     กําหนดใหเปนภาพสีที่มีบางสวนโปรงใสเพื่อจะนําไปซอนกับภาพอื่นๆ ดวยโปรแกรมตัดตอได  
 

ในตัวอยางฉากหลังของรถเปนพื้นที่วาง ถาเรานําภาพเรนเดอรแบบ RGBA นี้ไปวางซอนกับภาพอื่นๆ เราก็จะ

พบวาสวนของฉากหลังเดิมหายไป นั้นเปนเพราะสวนของฉากหลังนั้นถูกทําใหโปรงใสโดยใชหลักการอัลฟามาสรางให

ภาพแสดงเฉพาะสวนที่ตองการ แตภาพที่เปน RGB ปกติจะไมสามารถซอนภาพโดยทําใหฉากหลักโปรงใสได 
 

 
 

ภาพแสดงความแตกตางระหวาง RGBA กับ RGB 
 

สําหรับคุณสมบัติอื่นๆ ที่เราสามารถกําหนดใหมีความพิเศษมากขึ้น ก็ใหเขามาปรับในแท็ป Render เพิ่มเติม 

เชน  
 
กําหนดเงา ถาชิ้นงานนั้นมีการจดัแสงและเงาไว ใหเราเลือกปุม  เพื่อแสดงเงานัน้ แตถาไมคลิกเลือกก็จะไมแสดง 

  คลิกเพื่อแสดงเงา 
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กอนเลือกปุม       หลังเลือกปุม  
 

Render Size เราสามารถกําหนดใหแสดงขนาดภาพเทาไหรก็ได หรือจะใหแสดง

เต็มขนาดเฟรม โดยกําหนดไดในแท็บ Format ใหเลือกคาเทากับ 100% 
 
 

 
 

แสดงขนาดภาพตอนเรนเดอร 

จากนั้นเมื่อเรากําหนดคุณสมบัติของการเรนเดอรแลว ใหเราคลิกเลือกปุม  

เพื่อทําการเรนเดอรผลงานตามคุณสมบัติที่ตั้งไว  
 

 
 
 

คลิกเพื่อเรนเดอร 
 

ถาเราตองการบันทึกไฟลภาพนิ่ง

หลังการเรนเดอร ก็ใหคลิกที่ File จากนั้น

เลือก Save Image โปรแกรมจะแสดง

รูปแบบไฟลภาพดานบนขวาตามที่เราเลือก

ฟอรแมตดังกลาวไว แลวพิมพชื่อไฟลที่

ตองการ เชน PictExample จากนั้นเลือก

โฟลเดอรที่ตองการเก็บภาพไว แลวคลิกปุม 
Save 

สุดทายเราก็จะไดภาพนิ่งซึ่งถูก
เก็บไวในโฟลเดอรที่กําหนด โดยมี
คุณสมบัติของการเรนเดอรตามที่เรากําหนด
ไวทุกประการ 

เลือก File>Save Image เพื่อบันทึกภาพที่เรนเดอร 
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และในหัวขอตอไปเราจะไดรูจักกับวิธีการเรนเดอรงานที่เปนแอนิเมชั่น เพื่อเราจะไดไฟลวิดีโอที่สามารถนําไป

เผยแพรได 
 

การเรนเดอรงานแอนิเมชัน่ 
สําหรับหัวขอนี้ เราจะเรียนรูจักวิธีการเรนเดอรชิ้นงานที่เปนแอนิเมชั่น ซึ่งเราไดเกริ่นถึงการกําหนดคุณสมบัติของ

ไฟลวิดีโอ เพื่อใชในการเรนเดอรงานแอนิเมชั่นไปบางแลว ตอมาเราไดจะทดลองเรนเดอรชิ้นงานเพื่อใหไดผลลัพธออกมา

เปนไฟลวิดีโอจริงๆ ที่สามารถนําไปตัดตอและเผยแพรได 

 
 

ดังในตัวอยางเราไดสรางชิ้นงานหนึ่งที่มีการทําแอนิเมชั่นไว เมื่อเราไดชิ้นงานที่สมบูรณตามความตองการแลว 

เราจะเขาสูการตั้งคาสําหรับการเรนเดอร โดยคลิกเมาสปุมซายที่ปุม    (Scene) แลวคลิกเลือก   (Render Button) 

จากนั้นในสวนของ Buttons Windows ก็จะแสดงคุณสมบัติสําหรับการเรนเดอรที่เราตองเขาไปกําหนด ดังนี้ 
 

 
 
 
 

 
จากภาพจะพบวาเครื่องมือและปุมตางๆ จะเหมือนกับการเรนเดอรแบบภาพนิ่ง แตจะมีสวนที่นาสนใจเพิ่มเติม

สําหรับการเรนเดอรงานแอนิเมชั่น ดังนี้ 

 แท็ป Output ในชองแรกจะเปนการกําหนดไดเร็กทอรี่ที่เราจะใชเก็บไฟลวิดีโอ โดยเมื่อคลิกที่ปุม   ในชอง 

 โปรแกรมจะแสดงไดเร็กทอรี่ปจจุบันที่เก็บไฟลนี้ และสามารถเลือกไดรวที่ตองการในปุม   

แลวเลือกโฟลเดอรสําหรับเก็บไฟล จากนั้นตั้งชื่อไฟลวิดีโอที่ตองการ เมื่อเสร็จแลวใหคลิกปุม   

 
 
 
 
 

ตั้งคาเอาทพุต  ตั้งคาการเรนเดอร ตั้งคาแอนิเมชั่น ตั้งคาฟอรแมตไฟล 
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2. เลือกไดรวสําหรับเก็บไฟล   3. ตั้งชื่อไฟล   4. คลิกปุม Select Output Pictures 
 

 
 

1. คลิกเลือกโฟลเดอรที่ตองการเก็บไฟลเอาทพุต 
 

กําหนดคุณสมบัติพิเศษในการเรนเดอร เชน ถาตองการเรนเดอรแบบ

เนนขอบภาพเหมือนการตูน ก็ใหคลิกเลือกปุม  ในแท็ป Output ซึ่งเราจะกลาวอยาง

ละเอียดในหัวขอตอไป  
 

 
 

คลิกเพื่อเรนเดอรเนนขอบภาพเหมือนการตูน 

  กําหนดคา Over Sampling เพื่อกําหนดคุณภาพของเอาทพุต โดยคลิกที่

ปุม  แลวเลือกคาที่ตองการ คาสูงสุดเทากับ 16 จะทําใหเราไดภาพที่มีคุณภาพสูง 

แตจะทําใหการเรนเดอรใชเวลานาน ดังนั้นจึงแนะใหใชคามาตรฐานที่ 8 ก็เพียงพอ   
 
 
 

กําหนดคุณภาพของเอาทพุต 
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ปุม Motion Blur หากเราคลิกที่ปุม   เราจะสามารถกําหนด

ความเบลอใหกับภาพเมื่อวัตถุมีการเคลื่อนที่   
 

 
 
 

กําหนดความเบลอใหกับการเคลื่อนไหว 
 

ในตัวอยางนี้ เปนภาพเปรียบเทียบการกําหนด Motion Blur ดวยคาตางๆ ซึ่งถาเรากําหนดคาใหมาก เชน ภาพ

นี้กําหนดเทากับ 3 เมื่อวัตถุเคลื่อนที่ก็จะมีความเบลอมาก แตถามีคานอยเราก็จะเห็นความเบลอที่ลดลงตาม และถาเราไม

กําหนดคา Motion Blur วัตถุนั้นก็จะชัดเจน ซึ่งเทคนิค Motion Blur นี้จะนิยมใชกับวัตถุที่มีการเคลื่อนไหวและตองการ

ความราบรื่น 

 
ยังไมใส Motion Blur 

 

 
ใส Motion Blur เล็กนอย   ใส Motion Blur มาก 
 

กําหนดชวงการแสดง การกําหนดชวงการแสดงของชิ้นงานที่เรา

ตองการจะเรนเดอร ทําไดโดยกําหนดในชอง Start และ End เชน ในตัวอยางเรา

กําหนดใหเริ่มตนตั้งแตเฟรมแรก หรือเฟรมที่ 1 และส้ินสุดในเฟรม 100   
 
 
 

กําหนดชวงเฟรมที่ตองการเรนเดอร 
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และสุดทายใหกําหนดขนาดเฟรมและคุณสมบัติของไฟลวิดีโอที่ตองการ ในแท็ป Format จากนั้นกําหนดฟอร

แม็ตของไฟลวิดีโอ ซึ่งมี 2 กลุมใหญๆ คือ 

  รูปแบบที่ 1 กําหนดใหเรนเดอรเปนซีเควนสไฟล  

  รูปแบบที่ 2 กําหนดใหเรนเดอรเปนไฟลวิดีโอ  

ดังวิธีการตอไปนี้ 
 

รูปแบบที่ 1 กําหนดใหเรนเดอรเปนซีเควนสไฟล 

 
การเรนเดอรเปนซีเควนสไฟล 
 

การเรนเดอรเปนซีเควนสไฟล จะทําใหเราไดภาพวิดีโอเปนภาพนิ่งเรียงตอกัน โดยแตละภาพที่โปรแกรมเรนเดอร

ออกมาคือ 1 เฟรมที่มีการเคลื่อนไหว หลังจากการเรนเดอร เราก็จะไดภาพนิ่งจํานวนเทากับเฟรมทั้งหมดในชิ้นงาน และมี

การแสดงที่เรียงตอเนื่องกัน 

วิธีเรนเดอรเปนซีเควนสไฟลสามารถทําไดโดย กําหนดฟอรตแม็ตของไฟลภาพนิ่ง เชน Tiff/ Jpeg/ Bmp/ 

Targa เปนตน จากนั้นใหคลิกปุม    
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เลือกฟอรแมตไฟลภาพนิ่งทีต่องการ 
 
 

ประโยชนของการการเรนเดอรแบบซีเควนสไฟลคือ จะชวยใหเราไดไฟลงานที่สามารถเลือกทํางานกับเฉพาะบาง

เฟรมได และนํามาตกแตงเพิ่มเติมจากโปรแกรมแตงภาพได เชน โปรแกรม Photoshop, โปรแกรม GIMP  

นอกจากนั้นในกรณีที่ชิ้นงานของเราตองใชเวลานานเนื่องจากมีจํานวนเฟรมมาก แตเครื่องคอมพิวเตอรมีปญหา

ระหวางเรนเดอร ไฟลภาพที่เรนเดอรผานไปแลวก็ยังถูกเก็บอยูในเครื่อง จากนั้นเราสามารถเรนเดอรใหมในชวงที่ขาด

หายไปได ซึ่งตางจากการเรนเดอรเปนไฟลวิดีโอ ถาเกิดเหตุการณลักษณะนี้ขึ้น ไฟลนั้นจะเสียไปทั้งไฟล ทําใหตองเรนเดอร

ใหมทั้งหมด  
 

รูปแบบที่ 2 กําหนดใหเรนเดอรเปนไฟลวิดีโอ 
เปนการเรนเดอรใหเปนไฟลภาพเคลื่อนไหว ซึ่งถูกจัดเก็บในรูปแบบไฟลวิดีโอ โดยเราจะไดไฟลผลลัพธเปนไฟล

เดียว และสามารถนําไปตัดตอดวยโปรแกรมตัดตอได  

เมื่อเราตั้งคาทั้งหมดสําหรับการเรนเดอรแลว ใหคลิกเลือกปุม   ในแท็ป Output เพื่อใหโปรแกรมนํา

ฟอรแมตที่เราเลือกทั้งหมดมากําหนดเอาทพุตใหออกมาตรงกับคาตางๆ ที่เราเลือก จากนั้นใหเราคลิกเมาสซายเลือกปุม 

  โปรแกรมก็จะทําการประมวลผลตามคารายละเอียดตางๆ ที่เรากําหนดไว 
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1. คลิกปุม      2. คลิกปุม  
 

การเรนเดอรชิ้นงานใหไดฟอรแม็ตรูปแบบตางๆ 
สําหรับหัวขอนี้ เราจะมาทําความเขาใจกับการเรนเดอรชิ้นงานใหไดฟอรแม็ตรูปแบบตางๆ ซึ่งแตละฟอรแม็ตนั้น 

ก็มีคุณสมบัติไฟลแตกตางกัน โดยถาเราสังเกตในแท็ป Format ก็จะพบวาฟอรแม็ตสําหรับการเรนเดอรนั้นมี 2 กลุม

ใหญๆ นั่นคือ ฟอรแม็ตสําหรับไฟลภาพนิ่งและฟอรแม็ตสําหรับไฟลวิดีโอหรือสําหรับช้ินงานที่มีการ แอนิเมชั่น 

 
 
 

 
 

 
  

 
 
 
 

ฟอรแม็ตสําหรับไฟลภาพนิ่ง 
สําหรับฟอรแม็ตสําหรับไฟลภาพนิ่ง มีฟอรแม็ตที่นาสนใจและใชบอยๆ มีดังนี้ 

 Targa เปนไฟลมาตรฐานที่โปรแกรมใชตั้งคาเปน Default โดยไฟลชนิดนี้จะมีคุณภาพสูง นิยมนําไปตัดตอใน

งานโทรทัศน แตไมเหมาะที่จะใชงานกับเว็บ เนื่องจากไฟลมีขนาดใหญ ซึ่งถาตองการใชภาพสําหรับเว็บไซตใหเลือกใช 

Jpeg หรือ Gif จะเหมาะสมกวา เพราะไฟลเหลานี้จะมีขนาดเล็ก แมคุณภาพของภาพจะไมละเอียดเทากับ Targa แตก็ยัง

ถือวาคุณภาพอยูในเกณฑดี 

 Targa RAW เปนไฟลแบบ Targa แตไมมีการบีบอัดไฟลใดๆ ทําใหคุณภาพไฟลสมบูรณ และมีขนาดไฟลที่

ใหญตามไปดวย 

PNG ไฟลอีกรูปแบบหนึ่งที่เหมาะสําหรับทําเว็บไซต เนื่องจากไฟลมีคุณภาพดี แตขนาดไมใหญ ใหสีสันสวย  

Bmp เปนไฟลรูปภาพมาตรฐานที่ใชงานกับระบบปฏิบัติการ Windows 

Ham X ไฟลที่เหมาะกับการเรนเดอรเพื่อดูผลงาน ซึ่งตองการดูผลงานที่

ไมตองการรายละเอียด ทําใหเรนเดอรไดเร็วขึ้น และจะเรนเดอรเปนซีเควนซเก็บไว

ฟอรแม็ตสําหรับไฟลภาพนิง่ 

ฟอรแม็ตสําหรับไฟลวดิีโอ 

คลิกเพื่อพรีวิวดูผลงาน 
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ในโฟลเดอรที่ตองการ ถาเราเลือก Output เปน Ham X ก็ใหเลือกปุม Play ในแท็ป Anim เพื่อพรีวิวดูผลงาน  

TIFF เปนไฟลที่สามารถใชไดทั้งในเครื่อง PC และ MAC มีความคมชัดและคุณภาพไฟลสูง 
 
ฟอรแม็ตสําหรับไฟลวิดีโอ 
สําหรับฟอรแม็ตสําหรับวิดีโอหรือชิ้นงานที่ตองการทําเปนไฟลแอนิเมชั่น มีฟอรแม็ต ที่นาสนใจและใชบอยๆ ดังนี้ 

 QuickTime มีนามสกุลเปน .mov เปนไฟลที่ใชเปดกับโปรแกรม QuickTime มีคุณภาพดี และขนาดไมใหญ

มาก  

AVI เปนฟอรแม็ตมาตรฐานสําหรับงานวิดีโอ มีความคมชัดสูง แตขอเสียคือไฟลมีขนาดใหญ  

ตัวอยางเราจะคลิกเลือก AVI Codec โปรแกรมจะแสดงหนาตาง Video Compression ขึ้นมา ใหเราเลือกการ

เขารหัส เพื่อบีบอัดไฟลใหเล็กลง โดยในชอง Compressor จะม ีCodec ตางๆ ใหเลือก ตัวอยางเชน 

 
 Intel IYUV Codec เปน Codec ที่ชวยบีบอัดไฟลใหขนาดลดลงไดถึง 3 เทา แตใหภาพคมชัด 

Microsoft Video 1 ใชสําหรับแสดงผลทั่วไปในระบบปฏิบัติการ Windows ซึ่งจะใหภาพแบบ 8 

และ 16 บิต ใหคุณภาพไฟลในระดับปานกลาง      

Intel Video 5.10 เปน Codec ที่สามารถบีบอัดไฟลไดมาก แตยังรักษาคุณภาพของไฟลไดดี มี

ความคมชัดใกลเคียงกับตนฉบับ และใชเวลาบีบอัดนอย 

ซึ่งถาเราเลือกใช Codec เหลานี้ในการบีบอัดไฟล เราก็จะสามารถปรับคาเพิ่มเติมไดอีก เชน ปรับคาคุณภาพ

ของวิดีโอ ในชอง Compression Quality แตถาไมตองการใช Codec ใดๆ เลย ก็ใหเลือก Full Frame 

(Uncompressed) แทน  

AVI JPEG เปนฟอรแม็ตที่ใหคุณภาพของภาพเหมือนรูปภาพฟอรแม็ต Jpeg และมีการเรนเดอรในลักษณะซีแค

วนซ แตถูกรวมรวมเปนไฟลวิดีโอ 

AVI RAW เปนการกําหนดเอาทพุตโดยไมมีการบีบอัดไฟลใดๆ เลย ทําใหไฟลผลลัพธมีคุณภาพสูง  

แตขอควรระวังกอนที่เราจะทําการเรนเดอรชิ้นงาน ใหเราคลิกปุม     เพื่อใหโปรแกรมกําหนดไฟลตาม

ฟอรแม็ตที่เราเลือกไวนั่นเอง 

การเตรยีมงานแอนิเมชั่นเพื่องานวิดีโอ 
สําหรับการเตรียมงานแอนิเมชั่นเพื่องานวิดีโอนั้น ถือเปนเรื่องสําคัญอีกเรื่องหนึ่งที่เราจําเปนตองศึกษาไว โดย

เมื่อเราไดสรางงานแอนิเมชั่นไวในวิวพอรตแลว กอนที่จะทําการเรนเดอรเพื่อใหไดไฟลสําหรับงานวิดีโอนั้น มีขอแนะนํา

ดังนี ้

เรื่องที ่1 ตรวจสอบการจัดวางวัตถุ 
ควรตรวจสอบการจัดวางวัตถุในมุมมองของกลองเสียกอน เพื่อดูวามีสวนใดของวัตถุที่หลุดไปจากกรอบของ 

Title Safe หรือไม ถามีบางสวนหลุดไปนอกกรอบก็อาจจะทําใหบางสวนนั้นขาดหายไปไดเมื่อเราเรนเดอรออกมา  
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โดยในตัวอยางนี้เราไดสรางแอนิเมชั่นของวัตถุไว จากนั้นเราจะเปดมุมมองของกลองเพื่อตรวจสอบใหวัตถุแสดง

อยูในกรอบของ Title Safe กอนที่จะทําการเรนเดอร 

 
ตรวจสอบการจัดวางวัตถุในมุมของกลองกอน 

 

เรื่องที ่2 กําหนดระบบวิดีโอตามรูปแบบงานที่จะนําไปใช 
จากนั้นใหเรากําหนดรูปแบบของวิดีโอที่ตองการเรนเดอร โดยมี 3 รูปแบบที่เราใชในงานวิดีโอดังนี้ 

ระบบ PAL เปนระบบวิดีโอที่ประเทศไทยใช มีขนาดเฟรมเทากับ 720x576 และมีคา Aspect Ratio 

เทากับ 54:51  

  ระบบ PAL อีกรูปแบบหนึ่งคือ PAL แบบ Wide Screen คลิกเลือกปุม PAL 16:9 ซึ่งมีขนาดเฟรม

เทากับ PAL ปกติ แตมีคา Aspect Ratio เทากับ 64:45 ทําใหการแสดงผลเปนแบบ Wide Screen  

  ระบบ NTSC มีขนาดเฟรมเทากับ 720x480 และมีคา Aspect Ratio เทากับ 10:11  

 
รูปแบบฟอรแมตไฟลที่เราใช 
 

เรื่องที ่3 กําหนดการสแกนภาพสําหรับโทรทัศน 
เราจําเปนตองกําหนดในสวนของ Field และ Odd ซึ่งเปนการกําหนดรูปแบบของการสแกนภาพเพื่อแสดงผลใน

จอโทรทัศน อยูในแท็ป Render 

 
กําหนดการสแกนภาพวิดโีอสําหรบัโทรทศัน 
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ซึ่งถาเราตองการสรางชิ้นงานใหเปนระบบ PAL ใหคลิกที่ Field แตถาตองการใหเปน NTSC ใหคลิกที่ Odd 

ในทางกลับกันถาเราจะตองการนําไปใชงานกับคอมพิวเตอรก็ไมจําเปนตองกดปุมใดๆ เนื่องจากการแสดงผลใน

คอมพิวเตอรนั้นไมมีการสแกนภาพ 
จากนั้นทดลองเรนเดอรโดยกดแปน <F12> จะเห็นวาผลลัพธทีไ่ดนัน้มีเสนเบลออยู เนื่องจากการแสดงผลขณะนี้เรามองจาก
จอคอมพิวเตอร แตถาเรานําไปแสดงผลในจอโทรทัศนก็จะสามารถมองเห็นไดชัดเจน 

 ตัวอยางการเรนเดอรในระบบ PAL จะเกิดเสนเบลอในจอคอมพิวเตอร 
 

แนะนําเทคนคิสรางภาพออกมาเปนลายเสนการตูน 
สําหรับเทคนิคการเรนเดอรที่นาสนใจในที่นี้ จะขอแนะนําวิธีการเรนเดอรใหไดลายเสนแบบการตูน โดยอาศัย

โมเดล 3 มิติเปนโครงรางของลายเสนนั้น ดังในตัวอยาง เราไดเตรียมวัตถุหนาลิงไว โดยกําหนดใหมุมกลองสงมายังบริเวณ

หนาของลิง  

 
กอนกําหนดใหมีการเรนเดอรเปนลายเสนการตูน  หลังกําหนดใหมีการเรนเดอรเปนลายเสนการตูน 
 

สําหรับวิธีการเรนเดอรเปนลายเสนการตูนนั้น จะมีขั้นตอนหลักๆ ในการทํางาน ดังนี้ 

  ขั้นตอนที ่1 ซอนพื้นผิวของวัตถุ  

  ขั้นตอนที ่2 เรนเดอรแบบเนนเสนขอบ 

  ขั้นตอนที ่3 ปรับแตงการแสดงผลเสนขอบ 
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ซอนพื้นผิวของวตัถุ          เรนเดอรแบบเนนเสนขอบ                ปรับแตงการแสดงผลเสนขอบ 
 

ขั้นตอนที่ 1 ซอนพื้นผิวของวัตถุ 
กอนที่เราจะเรนเดอรวัตถุนี้ใหกลายเปนลายเสน เราจะตองเตรียมวัตถุสําหรับการเรนเดอรครั้งนี้กอน โดยเรา

จําเปนตองสรางใหวัตถุมีความโปรงใส เพื่อใหการเรนเดอรนั้นไมสามารถมองเห็นพื้นผิวของวัตถุได ทั้งนี้เนื่องจากเราไม

ตองการใหแสดงพื้นผิววัตถุ แตตองการแสดงเพียงเสนขอบของวัตถุเทานั้น สามารถทําไดดังนี้ 

1. คลิกเลือกปุม   Shading หรือกดคีย <F5>  

2. จากนั้นใหคลิกปุม   ในแท็ป Material โปรแกรมจะเขาสูการสรางพื้นผิวชนิดใหม  

3. ในสวนนี้เราจะเปลี่ยนชื่อพื้นผิวนี้ใหม โดยคลิกเมาสในชองสําหรับใสชื่อพื้นผิว แลวพิมพชื่อใหมเปน 
CartoonEdge  

4. จากนั้นปรับคา Alpha ใหกับวัตถุใหมใหเปน 0 โดยเลื่อนสไลดมาทางซาย เพื่อใหพื้นผิวนี้โปรงใส   

 
 
1. คลิกเลือก Shading 2. คลิกเพื่อสรางพื้นผิวชนดิใหม 
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3. เปลี่ยนชื่อพื้นผิว   

 
4. ปรับคาใหเปน 0 เพื่อซอนพื้นผิว 
 

เมื่อไดพื้นผิวใหมใหกับวัตถุหนาลิงแลว ใหทดลองเรนเดอรโดยกดคีย <F12> 

 
 
สังเกตวาเมื่อเราเรนเดอรแลว จะมองไมเห็นวัตถุหนาลิง นั่นก็เพราะพื้นผิวของวัตถุโปรงใสตามที่เราสรางแลว 
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ขั้นตอนที ่2 เรนเดอรแบบเนนเสนขอบ 
ตอมาเราจะเริ่มทําการตั้งคาเพื่อใหการเรนเดอรนั้นไดผลลัพธเปนลายเสนการตูน เราจะใชวิธีดังตอไปนี ้

1. เขาสูการเรนเดอรโดยคลิกเลือกปุม   (Scene) และเลือกปุม          

2. จากนั้นคลิกที่ปุม   (Edge) ในแท็ป Output เพื่อเรียกใชคุณสมบัติการแสดงเสนขอบเปนลายเสน

การตูน  
 

 
 

2. คลิกเพื่อเนนเสนขอบ   1. เขาสูการเรนเดอร 
 

  ตอจากนั้นใหเรากดคีย <F12> เพื่อทดลองเรนเดอรชิ้นงาน  

 ผลลัพทจาการเรนเดอร 
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หลังจากที่เราเรนเดอรแลววัตถุหนาลิงจะปรากฏขึ้นมา โดยเห็นเปนโครงรางลายเสนการตูนที่มีขอบเปนสีดํา   
 

ขั้นตอนที ่3 ปรับแตงการแสดงผลเสนขอบ 
หลังจากที่เราไดเสนขอบสีดําแสดงขึ้นมาแลว สังเกตวาเรายังมองไมเห็นรายละเอียดของหนาลิงเทาไหรนัก 

ดังนั้นเราจึงปรับรายละเอียดสําหรับการเรนเดอรนี้ ใหลายเสนนั้นชัดเจนขึ้นและมีสีสันเพิ่มขึ้นโดย 

1. คลิกที่ปุม   (Edge Setting) โปรแกรมจะแสดงปอบอัพขึ้นมา 

2. ในพื้นที่สีนั้น เราสามารถกําหนดสีใหกับเสนขอบได โดยคลิกเมาสปุมซายที่พื้นที่สี จากนั้นคลิกเมาสปุมซาย

บริเวณสีที่ตองการอีกครั้ง  

นอกจากนั้นเรายังสามารถเลือกสีไดจากแถบสไลด RGB เพื่อกําหนดสีจากการผสมสีของทั้ง 3 สี นั้นคือ สีแดง สี

เขียว และสีน้ําเงินนี้  
 

 
 

คลิกเพื่อตั้งคาเสนขอบ 
 

 สีของเสนขอบเปลี่ยนไป 
 

เมื่อเรนเดอรแลว จะพบวาสีของเสนขอบนั้นเปลี่ยนจากสีดําเปนสีที่เราเลือกแลว  
 

2. สําหรับคาตอมาคือคา Edge Intensity ใชปรับคาความสวางของเสนขอบ ซึ่งคาสูงสุดนั้นคือ 255  ในที่นี้เราจะ

เลือกใชคาสูงสุดสําหรับช้ินงานนี้ โดยพิมพคา 255 ลงไปในชอง Edge Intensity จากนั้นทดลองเรนเดอร 

 
คลิกเพือ่ปรับ Edge Intensity 
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 หลังจากปรับ Edge Intensity แลว 
 

จะเห็นไดวา การปรับใหคา edge intensity มีคาสูงนั้น ความสวางของเสนก็จะยิ่งสวางมากตาม และเปนผลให

มีการกระจายไปถึงสวนรอบขางเสนขอบหลักดวย  

สําหรับการสรางลายเสนการตูนนั้น จะใหออกมาสวยและเห็นไดชัดเจน หรือใหจางและเปนลวดลายสเก็ต ก็

ขึ้นอยูกับความเหมาะสมในการปรับคารายละเอียดดังกลาว และความตองการสรางชิ้นงานใหเปนไปตามที่ออกแบบไว

ดวย 
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